


Tools and utilities
in free software
David Megías Jiménez (coordinator)
Jordi Mas (coordinator)
Ana-Elena Guerrero Roldán (coordinator)
Jesús Corrius i Llavina
 
PID_00148378



GNUFDL • PID_00148378 Tools and utilities in free soft\⤀ᨀࠀ

David Megías Jiménez Jordi Mas Ana-Elena Guerrero Roldán

Degree in IT engineering from the
UAB (Autonomous University of
Barcelona). Master's degree in ad-
vanced process automation tech-
niques from the UAB. Doctorate in
IT from the UAB. Lecturer in IT, Mul-
timedia and Telecommunication
Studies at the UO\⠀Ḁ

Soft\⤀ᨀࠀ engineer at the open
source company Ximian, \⤀ᄀࠀ he
\⤀ࠀ⬀ᜀ on the implementation of
the free soft\⤀ᨀࠀ project Mono. He
\⤀ࠀ⬀ᜀ as a volunteer on the devel-
opment of the Abi\⤀ࠀ℀ \⤀ࠀ℀ pro-
cessor and on the engineering of
the \⠀ᨀကᨀᰀᨀ versions of the Mozil-
la and Gnome project. He is also
general coordinator of Softcatalà.
He \⤀ᨀᜀ \⤀⬀ࠀ℀ as a consultant for
companies such as Menta, Telépolis,
Vodafone, Lotus, eresMas, Amena
and Terra España.

Ana-Elena has a degree in pedagogy
from the Ramon Llull University. She
specialised at the Ramon Llull Uni-
versity in online learning and on the
conceptualisation and creation of
multimedia learning materials for
the Universitat Oberta de \⠀ᨀကᨀᰀᘀᤀᨀ─
and on the study of the influence of
I\⠀ఀᜀ on education. She lectures in
IT, Multimedia and Telecommunica-
tion Studies at the UO\⠀Ḁ

Jesús Corrius i Llavina

Jesús holds a degree in Informa-
tion Sciences and is a computer
programmer. He has taken part in
the localisation and engineering of
a range of free soft\⤀ᨀࠀ projects,
including the \⠀ᨀကᨀᰀᨀ version of
OpenOffice.org.

First edition: September 2009
© Jesús Corrius i Llavina, Ana-Elena Guerrero Roldán, Jordi Mas, David Megías Jiménez
All rights are reserved
© of this edition, FUOC, 2009
Av. Tibidabo, 39-43, 08035 Barcelona
Design: Manel Andreu
Publishing: Eureca Media, SL

Copyright © 2010, FUOC. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free
Documentation License, Version 1.2 or any \⠀ᰀഀ᠀ऀ \⤀᠀ऀᨀᬀ pub\⠀ᨀఀ᠀ᴀ by the Free Software Foundation; with no In\⤀ᰀऀᰀᬀഀ Sections,
no Front-Co\⤀᠀ऀ Texts, and no Back-Co\⤀᠀ऀ Texts. A copy of the \⠀Ḁ᠀ᬀᨀ᠀ is inc\⠀ ᴀ᠀ᴀ in the section entit\⠀᠀ᴀ "GNU Free Documentation
License"



Software has become a strategic societal resource in the last few decades. 
e emergence of Free Software, which has entered in major sectors of 
the ICT market, is drastically changing the economics of software 
development and usage. Free Software – sometimes also referred to as 
“Open Source” or “Libre Software” – can be used, studied, copied, 
modified and distributed freely. It offers the freedom to learn and to 
teach without engaging in dependencies on any single technology 
provider. ese freedoms are considered a fundamental precondition for 
sustainable development and an inclusive information society.

Although there is a growing interest in free technologies (Free Software 
and Open Standards), still a limited number of people have sufficient 
knowledge and expertise in these fields. e FTA attempts to respond to 
this demand.

Introduction to the FTA
e Free Technology Academy (FTA) is a joint initiative from several 
educational institutes in various countries. It aims to contribute to a 
society that permits all users to study, participate and build upon existing 
knowledge without restrictions.

What does the FTA offer?
e Academy offers an online master level programme with course 
modules about Free Technologies. Learners can choose to enrol in an 
individual course or register for the whole programme. Tuition takes 
place online in the FTA virtual campus and is performed by teaching 
staff from the partner universities. Credits obtained in the FTA 
programme are recognised by these universities.

Who is behind the FTA?
e FTA was initiated in 2008 supported by the Life Long Learning 
Programme (LLP) of the European Commission, under the coordination 
of the Free Knowledge Institute and in partnership with three european 
universities: Open Universiteit Nederland (e Netherlands), Universitat
Oberta de Catalunya (Spain) and University of Agder (Norway).

For who is the FTA?
e Free Technology Academy is specially oriented to IT professionals, 
educators, students and decision makers.

What about the licensing?
All learning materials used in and developed by the FTA are Open 
Educational Resources, published under copyleft free licenses that allow 
them to be freely used, modified and redistributed. Similarly, the 
software used in the FTA virtual campus is Free Software and is built 
upon an Open Standards framework.

Preface
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Introduction

The term free�software refers not only to software that enables users to freely

run programs but also to that which allows source code access, adaptation of

the latter to user needs, distribution of copies of the software to others and

the publication of new versions of this software.

When we talk about free software, we often think of applications in text mode

that are run on servers, but the movement also offers a wide range of utilities

for the average desktop user.

This tools and utilities course will introduce students to some of the programs

designed for the desktop environments of end users. We can use these pro-

grams to browse the Internet securely (Mozilla), manage our e-mail and work

in groups (Ximian Evolution) and to create Microsoft-Office style text docu-

ments, spreadsheets and presentations (OpenOffice.org).

On this course, students will also discover how to work with these free tools in

proprietary environments such as Microsoft Windows, as well as GNU/Linux

of course.

The course contents are organised into two main parts. The first, which cov-

ers Units 1 and 2, deals with Internet tools, while the second focuses on the

OpenOffice.org program, which needs more units due to its complexity.
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Objectives

At the end of this subject, students should have:

1. Witnessed the advantages of free tools in terms of cost, security and fea-

tures.

2. Learned how to use tools in environments such as Windows and GNU/

Linux.

3. Discovered how these utilities can replace their proprietary equivalents

without a loss of productivity.
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Glossary

cookie  /  Small text file stored by the browser on our computer when request-

ed by an Internet server.

Javascript  /  Programming language interpreted by our browser used to cre-

ate websites with advanced features.

plug-in  /  Small program integrated into the browser that adds further func-

tionality.

SSL  /  Open protocol allowing secure communication between the browser

and a web server.
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GNU Free Documentation License

GNU Free Documentation License

Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation,

Inc. 59 Temple Place, Suite 330, Boston, MA 021111307 USA

Everyone is permitted to copy and distribute verbatim copies

of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional

and useful document "free" in the sense of freedom: to assure everyone the

effective freedom to copy and redistribute it, with or without modifying it,

either commercially or noncommercially. Secondarily, this License preserves

for the author and publisher a way to get credit for their work, while not being

considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the

document must themselves be free in the same sense. It complements the

GNU General Public License, which is a copyleft license designed for free soft-

ware.

We have designed this License in order to use it for manuals for free software,

because free software needs free documentation: a free program should come

with manuals providing the same freedoms that the software does. But this

License is not limited to software manuals; it can be used for any textual work,

regardless of subject matter or whether it is published as a printed book. We

recommend this License principally for works whose purpose is instruction

or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that con-

tains a notice placed by the copyright holder saying it can be distributed un-

der the terms of this License. Such a notice grants a worldwide, royaltyfree

license, unlimited in duration, to use that work under the conditions stated

herein. The "Document", below, refers to any such manual or work. Any mem-

ber of the public is a licensee, and is addressed as "you". You accept the license

if you copy, modify or distribute the work in a way requiring permission un-

der copyright law.
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A "Modified Version" of the Document means any work containing the Doc-

ument or a portion of it, either copied verbatim, or with modifications and/or

translated into another language.

A "Secondary Section" is a named appendix or a frontmatter section of the

Document that deals exclusively with the relationship of the publishers or au-

thors of the Document to the Document's overall subject (or to related mat-

ters) and contains nothing that could fall directly within that overall subject.

(Thus, if the Document is in part a textbook of mathematics, a Secondary Sec-

tion may not explain any mathematics.) The relationship could be a matter

of historical connection with the subject or with related matters, or of legal,

commercial, philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are desig-

nated, as being those of Invariant Sections, in the notice that says that the

Document is released under this License. If a section does not fit the above

definition of Secondary then it is not allowed to be designated as Invariant.

The Document may contain zero Invariant Sections. If the Document does

not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as

FrontCover Texts or BackCover Texts, in the notice that says that the Doc-

ument is released under this License. A FrontCover Text may be at most 5

words, and a BackCover Text may be at most 25 words.

A "Transparent" copy of the Document means a machinereadable copy, rep-

resented in a format whose specification is available to the general public, that

is suitable for revising the document straightforwardly with generic text edi-

tors or (for images composed of pixels) generic paint programs or (for draw-

ings) some widely available drawing editor, and that is suitable for input to

text formatters or for automatic translation to a variety of formats suitable for

input to text formatters. A copy made in an otherwise Transparent file format

whose markup, or absence of markup, has been arranged to thwart or discour-

age subsequent modification by readers is not Transparent.

An image format is not Transparent if used for any substantial amount of text.

A copy that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII with-

out markup, Texinfo input format, LaTeX input format, SGML or XML using

a publicly available DTD, and standardconforming simple HTML, PostScript

or PDF designed for human modification. Examples of transparent image for-

mats include PNG, XCF and JPG. Opaque formats include proprietary formats

that can be read and edited only by proprietary word processors, SGML or
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XML for which the DTD and/or processing tools are not generally available,

and the machinegenerated HTML, PostScript or PDF produced by some word

processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such fol-

lowing pages as are needed to hold, legibly, the material this License requires

to appear in the title page. For works in formats which do not have any title

page as such, "Title Page" means the text near the most prominent appearance

of the work's title, preceding the beginning of the body of the text.

A section "Entitled XYZ" means a named subunit of the Document whose

title either is precisely XYZ or contains XYZ in parentheses following text

that translates XYZ in another language. (Here XYZ stands for a specific sec-

tion name mentioned below, such as "Acknowledgements", "Dedications",

"Endorsements", or "History".) To "Preserve the Title" of such a section when

you modify the Document means that it remains a section "Entitled XYZ" ac-

cording to this definition.

The Document may include Warranty Disclaimers next to the notice which

states that this License applies to the Document. These Warranty Disclaimers

are considered to be included by reference in this License, but only as regards

disclaiming warranties: any other implication that these Warranty Disclaimers

may have is void and has no effect on the meaning of this License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commer-

cially or noncommercially, provided that this License, the copyright notices,

and the license notice saying this License applies to the Document are repro-

duced in all copies, and that you add no other conditions whatsoever to those

of this License. You may not use technical measures to obstruct or control

the reading or further copying of the copies you make or distribute. However,

you may accept compensation in exchange for copies. If you distribute a large

enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you

may publicly display copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed

covers) of the Document, numbering more than 100, and the Document's

license notice requires Cover Texts, you must enclose the copies in covers that

carry, clearly and legibly, all these Cover Texts: FrontCover Texts on the front

cover, and BackCover Texts on the back cover. Both covers must also clearly
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and legibly identify you as the publisher of these copies. The front cover must

present the full title with all words of the title equally prominent and visible.

You may add other material on the covers in addition.

Copying with changes limited to the covers, as long as they preserve the title of

the Document and satisfy these conditions, can be treated as verbatim copying

in other respects.

If the required texts for either cover are too voluminous to fit legibly, you

should put the first ones listed (as many as fit reasonably) on the actual cover,

and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering

more than 100, you must either include a machinereadable Transparent

copy along with each Opaque copy, or state in or with each Opaque copy

a computernetwork location from which the general networkusing public

has access to download using publicstandard network protocols a complete

Transparent copy of the Document, free of added material.

If you use the latter option, you must take reasonably prudent steps, when you

begin distribution of Opaque copies in quantity, to ensure that this Transpar-

ent copy will remain thus accessible at the stated location until at least one

year after the last time you distribute an Opaque copy (directly or through

your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document

well before redistributing any large number of copies, to give them a chance

to provide you with an updated version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the

conditions of sections 2 and 3 above, provided that you release the Modified

Version under precisely this License, with the Modified Version filling the role

of the Document, thus licensing distribution and modification of the Modi-

fied Version to whoever possesses a copy of it. In addition, you must do these

things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that

of the Document, and from those of previous versions (which should, if there

were any, be listed in the History section of the Document). You may use the

same title as a previous version if the original publisher of that version gives

permission.
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B. List on the Title Page, as authors, one or more persons or entities responsible

for authorship of the modifications in the Modified Version, together with at

least five of the principal authors of the Document (all of its principal authors,

if it has fewer than five), unless they release you from this requirement.

C. State on the Title page the name of the publisher of the Modified Version,

as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the

other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the

public permission to use the Modified Version under the terms of this License,

in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and re-

quired Cover Texts given in the Document's license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled "History", Preserve its Title, and add to it an

item stating at least the title, year, new authors, and publisher of the Modified

Version as given on the Title Page. If there is no section Entitled "History" in

the Document, create one stating the title, year, authors, and publisher of the

Document as given on its Title Page, then add an item describing the Modified

Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public

access to a Transparent copy of the Document, and likewise the network lo-

cations given in the Document for previous versions it was based on. These

may be placed in the "History" section. You may omit a network location for

a work that was published at least four years before the Document itself, or if

the original publisher of the version it refers to gives permission.

K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the

Title of the section, and preserve in the section all the substance and tone of

each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text

and in their titles. Section numbers or the equivalent are not considered part

of the section titles.

M. Delete any section Entitled "Endorsements". Such a section may not be

included in the Modified Version.
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N. Do not retitle any existing section to be Entitled "Endorsements" or to con-

flict in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new frontmatter sections or appendices that

qualify as Secondary Sections and contain no material copied from the Doc-

ument, you may at your option designate some or all of these sections as in-

variant. To do this, add their titles to the list of Invariant Sections in the Mod-

ified Version's license notice. These titles must be distinct from any other sec-

tion titles.

You may add a section Entitled "Endorsements", provided it contains nothing

but endorsements of your Modified Version by various partiesfor example,

statements of peer review or that the text has been approved by an organiza-

tion as the authoritative definition of a standard.

You may add a passage of up to five words as a FrontCover Text, and a passage

of up to 25 words as a BackCover Text, to the end of the list of Cover Texts

in the Modified Version. Only one passage of FrontCover Text and one of

BackCover Text may be added by (or through arrangements made by) any

one entity. If the Document already includes a cover text for the same cover,

previously added by you or by arrangement made by the same entity you are

acting on behalf of, you may not add another; but you may replace the old

one, on explicit permission from the previous publisher that added the old

one.

The author(s) and publisher(s) of the Document do not by this License give

permission to use their names for publicity for or to assert or imply endorse-

ment of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this

License, under the terms defined in section 4 above for modified versions,

provided that you include in the combination all of the Invariant Sections

of all of the original documents, unmodified, and list them all as Invariant

Sections of your combined work in its license notice, and that you preserve

all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple

identical Invariant Sections may be replaced with a single copy. If there are

multiple Invariant Sections with the same name but different contents, make

the title of each such section unique by adding at the end of it, in parentheses,

the name of the original author or publisher of that section if known, or else

a unique number.
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Make the same adjustment to the section titles in the list of Invariant Sections

in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the

various original documents, forming one section Entitled "History"; likewise

combine any sections Entitled "Acknowledgements", and any sections Entitled

"Dedications". You must delete all sections Entitled "Endorsements".

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents

released under this License, and replace the individual copies of this License

in the various documents with a single copy that is included in the collection,

provided that you follow the rules of this License for verbatim copying of each

of the documents in all other respects.

You may extract a single document from such a collection, and distribute it

individually under this License, provided you insert a copy of this License into

the extracted document, and follow this License in all other respects regarding

verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and in-

dependent documents or works, in or on a volume of a storage or distribution

medium, is called an "aggregate" if the copyright resulting from the compi-

lation is not used to limit the legal rights of the compilation's users beyond

what the individual works permit.

When the Document is included in an aggregate, this License does not apply

to the other works in the aggregate which are not themselves derivative works

of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the

Document, then if the Document is less than one half of the entire aggregate,

the Document's Cover Texts may be placed on covers that bracket the Docu-

ment within the aggregate, or the electronic equivalent of covers if the Doc-

ument is in electronic form.

Otherwise they must appear on printed covers that bracket the whole aggre-

gate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute trans-

lations of the Document under the terms of section 4. Replacing Invariant Sec-

tions with translations requires special permission from their copyright hold-
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ers, but you may include translations of some or all Invariant Sections in ad-

dition to the original versions of these Invariant Sections. You may include a

translation of this License, and all the license notices in the Document, and

any Warranty Disclaimers, provided that you also include the original En-

glish version of this License and the original versions of those notices and

disclaimers. In case of a disagreement between the translation and the origi-

nal version of this License or a notice or disclaimer, the original version will

prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications",

or "History", the requirement (section 4) to Preserve its Title (section 1) will

typically require changing the actual title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as

expressly provided for under this License. Any other attempt to copy, modi-

fy, sublicense or distribute the Document is void, and will automatically ter-

minate your rights under this License. However, parties who have received

copies, or rights, from you under this License will not have their licenses ter-

minated so long as such parties remain in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU

Free Documentation License from time to time. Such new versions will be

similar in spirit to the present version, but may differ in detail to address new

problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the

Document specifies that a particular numbered version of this License "or any

later version" applies to it, you have the option of following the terms and

conditions either of that specified version or of any later version that has been

published (not as a draft) by the Free Software Foundation. If the Document

does not specify a version number of this License, you may choose any version

ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the

License in the document and put the following copyright and license notices

just after the title page:

Copyright (c) YEAR YOUR NAME.
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Permission is granted to copy, distribute and/or modify this document under

the terms of the GNU Free Documentation License, Version 1.2 or any lat-

er version published by the Free Software Foundation; with no Invariant Sec-

tions, no FrontCover Texts, and no BackCover Texts.

A copy of the license is included in the section entitled "GNU Free Documen-

tation License".

If you have Invariant Sections, FrontCover Texts and BackCover Texts, re-

place the "with...Texts." line with this:

with the Invariant Sections being LIST THEIR TITLES, with the FrontCover

Texts being LIST, and with the BackCover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combina-

tion of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recom-

mend releasing these examples in parallel under your choice of free software

license, such as the GNU General Public License, to permit their use in free

software.
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Introduction

Firefox is a very fast, lightweight, powerful and flexible Internet browser. The

program is based on the well-known Mozilla browser whose source code was

released in March 1998, although it offers many improvements over the orig-

inal product. In fact, Firefox is only based on the essence of Mozilla, the web

page layout engine called Gecko, which confers the browser its power but with

a much more modern and attractive user interface.

In its day, Netscape Communicator, the "parent" product of Mozilla, intro-

duced most of the technologies used on the Internet today, including the SSL

protocol for accessing safe sites, frames, tables, cookies and the JavaScript pro-

gramming language. The influence of this program was key to the Internet's

development.

This unit supposes that students have a basic knowledge of the Internet. It

will not explain basic browsing concepts, but it will look at how they can be

applied to this excellent tool.

We will look at the program's interface and its basic configuration, but we

will focus mainly on the privacy and security options that we consider very

important and one of the main reasons for choosing free software over pro-

prietary solutions.

The main aims of this unit are:

1) to teach students how to use the diverse web browsing features of the

Firefox program,

2) to explain how to customise these features to adapt them to students' own

needs, and

3) to configure the program correctly to make web browsing as secure as pos-

sible.
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1. Firefox installation and setup

Firefox is a very popular program that comes as standard with all modern

distributions of the GNU/Linux system. For instance, if you are using the latest

version of Red Hat, you can open the program from the panel launcher or with

the Internet > Web browser main menu option. Nevertheless, new versions

of the program are released on a regular basis so you will probably be tempted

to try a newer version of the product. We will discuss how to do this in this

section.

The first thing we will need to do is to download the original package from

the project website at http://www.mozilla.com/firefox/. You will see a link for

downloading the program on this first page. Pay attention and you will see

that there are different versions available. Unless you know exactly what you

are doing, we would advise you to download the normal version, called the

stable version, for GNU/Linux in a package with the tar.gz extension, which

you should copy to your user folder.

We will suppose that you have downloaded the firefox1.5.tar.gz file (the exact

filename will obviously be different for each new version of the program) to

your personal folder. There are a number of ways of extracting the contents

of the package and running the installation program but the one way that

is almost certain to work is to enter the following commands in a terminal

window of your system.

$ tar xvzf firefox1.5.tar.gz

A new folder entitled firefox will be created inside your personal folder.

This folder contains all of the programs and configuration files needed to run

the application in your personal home folder. This means that we can install

different versions of this program on our computer without them interfering

with the stable version that came with our GNU/Linux system.

To run the program, go to the directory created by the package you download-

ed after it was decompressed and enter the following command:

$ ./firefox &

In a few moments, the Firefox main window will appear on the screen.
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Figure 1. Firefox main window

1.1. Selecting profiles

The program may ask which profile to use the first time you run it, especially if

you had previously installed another version of Firefox. If there are no profiles,

one will be automatically created in your personal user folder.

Figure 2. Profile selection dialog box

The Firefox program uses profiles to store information such as e-mail messages,

contacts, browsing histories, browser customisations etc. If different people

are going to use the computer, it is a good idea to create a profile for each one.

If you create more than one profile, the program will ask which profile to use

every time you run it unless you tick the option in this dialog box. A green



GNUFDL • PID_00148482 9 Firefox: using and configuring the browser

arrow next to the profile name indicates that it is a profile from a previous

version of the program and needs to be migrated before it can be used. This

operation is usually automatic and the user does not need to do anything here.

On the left of the screen are the buttons for operating with the profiles. We

can create a new profile, delete an existing one or change its name. The on-

ly information we need to enter to create a new profile is the name and geo-

graphical location. The information on geographical location is used to deter-

mine the language that the program interface will be shown in if the language

package is installed.

1.2. Advanced profile features

Now that we have seen that the profiles store all of our information and con-

figurations, we need to know the actual location of this information so that

we can make backups of it. This location will depend on the operating system

we use.

In GNU/Linux, profiles are stored in each user's personal folder in a hidden

folder with the following path:

~/.mozilla/firefox/[random_string].[profile_name]

~/.firefox/xq9m0u3x.jesus/

Where [profile_name] is the name used to log on to the system and

[random_string] is a random string containing numbers and letters. Although

the use of a folder with a random name may seem a little strange and perhaps

even inconvenient for backing up data, it actually considerably enhances the

security of the data stored in the profile because it means that much more

complex programs are required (viruses or Trojan Horses) to extract the data

from the system.

If you use the Windows platform, the profile folder will depend on whether

you are working in 95, 98 or ME or in a NT/2000/XP system. In the first case,

the path is as follows:

%APPDATA%\Mozilla\Profiles\[profile_name]\[random_string].slt\

And for Windows NT/200/XP:

C:\Documents and Settings\[user_name]\Program files

\Mozilla\Profiles\[profile_name]\[random_string].slt\

C:\Documents and Settings\jesus\Program files\Firefox\Profiles\jesus\xvod4stn.slt
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If you cannot find the profile name for any reason, you can always search your

hard drive for the file entitled prefs.js. In Windows, you can use the search

utility, which you can launch from the "Start > Search > Files and folders..."

option in the task bar.

In GNU/Linux, you can use a similar utility to that used by Windows in the

operating environment or you can enter the following command in the ter-

minal window:

$ find . name prefs.js print

We will now take a brief look at the most important files in our profile folder.

This will be very useful if we have a problem with Firefox or simply wish to

back up certain information.

Folders

Cache Contains temporary Internet files

cert8.dir Database of digital certificates

chrome Styles defined by the user, installed themes and applications.

Files

[a_number].s Password data

[a_number].w Form data

bookmarks.HTML Bookmark data

cert7.db and cert8.db Client certificate databases

component.reg Mozilla XPCOM component registry

cookies.txt File with the cookies we have installed

cookperm.txt Data on the configuration of the cookies and image permissions

downloads.rdf Download manager data

history.dat History of visited pages

key3.db Key database

localstore.rdf Information on the status of windows, position, icons, toolbars
etc.

mimeTypes.rdf Definition of MIME types configured in Firefox

panels.rdf Customised configuration of the side panel

parent.lock If this file appears in the folder it means that the profile is currently
in use

prefs.js All of our customisations
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Files

prefs.bak Backup of the previous file

search.rdf Data on search engines

secmod.db Security module databases

URL.tbl List of websites excluded from automatic forms

user.js User configuration

This is a non-exhaustive list of the main elements found in the profile fold-

er. A full list of these files can be obtained from the following website: http:/

/gemal.dk/mozilla/files.HTML

1.3. Installing a language package

Although some versions have been fully translated into many of the world's

languages (installer included), we have chosen to install a version in English

so that we can see how to install a language package for the program. The

project website, where you can check on the status of translation projects and

download language packages, is:

http://wiki.mozilla.org/L10n:Home_Page

By way of example, we will walk you through installation of the Spanish lan-

guage package. The volunteers who translate the program into Spanish belong

to a project called Proyecto Nave. You can visit their website at:

http://nave.escomposlinux.org/.

You will find the language package in the XPI section on the download page.

You can in fact choose from a number of packages: language, which includes

translation of the user interface only; regional, which adds regional content

such as language community website links to the application, or you can opt

for the global package, which includes both of the above. For our demo, we

will select the global package.
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Figure 3. Package installation dialog box

When you click on the link to the package with the XPI extension, a dialog box

will pop up asking for permission to install it. Since we are downloading from

a reliable source, click on Install now to begin installation. The program will

be downloaded from the Internet and installed automatically. If the download

is completed correctly, a window will pop up with the instructions to follow.

Click on OK and exit Firefox by closing the program's main window. The next

time you run Firefox, the interface will be displayed in the language you chose.

You can install as many languages as you like but you can obviously use only

one at a time.

1.4. Installing plug-ins

There are now many plug-ins that are virtually essential for browsing any

modern website. The most common of these are the ones by Macromedia,

which allow us to execute Flash files, the Acrobat Reader plug-in , for viewing

documents in PDFformat, and the ever-present Sun Microsystems plug-in for

running Java programs. Unfortunately, the Firefox project cannot incorporate

these plug-ins into its program or distribute them with it because they are

proprietary applications. Obviously, GNU/Linux distributions do not usually

distribute them either for the same reasons. We will see that the installation

and configuration of these plug-ins are necessary for a completely satisfactory

web browsing experience.

We will now turn then to their installation.
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1.4.1. Installing the Java plug-in

You will find the Java virtual machine plug-in on the Sun Microsystems web-

site:

http://java.sun.com/products/plugin/

containing a link to the latest version of the product. On the page of the

latest version of the product, click on the blue Download button in the top

right-hand corner.

On the downloads page, go to the J2SE section and find the version for your

platform.

The JRE version is simply the virtual machine used to run programs in Java.

The SDK version includes programming tools besides the virtual machine. If

you are not interested in developing programs in this language you will not

need to install SDK.

The next step in the process is to accept the product installation licence. To

do this, click on "I agree" in the lower section of the licence page.

The Windows version uses Microsoft Windows Installer, so it integrates per-

fectly into the environment of this operating system.

Figure 4. Licence acceptance dialog box

The first screen we see when we run the program is the licence acceptance

dialog box. Here, you will need to read the conditions of use of the program

and tick the "I accept the terms of the license agreement" option. Click on

Next to continue.
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Figure 5. Selection of type of installation dialog box

In the selection of type of installation window, you must choose the type

of installation you require. The best option is Typical, which will install the

default components. After this, click on Next to begin installation. The time

that this takes will depend on whether you downloaded the full program or

the installer alone. If you only downloaded the installer, the program must

download the rest of the files from the Internet and this can take some time,

depending on how fast your Internet connection is.

Figure 6. Final installation dialog box

The final installation dialog box indicates that the process has concluded sat-

isfactorily. Now you simply need to restart Firefox to access all of the function-

alities of the Java environment for web browsing. When Firefox is running a

Java applet , it displays a small white icon in the system tray with the Java

programming language logo, which is a cup of coffee.
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The process is very similar on the GNU/Linux platform except that text mode

is used. We must accept the licence terms and then indicate the installation

folder. As in Windows, we cannot download the plug-inalone; we need to

download the entire environment with it. In the sections on other plug-ins

we will see how this process is carried out.

1.4.2. Installing the Macromedia Flash plug-in

If you use the Windows platform, you will need to visit the Macromedia down-

loads site. The address is http://www.macromedia.com/downloads/ Here, you

will need to select the Macromedia Flash Player option. When you click on it,

the site will detect the version of the browser you are using and a page will ap-

pear with a link where you can download an installer program for the plug-in.

Click on Download now to save the program to your hard drive. The program

takes a while to download. Once the process is complete, double-click on the

program to run it.

Figure 7. Language selection dialog box

In the first screen, you can select the language you want the installation pro-

gram to use. Select the language you require and click on OK to continue.

Figure 8. Welcome screen
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The first screen is for information purposes only. So simply click on Next.

Figure 9. Web browser selection dialog box

This screen should automatically detect that you have Firefox installed on

your system as well as the version. Otherwise, you will need to select the Other

Explorer option and manually enter the folder where the program is located.

After selecting Firefox correctly, click on Install.

Figure 10. Final installation dialog box

This screen indicates that the plug-in installation process has been complet-

ed successfully. When you close the installation application, Firefox will au-

tomatically close (be prepared for this if you need to save any information

first) and the Macromedia website will appear automatically running an ap-

plication in Flash.

If you are running GNU/Linux and wish to install the Flash plug-in , you

will need to download the web package as we saw earlier for Windows. This

time, instead of an executable, the file will be a zipped package that you

need to download to your user folder. You should then unzip and run the in-

stallation program following the example below, where the package name is

install_flash_player_7_linux.tar.gz:

# tarxvzf install_flash_player_7_linux.tar.gz

# cd install_flash_player_7_linux

# ./flashplayerinstaller
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In this case, installation will be in text mode. If you run the program as the

superuser, you can install the plug-in for all system users. If it is run with your

privileges, the plug-in will be installed in your personal profile and only you

will be able to use it. The program may prompt us to install the plug-in in the

Mozilla or Netscape folder if we have or have had these two programs installed

on the system or if we use a Mozilla-based browser (such as Galeon, Epiphany

or Firefox). In our case, we should select the Firefox folder.

1.4.3. Installing the Acrobat Reader plug-in

To download the latest version of the Acrobat Reader plug-in for viewing PDF

documents in your web browser, you will need to go to the following website:

http://www.adobe.com/products/acrobat/readstep2.HTML and select your ap-

plication language, operating platform and whether you have a broadband

connection. You can also choose whether or not to download the full prod-

uct. One of the more useful options of the full product is the possibility of

searching for text in PDF documents. As the full product option is ticked by

default, leave it as it is.

Once you have ticked and selected the required options, click on the Down-

load button to open the Firefox downloads dialog box. Either run the applica-

tion directly or save it to disk, to a location that you will be able to find easily.

When you run the program you have downloaded, Acrobat Download Man-

ager will launch and download the rest of the files needed from the Internet.

This can take a while, depending on the speed of your connection, but it will

not take as long as the Java plug-in

When all of the necessary files have been downloaded, the welcome screen

will appear.
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Figure 11. Welcome screen

The welcome screen is for information purposes only and is not important to

us. Click on Next to continue the installation process.

Figure 12. Folder selection dialog box

In this dialog box, you can select the installation folder for the application.

Unless you have a justified reason for installing it in another location, it is

always best to use the default folder. Click on Next to continue.
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Figure 13. Review of installation settings dialog box

When you reach this window, installation is ready to begin, although you still

have time to change the information you have entered before this point. To

do so, click on Back to return to the previous windows. If you are sure that all

the information is correct, simply click on Install to start copying the files.

Figure 14. Final installation dialog box

If the final installation dialog box appears, this indicates that installation was

successful and the program has been installed correctly on the system. In this

dialog box, click on the End button to exit the installation program.

If your operating platform is GNU/Linux, installation is also very similar to

the installation of Macromedia Flash Player. Firstly, download the package

from the website and decompress it to a folder. This time, a new folder will

not be created with the name of the package; you have to create it your-
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self beforehand. For instance, if the name of the file you downloaded was

AdbeRdr701_linux_enu.tar.gz, you can enter the following in a terminal win-

dow:

$ tarxvzf AdbeRdr701_linux_enu.tar.gz

$ cd AdobeReader

$ ./INSTALL

The program will display a text with the licence, which you must accept by

typing in Accept. You must then specify the installation folder. To install it

in the suggested folder for use by all system users, you must have superuser

privileges.
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2. Interface and general use of the program

The program's GUI is very similar to that of any other web browser, so you

should have no problems getting to work with it. It has a browser bar, buttons

and menus, the functions of which should be immediately familiar.

If you are used to much more complex web browsers, you will see that Fire-

fox does not include the small icons usually found in the bottom left of the

main application window, giving access to various functions. Firefox is a very

straightforward program that has no default mail manager, address book or

IRC program, but it can be built on and complemented very easily with dif-

ferent add-ons, browser bar and themes.

2.1. Themes

The program comes with a default grey theme called Firefox 2.0, but you can

use other themes to customise your browser. It is even possible to use buttons

and colours that are very similar to those of Internet Explorer. Besides the

theme that comes with Firefox, you can obtain many more from the Internet.

To change the appearance of the program, go to the Tools > Themes menu,

which will indicate the options for selecting themes.

Figure 15. Theme selection preferences dialog box
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If you have not previously downloaded a Firefox theme, you will only see the

Firefox 2.0 theme, which cannot be uninstalled. When you select a theme,

you will see how the program will look in the preview window. In the bottom

of the dialog box, you will see a Download new themes link, which will take

you to a website containing many different themes that you can use.

The system for installing new themes is very similar to installation of a lan-

guage package but in this case the files have the extension JAR instead of XPI.

An alert dialog box will appear first of all, asking whether you wish to install

the theme. The software installation dialog box will then appear on the screen,

indicating the progress of the installation. If installation is successful, you will

have a new theme in the selection dialog box.

Figure 16. Theme installation alert dialog box

Once you have selected the theme you wish to use, you must quit the appli-

cation and open it again for Firefox to adopt the new appearance.

Figure 17. Main Firefox window with a new theme



GNUFDL • PID_00148482 23 Firefox: using and configuring the browser

2.2. Bookmarks toolbar

This personal toolbar is used to save the customised addresses of websites for

easy access to them. If it is not enabled by default, you can turn it on with the

View > Toolbars > Bookmarks Toolbar menu option.

It is very useful for saving sites so that we do not need to type in the address

again. It offers the same features as Bookmarks but is much easier to use. To

add a site to the Bookmarks toolbar, simply select the address and drag it to

the toolbar.

Figure 18. Firefox Bookmarks toolbar

We are not limited to creating direct links to websites; we can also create fold-

ers to group them into different categories. To create a new folder, right-click

the toolbar and select the New Folder option. A dialog box will appear in

which you can enter the name and, if necessary, a short description.

Figure 19. Folder properties dialog box
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To add a link to a folder, drag the address to it as you did in the previous

example. To select a link from a folder, click on its name inside the folder,

which will display a drop-down list of the items that you have added to it.

2.3. The Sidebar

Although the Sidebar may initially seem a bit of a nuisance because it takes

up valuable screen space, when used properly, it can be very useful. The Side-

bar can display our downloads, bookmarks and browsing history and can be

closed by clicking the X in the top right-hand corner of the panel. To display

the Sidebar, simply select the View > Toolbars > Sidebar menu option. Repeat

this step to hide the bar again.

Figure 20. Browser window with the Sidebar

The two standard options offered by the Sidebar are bookmarks and browsing

history. The top section of the Sidebar contains a text box for quick searching

within these items and, in the case of histories, a button to arrange the data

by diverse preset criteria.

2.4. Web browsing with tabs

In other browsers, we can view more than one web page at a time if we open a

browser window for each. One of the best features of Firefox is the possibility

of Internet browsing with tabs, allowing the user to view various web pages

at a time inside the same window. To open a new tab, select the File > New

tab option from the main menu or use the Ctrl+t key combination, which is

the fastest way of opening a new tab.
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Figure 21. Browsing with tabs

You can open as many tabs as you like in a single window. However, if you

open too many, it might be difficult to work with them all so it is better to

spread them out across several windows. To switch tabs, simply click on the

tab title. If you right-click the tab title, you will see the various actions you

can perform, such as closing the tab. It is also possible to close the current tab

by clicking on the X button to the right of the tab title.

Just as we can open a link in a new window, we can open it in a new tab. To

do so, right-click the link with the mouse and select the Open in a New Tab

option from the context menu.

In Firefox 1.5, it is possible to drag tabs into the main window for better or-

ganisation. To do this, simply click on the tab title and hold down the left

mouse button as you drag the tab to the desired location.

2.5. Help

The Firefox browser free software project is one of the best for documentation.

You can access this general information from the Help > Help Contents menu

option and there is also a Help button in most windows and dialog boxes. The

Help is very thorough and you will almost certainly find the answer to your

questions here.
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Figure 22. Main Help page
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3. Basic browser configuration

We will now look at the program's configuration and customisation tools.

We will deal specifically with determining the behaviour of the browser, web

searching and the management of the different types of file we can find while

browsing the Internet. This section will deal with the basic configuration of

the program and look only at the most important options. The next section

will focus on everything that concerns web browsing security.

All of these options are grouped into a series of windows in Preferences. Those

of you who remember previous versions of Mozilla or Netscape will see that

this dialog box has been greatly simplified. To access these options, go to Tools

> Options.

Figure 23. Browser preferences window

We can customise the following options in this initial preferences window:

Home�page

In the text box, we can select or type in the page that will be shown by the

program for each of the following actions: when Firefox is launched, when a

new window is opened and when a new tab is created. This is also the page
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that will appear when you click on the Home page button. This gives us greater

flexibility when it comes to customising our browser behaviour. The available

options are as follows:

• Current�Page: If you check this option, Firefox will open at the last page

you visited. For privacy reasons, if you share your computer with other

users, it is important to check the selected page because the other users will

see the last page you visited and it may contain confidential information.

If you have more than one tab open, Firefox will open as many tabs as are

open, using their current addresses.

• Bookmarks: Here you can select a web address from your Bookmarks fold-

er to replace the page indicated as your home page in the Address text field.

Figure 24. Bookmark selection dialog box

• Blank�Page: If you check this option, the program will not display a page,

so the new window or tab will be opened instantaneously because there is

no need to wait for a page to load before you can start using the browser.

Default�browser

The button in Default browser makes Firefox the default system browser. The

following options are available here:

• Check�to�see�if�Firefox�is�the�default�browser: Every time you launch

the program, Firefox will check to see whether it is the system's default

browser. If it is not, a dialog box will appear asking you whether you wish

to make it the default browser.

• Check�Now: When you click on this button, Firefox will immediately

check to see if it is the default web browser for the system.



GNUFDL • PID_00148482 29 Firefox: using and configuring the browser

Connection

For obvious security reasons, many companies block Internet access from their

networks. This means that third parties cannot access important information

in the company network from other computers. This protection uses a proxy

server or firewall.

If your company has a firewall or your Internet provider needs one, the brows-

er may need to go through a proxy server to connect to the Internet. You can

configure this using the Settings button under Connection.

Figure 25. Internet options configuration dialog box

The options offered in this configuration dialog box are:

• No�proxy: this is the default option for the program, indicating that we

do not want to use a proxy to connect to the Internet.

• Auto-detect�proxy: If the network is configured with automatic proxy

settings (using a configuration file), we can select this option. This means

that we will not have to update the settings if the network configuration

changes.

• Manual�proxy�configuration: If there is only one proxy for connecting to

the Internet, type the address in the appropriate text box. It is also possible
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to enter a different address or port for each of the available services if

greater flexibility is required in the configuration settings.

3.1. History

Figure 26. History preferences dialog box

The history preferences dialog box is used to customise the behaviour of Fire-

fox for the pages we have visited. The following fields can be customised:

• Browsing�history

The history file contains all the addresses visited over the last few days. We

can access these from the Sidebar or by using the Ctrl+H key combination.

In the text field, you can enter the number of days you wish to keep the visited

pages for. To delete the record, click on Clear history.

• Address�bar�history

The address bar also has a minihistory of the last pages visited, although it

is much less exhaustive than the main history. However, as you start to write

a website address in the address bar, Firefox will display the last pages visited

that match the address you are typing. So, if you always visit the same pages,

this feature offers very easy access to them. To visit one of the suggested pages,

click on the address in the drop-down list.
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The Clear addresses button is used to delete this history so that the above

suggestions are not displayed.

3.2. Languages

Figure 27. Language preferences dialog box

The next section, Languages, is used to select the language in which you would

like websites to appear, when a site offers versions in different languages. The

websites of leading companies normally have these features. If the page is only

available in one language, these options will have no effect.

• Languages�for�websites

By default, the program uses US English. If you want to enable more languages,

click on the Add button. This action will open a dialog box in which you can

select your preferred language, or you can enter its ISO code in the text field.

The languages are organised by order of preference, so, for example, if you

want websites to be displayed in Spanish first and then English, select Spanish

and move it to the top using the Move Up button on the right-hand side of

the dialog box.

• Character�encoding

Character encoding determines text decoding. In general, the default encod-

ing will be correct and it will not need to be changed. This is the place to go

when, for instance, certain letters appear as question marks or funny symbols

as this tells us that the character set is incorrect.

To change the default browser character encoding, go to Tools > Options >

Content > Font and Colours > Advanced and select the default encoding.
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Figure 28. Dialog box for default encoding selection

3.3. Accessory applications

Figure 29. Dialog box with the accessory application preferences

In this dialog box, you can specify the accessory applications. We can come

across several file formats on the Internet that Firefox cannot open alone, such

as audio tracks in mp3 format or video files. In these cases, the program calls

up accessory applications, which display or run these files for us.

There is normally no need to change any of the options in this window be-

cause the program will prompt you to indicate which program you wish to

use to open a file in an unfamiliar format to Firefox. However, it can be useful

if you want to enter new formats to be automatically opened without being

prompted or, more importantly, if you have made a mistake. Imagine that you
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want to open an audio file and mistakenly tell the program to use the system

notebook (for instance, gEdit) to open it. From this point on, Firefox will al-

ways open this type of audio file with the selected program. You can change

this behaviour in this setup window.

To change an existing type, first select it and then click on Edit. A dialog box

will appear with a number of fields, as shown below:

Figure 30. File type editing dialog box

The features of the file type are displayed in the upper part of the window.

Each has a specific MIME.

MIME is the abbreviation for Multipurpose�Internet�Mail�Extensions and is

a standard for displaying e-mail message content. For example: text/plain for

text or image/jpeg for a JPEG image.

There are websites on the Internet with lists of all available MIME types. To

create a new type, you will need to consult these lists to find out which type

corresponds to the extension. However, this is a very advanced topic that will

not be dealt with in this module.

Click on the Change Action button to specify the default behaviour of the

browser when you have one of these files. A new dialog box will open with

a list of options:
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Figure 31. 'Change Action' dialog box

• Open�using�the�default�application

If you select this option, the file will be opened with the default system appli-

cation. Thus, it would open in the same way if, for example, you clicked on

it while using Nautilus.

• Open�with

If you want Firefox to open the file in another application not included by

default in the system, click on Select to find the path for the application you

wish to use.

• Save�to�disk

If you select this option, the file will be downloaded to your user folder and

you will have to open it manually.

• Always�ask�for�files�of�this�type

If this option is checked, the program will always ask which action to take

regardless of what was entered in the previous fields.
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3.4. Tabs

Figure 32. Tab preferences dialog box

We have already looked at basic tab browsing. In this dialog box, we will see

how to configure some of its features. At the top of the dialog box, we see that

the options for opening an external link from another program using Firefox

as the default browser are:

• A�new�window: The external browser link will open in a new window.

• A�tab�in�the�current window: The external link that we clicked on will

open in a new tab in our window and will be automatically added to the

existing tabs.

• Current�window/tab: The web contents of the external link will replace

the contents of our current window or tab, meaning that the previous

contents of the browser window will be lost.

This window also offers advanced user options. Let's look to these individually:

• Force�links�that�open�in�a�new�window�to�open�in: This option enables

us to change the default behaviour of windows that open in a new window

when we click on them on a web page. When this option is checked, we

can indicate whether these windows should open in the current window

or in a new tab rather than a new Firefox window.
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• Hide�the�tab�bar�when�there�is�only�one�tab�in�the�window: When this

option is checked, the tab bar disappears when the window only has one

tab open. This is the default behaviour of the tab bar.

• Select�new�tabs�opened�from�links: If this option is selected, Firefox will

change the new tabs opened from links into active tabs. If this option is

not marked, the active tab will always be the current one when we open

a new tab from a link.

• Warn�me�when�closing�multiple�tabs: If you try to close a window con-

taining more than one open tab, Firefox will display a warning message.

Figure 33. Warning message when closing a window with multiple tabs.

3.5. Downloads

Figure 34. Downloads preferences dialog box

The downloads dialog box can be used to customise the behaviour of Firefox

when downloading programs from the Internet.

There are three options for this feature:
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• Download�folder

We can tell Firefox to either always save our Internet downloads to the same

folder (user desktop by default) or to ask us each time where to save the file

being downloaded.

• Open�download�manager

If you mark this option, the download manager will appear when download-

ing begins. The download manager can be used to pause and restart a down-

load in the same session provided that the server supports this.

• Download�actions

Here, Firefox can be configured to perform a specific action after downloading

a given type of Internet file. This is a very convenient option but we need to be

very cautious with it (particularly if we are Windows users) because some file

types can be Trojan Horses or viruses that can put the security of our system

at risk.

3.6. Advanced

Figure 35. Advanced preferences dialog box

The advanced preferences dialog box has a number of tabs with different func-

tions covering three broad areas: General, Updates and Security. We will now

look briefly at each of these areas.
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• General

This section is used to customise accessibility, browsing and language pref-

erences. The accessibility options, designed particularly for individuals with

some form of disability, allow us to select text using the keyboard instead of

the mouse and to automatically perform text searches in a page when we start

typing, without the need to tell it to do so first.

The configurable browsing options are used to indicate whether to adjust

images displayed in the browser to fit the screen and the different types of

scrolling to use for navigating around the window contents. Finally, the lan-

guage selection section is used for selecting website languages, which we dealt

with in detail earlier.

• Updates

The updates tab is used to configure diverse aspects of Firefox updates, which

are installed automatically by default. It is a good idea to leave this as auto-

matic because it will install all program security updates without the need for

user intervention. This means that we will always be protected.

Figure 36. Advanced update preferences dialog box

• Security
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Figure 37. Advanced security preferences dialog box

The advanced security preferences allow us to indicate the secure web proto-

cols we wish to use while browsing the Internet and to operate with our secu-

rity certificates. We will deal with all this in the next section, which discusses

how to configure Firefox for the most secure browsing experience.
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4. Privacy and security in Firefox

This is an important aspect that needs to be taken into consideration when

choosing a common tool for Internet use. Browsers have become essential

tools of any computer environment. However, they are also one of the biggest

threats to user security and privacy.

Firefox is generally a very secure web browser, both in GNU/Linux and in

proprietary environments like Windows. Rather than list the technical details

of its security features or dwell on the astounding loopholes detected in Mi-

crosoft products in the past, we would do well to note that computer "pirates"

mainly seek out holes in common products and that the vast majority of users

currently use Internet Explorer and Outlook.

The default configuration of the program shows how all of these aspects have

been taken into account. We need to be aware that absolute security does not

exist and the ultimate responsibility for this lies with the user. This section

will look at the security features and options of Firefox.

4.1. Cookies

Of all of the elements affecting privacy, cookies are usually the biggest concern

for users. Cookies do not pose security risks because they are simply small text

files containing information. In most cases, they actually make web browsing

easier for users because they remember the pages we have visited, the options

we have chosen etc. For example, if we are registered users of the Amazon

site, cookies remember who we are so that, every time we connect to the site,

we are given tailored information on offers based on our tastes and hobbies.

However, cookies also allow companies to compile statistics on how we use

the Internet and what pages we visit, without our knowing it.

We can access the program's cookie options through the Tools > Options...

> Privacy > Cookies menu option.
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Figure 38. Cookie preferences dialog box

For ease of browsing, we will need to accept cookies on all websites. If we do

not, we might not be able to access all of their features or enter certain sections.

For increased security, we can check the Accept cookies option, which will

generate a dialog box asking whether or not we want to accept the cookie in

question.

Figure 39. Cookie acceptance dialog box

If you think the asking option will work best for you, check the Use this option

for all cookies on the site option so that the program asks us just once for each

website we visit.

The program offers different options for the use of cookies , depending on our

browsing needs and habits. A foolproof way of visiting websites without being

asked anything is to uncheck the "Warn me before accepting a cookie" option

and to check Limit maximum life of cookies to:  current session. This means

that our system will accept cookies and store them on our hard drive but that

they will all be deleted when we close the program. This will ensure access to

all websites but the data will only be saved for the current browsing session.
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Although they may be useful to some users, it is not generally a good idea to

use the Only accept cookies originating from the same server as the page being

viewed and Enable cookies based on privacy settings options because they are

affected by factors that we cannot always control. These properties can allow

access to most websites but this may not always be the case. It is best to use

one of the options described at the start.

If you are an advanced user or simply prefer only certain sites to store your

data (for example, an Internet banking site where you have an account), you

can use the cookies. If you are visiting a site where you want to block or allow

the use of cookies, simply select the relevant option from the Tasks > Cookie

manager main menu option.

For a more advanced setup, you will need to access the cookie manager per se,

either by clicking on the Show cookies button in the preferences screen or by

using the menu option: Tasks > Cookie Manager > Manage stored cookies.

Figure 40. Firefox Cookie Manager dialog box

This window is used for very detailed customisation of the cookies we wish

to keep on our computer.

4.2. Images and banners

Another of the program's features is that it allows us to block advertising im-

ages in the Options menu, although it is not directly available through the

Security section. You can access these settings from the Tools > Options... >

Content menu option.
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Figure 41. Content options dialog box

We will now look at the available options.

• Display�images

As one might well imagine, unchecking the Display images option blocks all

graphic content from the Internet. To display images, you will need to right-

click on the frame of the same name and select the Display image option.

You can use this feature to browse in text mode. However, in this day and

age, there can be no doubt that the best option for surfing the Internet is

Display images, as this will allow us to view all graphics without restrictions.

The alternative option of displaying only images originating from the server

can be very effective if we wish to avoid displaying advertising banners but

some servers, particularly those with a great demand for pages, store copies of

images on other servers. This means that we would be unable to view them

automatically. Later on, we will see how to block images from specific servers.

• Only�display�images�from�the�original�server

Although we will not dwell here on the e-mail program, this is a very impor-

tant option because it redirects a lot of junk mail. If you use Thunderbird to

read your e-mail, it is almost essential to check this option because many junk

mail messages are written in HTML format. In this format, invisible one-pixel

images can be incorporated that contain identifiers for our e-mail address. If

we open the message and the remote image is loaded, the person sending us
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the message knows that the e-mail address is correct and that we have read the

message, meaning that we will receive more junk mail. This option only blocks

remote images; it does not block images on the page that we have opened.

Recently, there has been a rise in the number of viruses and Trojan Horses that

use images as their method of propagation and we are at even greater risk if we

use Windows. It is therefore important to mark this option in web browsers

too, rather than just in e-mail programs.

As these rules are very general and we probably require much greater image

blocking flexibility, Firefox gives us a tool to customise all of this. To access

the Image Manager, click on the Exceptions button to modify image blocking

for specific websites.

Figure 42. Firefox Image Manager dialog box

The Image Manager lists the websites for which the program will load images.

To delete a site from the list, highlight the name and click on the Delete site

button.

The quickest way of blocking all images from a given server is to right-click

the mouse on one of its images and select the following option : Block Images

from this server.

Bear in mind though that this will block the entire domain. For example, if we

block images from a personal page in the www.geocities.com domain, we will

effectively block all images from this domain and we probably do not want to

do so. On the other hand, we will often find that advertising images always
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come from the same domain and this feature will prove very useful in this

respect. To quickly block images from a server, simply right-click an image and

select Unblock Images from this Server.

4.3. Popups

Popup windows are probably one of the most irritating items that Internet

users come across while browsing. The worst offenders are those that appear

when we close a window. This section will cover the Firefox tools designed

to rid you of these nightmares. Obviously, there may be new techniques for

opening pop-ups that Mozilla still cannot block. You can display the program

options using the Tools > Options... > Content menu option.

Figure 43. Content options dialog box

In this dialog box, select the Block popup windows option (the default config-

uration in the program). This will enable popup blocking and automatically

notify the user when the program is blocking a popup. This is important as

Firefox may block popups that are not advertising. Some websites use them to

gain users or to allow programs to be downloaded from other servers. If you

are on a site and click on a link where something should happen and nothing

does, check the Firefox bar to see whether it has blocked a popup. If this is

the case, an icon with an exclamation mark on an orange background will

appear in the bottom right of the window. If you double-click this icon, the

program's Popup Window Manager will launch and you can add the site to

those allowed to use popups. All popup windows are blocked by default so

you will need to specify exactly when you want a site to display popups.
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Figure 44. Popup Manager dialog box

After giving permission, you will need to load the page again for the new

properties to take effect.

4.4. Passwords

The use of passwords to access certain Internet services or content (for in-

stance, newspaper content or free e-mail accounts) is increasingly common.

If, as recommended, we use a different password for each one, we may find

it difficult to remember them all. However, it is more risky to use the same

password for all of them because if it falls into the hands of a malicious user,

they could use it to access all of our data.

If you are going to have problems memorising them all, you can use the Firefox

Password Manager. To enable this option, go back to the program's preferences

dialog box. The path is: Tools > Options... > Security > Passwords.
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Figure 45. Passwords preferences dialog box

If you want the program to save the passwords, you will need to check the

Remember passwords option. By default, Firefox uses encryption to store con-

fidential information in order to enhance password security. As a result, you

will need a master password to access the data. We will look at this now.

Firstly, you must go to the Master Password dialog box. If you are in Password

Preferences, simply click on the Master Password button to the right of the

window.

Figure 46. Master Password preferences dialog box
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Once inside this window, click on the Change Master Password button, which

will open a dialog box where you can enter your password. One very useful

feature of this dialog box is the password quality meter, which indicates the

reliability of our password.

Figure 47. Master Password dialog box

There are a few basic rules to bear in mind when choosing a password. The

first is that it should be easy to remember. The second is that we should not

use words that can be easily related to us (such as our own date of birth or the

name of our dog). It is important to use a combination of letters, numbers and

symbols. When these elements are added, the deciphering difficulties increase

exponentially. The password quality meter bar will give us a rough idea of this

difficulty.

We need to take special care with this password because a malicious user could

access all of the other passwords saved by Firefox.

After entering the password, click on OK to save it.

It is only natural to be wary about saving all of our passwords in Firefox, con-

sidering that it is a computer program that connects to the Internet and is

hence vulnerable to computer attacks. Absolute security does not exist but

the system used to save them by the program, with encrypted data and a vari-

able profile folder, is much more secure than the one supplied by default in

Microsoft's Internet Explorer.
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4.5. Scripts and plug-ins

One of the basic features of the Internet today is its use of JavaScript and plug-

ins, such as Macromedia's popular Flash Player, to increase the usability and

attractiveness of web browsing. But because nothing is perfect, all of these

improvements could seriously compromise the security and privacy of Inter-

net users if they are not adequately controlled. We will now look at the tools

offered by Mozilla for their control.

To access these options, go to Edit > Preferences...> Advanced > Scripts and

plug-ins, which will bring up the following dialog box:

Figure 48. Content options dialog box

The options offered here are:

• Enable�Java

The Java virtual machine can be very useful for sites with advanced content,

such as dynamic maps created by users or other complex web applications.

Java programs that come from known websites are generally quite safe and

do not usually cause security problems. Nonetheless, if you never visit sites

that use Java, it is best to turn it off, just in case. It is important to disable

whatever you do not use.

• Enabling�Javascript:
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For satisfactory web browsing, you must enable the Javascript option because

it is a language used by most Internet sites. However, this option should never

be enabled in an e-mail program. Javascript code can be used in a message

to send data to a server in a similar fashion to invisible images in junk mail.

There is no use for Javascript in a normal e-mail message. No friend would

send us an e-mail with Javascript in it.

If you want to further customise your control over Javascript for, although

necessary, it can be used to bother the user with advertising, click on the Ad-

vanced button to configure its behaviour.

Figure 49. Advanced Javascript options dialog box

For security reasons and particularly for the bother it can cause, it is best to

uncheck the Move or resize existing windows, Raise or lower windows and

Hide the status bar options. In contrast, it is important to allow the creation,

modification and reading of cookies, so we should select the Create or change

cookies and Read cookies options. The other options will depend on the indi-

vidual user but they will not have a direct impact on security.

4.6. Digital certificates

Digital or electronic certificates are an increasingly important aspect of secu-

rity. In an Internet environment, these documents serve to verify the source

of the displayed data. In other words, they are used to check that the issuer

of the data really is who they say they are. We can therefore think of it as an

identity card allowing us to identify ourselves on a network.

Security certificates can also be used to sign or encrypt e-mail messages but we

will look at this later. We will focus exclusively on the web environment here.

We can obtain a personal certificate from a CA (certification authority). These

organisations must have the authority to issue this type of certificate. Dif-

ferent types of certificate are available depending on their purpose, but it is

usually fairly easy to obtain one for purely personal reasons. If you need a
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company certificate, the process tends to be far more complicated. The most

widely known certification authority is VeriSign Inc, whose website is http://

www.verisign.com/, but there are many others too.

4.6.1. Secure websites

In the web environment, certificates are used for visiting websites securely. If

you look at the address of these sites, you will see that it begins with https://",

rather than "http://, indicating that we are on a secure site. When this hap-

pens, the colour of the address bar in Firefox turns bright yellow.

A much easier way of checking this is to observe the padlock icon displayed

in the status bar in the bottom right of the main window. It is very important

to know the meaning of the different positions of the padlock icon.

• A closed padlock icon means that all data sent between the server and our

web browser are encrypted.

• An open padlock means that communication between the server and our

web browser uses data that are not protected.

• If we see a broken padlock on a red background, this means that not all

of the elements of the page were received as encrypted although the page

containing them is marked as encrypted.

For more information about the status of the page, click on the padlock icon

to display a dialog box containing information about the page in the security

tab. You can also access this information from the Tools > Page Info > Security

menu option.
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Figure 50. Dialog box displaying security information for a page

The top section of the dialog box indicates whether the website to which the

page belongs has been validated and which authority has certified it. Click on

the View button to see the full details of the certificate.

In the rest of the dialog box, we can see whether the contents of the current

website are encrypted and to what level. There are different levels of encryp-

tion, offering varying degrees of security.
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Summary

This unit on the popular Firefox web browser has looked at various aspects

of its installation and configuration and described key elements that can be

very important when using the tool. Throughout, the approach has been to

provide an introduction to Firefox, rather than to web browsing, so we have

not covered basic aspects that we believe students will already be familiar with.

We have seen the process for installing the program and the different plug-ins

that make web browsing much more attractive, since this is one of the big us-

ability problems faced by users who use programs not developed by Microsoft

and the software giants that only support Internet Explorer and Outlook Ex-

press.

Another key area that we have looked at in this unit is data backups. Users do

not normally pay attention to this but we consider this information essential

if users are to be able to use the program comfortably and with peace of mind.

We have looked in detail at the program's security and its configuration, since

we consider this one of the most important aspects that need to be underlined

in Firefox and all free software in general.
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Introduction

We have already seen Firefox work and how its parent program Mozilla and

cousin Thunderbird allow it to be used for everyday e-mail purposes. This

unit will look at one of the leading free software programs: Novell Evolution,

Novell since the multinational bought out Ximian, the company that created

the product.

Evolution is not just an e-mail manager; it is a complete and attractive envi-

ronment for managing information and group work that is very similar in ap-

pearance to the popular Microsoft Outlook, though for free software environ-

ments and UNIX in general. One of its most interesting features is the possibil-

ity of working with a Microsoft Exchange server, a widespread phenomenon

in business IT environments nowadays.

In recent years, this program has been gaining ground as the default mail

manager for most commercial distributions of GNU/Linux to the detriment

of the Mozilla mail manager and Thunderbird, which are two very good prod-

ucts. This should give us an idea of the importance of the product we will be

looking at over the next few pages.

This unit will also look at the program's vast group work capabilities along

with its powerful contact management and capacity for organising everyday

tasks.

Because of its importance in business environments, Evolution is among the

fastest moving free software programs. This unit will look at the basic program,

for which we can use any version, although we would recommend using a

sufficiently updated version.

The main aims of this unit are:

1) to explain how to install and configure Novell Evolution on our GNU/

Linux platform,

2) we will study all of the features of the program's e-mail manager in detail,

from the most basic to the most advanced, and

3) we will also learn how to use the schedule and contact manager for organ-

ising group work.
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1. Installation and setup

Most modern distributions of GNU/Linux already come with a customised ver-

sion of the product (which now forms part of the GNOME desktop) installed

on our computer in the standard installation of the distribution. Nonetheless,

we will describe the installation process, which is very quick and easy.

For automatic installation, you must have a supported version of a GNU/Linux

distribution. You should find this out from the Novell support pages but if you

have a modern version of Red Hat, SuSE or Mandrake, you should not have

difficulty installing it like this.

Then, you will need to connect to the Internet and type the following com-

mand in a terminal window as a superuser:

wget q O  http://go.novell.com |sh

After the Novell Desktop installation has launched, go to Novell Desktop Core

Environment in the component selection screen and uncheck all available

options except for Evolution. If you do not have a supported distribution and

want to install a more recent version or product development, you can down-

load the GNOME CVS program source codes and compile it yourself. However,

you will probably already have the program installed with your distribution.

If not, you can install it very easily with the tools available, such as aptget for

Debian-based distributions or yum in distributions based on Red Hat.

Once the Novell Evolution program is installed, you can launch it from the

desktop panel menu or the command line by typing in "evolution". As with

most programs, we can access the full list of options that we can add to the

program by entering "man evolution" or "evolution –help".

When we use a program that allows us to save sensitive information, it is

always very important to know where this data is located so that it can back

them up. In this case, the program creates a folder called evolution in our

user folder. All of the data saved there is in standard file formats, allowing the

information to be recovered by third-party applications.

1.1. Setup wizard

The first time you run the program, a wizard will launch to configure an e-mail

account and import data from other applications. We will look at the various

steps to this process, skipping out the wizard dialog boxes that only give us

information.



GNUFDL • PID_00148478 8 Novell Evolution. E-mail manager and personal information manager

Figure 1. User identity dialog box

The first wizard screen is the user identity definition screen. Here, you type

in your name, e-mail address and, if you like, your reply address and organi-

sation. If you have several e-mail accounts, you can set up different identities

later in Edit > Preferences > Mail Accounts.
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Figure 2. Message receiving dialog box

The message receiving dialog box is used to configure the type of server from

which you will receive e-mail. The configuration options shown will depend

on the type of server you selected. It is also possible not to select a type of

server if you are not going to use this account to consult your e-mail.

If you select POP or IMAP, you will be asked for the following information:

• The name of the server (you can also use its IP address).

• Username.

• Whether you want to use secure SSL connections (if your server allows

this).

• The type of authentication (if you are not sure, click on Check supported

types).

• Whether you want the program to remember your password (so that you

do not have to enter it every time you run the program).
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If you are not sure of the server to use or the settings information for this page,

you will need to ask the systems administrator of your e-mail service. In most

cases, it will be a POP server.

Figure 3. More e-mail options dialog box

If you selected POP or IMAP, another dialog box will appear with more mail

configuration options. These will depend on the type of server selected. To

change this configuration after creating the account, go to Tools > Configu-

ration > Mail Accounts, select the account you want to modify and click on

Edit.

For POP servers, the two options you will be asked are:

• Whether you want the program to check whether you have new e-mail

and at what interval.

• Whether you want to leave a copy of the messages you have downloaded

on the server.
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Figure 4. Sending e-mail screen

The Sending e-mail screen offers two basic options: using your own computer

to send e-mail or using a remote server.

To send e-mails from your computer, you must have the Sendmail program

(or a similar application such as Postfix) correctly installed and configured as

a service. If you are using any modern GNU/Linux distribution, the manufac-

turer will probably have included it.

However, remember that if you do not have the program correctly configured

and updated, it can pose a serious security risk for the system. If you are not

familiar with the Sendmail program, it is better to use an external mail sending

server.

In this case, you will need to fill in the following options:

• Server: the name of the server or its IP address.

• Use secure connections (SSL): whether you want to use secure SSL connec-

tions (the best option if your server allows it).

• Server requires authentication: check this option if the mail sending server

requires you to enter a password to send messages.
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• Authentication type: the best option in this case is to leave the default

option unless your system administrator has requested otherwise.

• Username: usually the name you use to read your e-mail.

• Remember this password: select this option if you do not want to enter

your password every time you send a message.

Figure 5. Mail account management screen

You can enter a name in the Account Management screen to refer to this ac-

count in the program and indicate whether you want it to be the default ac-

count.
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Figure 6. Time zone selection screen

In the time zone selection screen, simply select your geographical location on

the world map.

Novell Evolution will now be configured and ready to use.

1.2. Importing data

You can import e-mail from other programs with the File > Import menu

option, but if during configuration the wizard detects that you have e-mail

saved on your hard drive or known files containing contact details, the import

wizard will launch during this initial configuration.

The Novell Evolution program can import the following data formats:

• VCard�(vcf,�gcrd). This is the standard address book format used by most

contact managers. Any program of this nature should be able to export its

data to this format for Novell Evolution to then import it.

• Microsoft�Outlook. E-mail data from this program can be imported di-

rectly to Novell Evolution if your version allows. Some versions of the pro-

gram cannot be imported because of the use of a proprietary data format

in Microsoft's program. Nonetheless, you can try to import your e-mail

using Mozilla as an intermediate stage between Outlook and Novell Evo-

lution or by exporting the data to CSV.

• LDAP. This widely-used protocol was created for users to exchange contact

information through the network, sharing access to a central directory



GNUFDL • PID_00148478 14 Novell Evolution. E-mail manager and personal information manager

where all contacts are stored. Many companies have an LDAP directory

for their internal or client contacts.

• Berkeley�e-mail�inbox�(mbox). This is the standard UNIX mail data sys-

tem used by Mozilla, Netscape and Eudora, among others. Most historical

programs support this format.

1.3. Exporting data

Exporting data is even more important than importing data, so Novell Evo-

lution uses standard formats to store information. If you use this program to

save important data, you should have no problem exporting it to other appli-

cations if you need to.

For your information, the format for mail is Mbox, for calendars it is iCal, and

for the address book it is vCards. If you look at any information management

application on the market today, you will see that most of them can recover

data in these formats.

1.4. Connection to a Microsoft Exchange server

One of the most useful features of Evolution for business is the possibility of

connecting to a Microsoft Exchange server to obtain and synchronise e-mail,

contacts and appointments with other members of staff at the company, re-

gardless of whether they use Windows or GNU/Linux. This section will study

the steps required to connect to a Microsoft Exchange 2000 or 2003 server

through the Evolution Exchange connector. This connector is free software,

licensed under the GNU GPL licence.

There are two requirements for connecting to an Exchange server. We first

need the Evolution Exchange connector installed on our system. This connec-

tor will be available for our platform but the GNU/Linux distribution we use

will probably not install it by default. If you do not install the connector, the

options below will not be available in the program.

The other requirement is that the Microsoft Exchange server be one of the

versions supported by the program. It now only supports versions 2000 and

2003 and also requires Outlook Web Access (OWA) to be enabled. In addition,

each user will need a valid Microsoft Exchange server account, which includes

a valid licence.

In Evolution 2.6, the program comes with a tool for the straightforward cre-

ation of Exchange accounts. If you have not yet set up an account, the con-

figuration wizard that launches at the start of Evolution will allow you to cre-
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ate it. The wizard only asks for the Outlook Web Access (OWA) URL and your

username and password. Evolution will obtain the rest of the information au-

tomatically.

Figure 7. Evolution Exchange Wizard dialog box

If we cannot launch automatic account setup, it is usually because we have

already added an account to our computer and so we will have to set up the

new account manually. To do so, go to Edit > Preferences and click on the

Add button. In this case, you will create the account in the same way as in

the previous section, selecting Microsoft Exchange in the message receiving

window.

If you wish to create more Microsoft Exchange accounts, you must carry out

these steps again. Evolution currently only allows one account to be set up

at a time.



GNUFDL • PID_00148478 16 Novell Evolution. E-mail manager and personal information manager

2. E-mail

One of the most interesting features – and one of the strong points – of the

Novell Evolution program is its capacity for work and e-mail management.

This section will look at all of these features in detail.

To launch the e-mail client program, click on the Entrance icon on the short-

cut or select an e-mail folder from the folder bar.

Figure 8. E-mail management feature main screen

2.1. Straightforward operations with the e-mail reader

This section will look at the most common e-mail options, such as reading

and deleting messages.

2.1.1. Reading

To read a message, simply select it from the list of messages and it will appear

in the screen display, in the bottom right of the application. To view a message

in full-screen mode, double click on it or use the Ctrl+O key combination if

you prefer to use the keyboard.

Once you are familiar with it, the keyboard can be a very fast way of accessing

the program's diverse actions. For example, it is quicker to use the space bar

and the delete key to scroll up and down in an e-mail message than it is to

use the mouse.
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Figure 9. An e-mail message in full-screen mode

2.1.2. Sorting

As with most e-mail viewers, Novell Evolution allows us to sort lists of e-mail

messages. We can sort them by sender, subject or date by clicking on the bars

above the list of messages. The direction of the arrows beside the name of the

bars indicates the direction of the order, which can be reversed by clicking on

this bar again.

Figure 10. Messages sorted by name of sender

By default, the list of messages column contains the following fields: an en-

velope icon that tells us whether we have read or replied to a message, an ex-

clamation mark indicating its priority, and the message recipient, subject and

date fields. If you right-click the bar, you can also configure the order and add
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or remove information from the messages you wish. For example, if you have

a slow Internet connection, displaying message size is very useful. The process

for adding a new column is as follows:

1) Right-click the column header.

2) Select the "Add column" option.

3) Drag the column you wish to add between two existing column headers.

A red arrow will indicate the position of the new column.

For a list of message sorting options, select the column header you wish to use

to sort messages and right-click on it. A list of the actions you can perform

will be displayed, which are:

• Sort�ascending: sorts messages from the highest column field value to the

lowest.

• Sort�descending: sorts messages from the lowest column field value to

the highest.

• Group�by�this�field: instead of sorting messages by a given criterion, mes-

sages with the same value (e.g. sender or date) are grouped together and

separated from the rest.

• Remove�this�column: deletes the selected column from the message view.

Another way of removing it is to drag it outside the columns headers.

• Add�column:�with this option, a new column can be added by dragging

it to the column header bar we saw above.
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Figure 11. Diverse e-mail message features

2.1.3. Message information

There are two more useful options for configuring how the program displays

our messages. Both can be enabled and disabled from the View menu. The first

is in View > Message Display and allows us to select the message information

we wish to see. If you only want to view the message contents, it is best to

leave the default option, which is Normal View.

2.1.4. Threaded message view

The other useful option for enhancing viewing in this program is to group

replies to a message with the original for easier communication follow-up. To

turn this feature on or off, go to View > Threaded Message List.

Figure 12. A threaded e-mail message displayed with the full header
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2.1.5. Deleting messages

To delete an e-mail message, select it first by right-clicking on it. You now have

a number of options to delete it. The first is to click on the trash button in

the application's Main toolbar. Other alternatives are to use the Del key or to

right-click the message and select the Delete option.

Note that when we tell the program to delete a message, it is not actually

deleted; it is simply marked for deletion for when the folder is expunged.

Figure 13. E-mail message marked for deletion

To expunge the folder, go to the Folder menu and select the Expunge option

or press the key combination Ctrl+E. When we do so, a warning message will

pop up asking if we want to permanently delete the messages from the folder.

If you do not wish to see this message every time you expunge a mail folder,

mark the Do not ask me again option in the warning dialog box.

Figure 14. Warning dialog box shown before expunging a folder

Although this system gives us an extra level of protection so that we do not

permanently delete messages by accident, users who are used to other e-mail

management programs may find the procedure tedious because it adds anoth-
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er step to the process. If this is your case, you can hide the process using the

View > Hide Deleted Messages option. From now on, the deleted messages

will only appear in the trash, as occurs with other programs.

2.1.6. Restoring deleted messages

It is impossible to restore messages that were permanently deleted from a fold-

er when it was expunged. However, we can restore messages marked for dele-

tion by selecting the Edit > Undelete menu option or using the key combi-

nation�Ctrl+U.

This action will unmark the message for deletion and remove it from the trash.

2.1.7. Checking for new mail

To check for new messages, click on Send/Receive in the toolbar. If you have

not yet entered your e-mail account details, the wizard that launched when

you first opened Novell Evolution will appear again. The first time you down-

load e-mail or if you have not told the program to save your password, a dialog

box will appear prompting you to enter the password.

2.1.8. Folders

Novell Evolution saves e-mail and other program elements in folders to keep

them organised. We can take advantage of this feature to create our own e-

mail folders. The program has some pre-defined basic folders, such as Inbox,

Outbox or Trash, but you can create others to organise your e-mail better. For

instance, you could create a folder called "University" and save all messages

on this topic there. To create a new folder, go to the New Folder menu option.

The program will display a dialog box where you can enter the name and type

of folder and the desired location.
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Figure 15. New folder dialog box

The new folder is created when you click on OK and you can see it in the folder

tree. You will be able to use this folder just as you use the others. To move

messages to the new folder, simply drag them to it or use the Move button on

the Main toolbar. If you want to drag more than one message at a time, you

can use the same technique as Microsoft's Windows Explorer. Hold down the

Ctrl key as you click on messages to select them individually. Alternatively,

hold down the�Shiftkey as you do so to select a range of messages.

2.1.9. E-mail search

If you have a lot of messages in your e-mail program, you may have problems

when it comes to searching for a particular one. Even if you are organised and

have created a folder for each message topic, you will need to be able to use

Novell Evolution's search features.

To use the program's search facility, simply type in the word or phrase in the

text field just below the Main toolbar and then select the type of search. The

program offers a number of search options:

• Body�or�Subject�Contains

This option will search for the word or phrase you typed into the search field

in the subject and text of your e-mail messages.

• Body�Contains
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With this option, you only search for the text in the body of the messages,

not in the subject.

• Subject�Contains

This option will find the messages containing the search text in the subject.

It does not search in the message text.

• Body�Does�Not�Contain

Select this option to find messages that do not contain the word or phrase

in the message body. Messages containing the text in their subject will be

displayed so long as the text is not found in the body.

• Subject�Does�Not�Contain

This option is used to find a message whose subject does not contain the search

text.

• Sender�Contains

Use this search option to find messages whose sender contains the text string

or name indicated.

• Recipients�Contain

Select this option to search for messages whose recipients contain the specified

words or text.

Enter the text and search criteria and press the Enter key for the program to

display the messages it finds.

To view all of your messages again, select the Clear option from the search bar.

You can also perform an empty search, which will produce the same result as

the above operation.

Although we can search very quickly using this system, the available options

are somewhat limited. To perform more complex searches, we will need to

select the Advanced option from the list of search bar options. A new dialog

box will appear in which we can select the search criteria we have already seen.

Nonetheless, this is a much more flexible option because it allows us to search

for messages matching all or just one of our criteria. To launch the message

search, click on Search Now.
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Figure 16. Advanced search dialog box

2.1.10. Attachments and HTML

The program usually displays e-mail attachments at the end of the message,

except if the attachments form part of the format of a HTML message. In the

latter case, these elements (for example, graphics or sounds inserted in the

text) are displayed in the message and not as attachments.

Figure 17. An e-mail with attachments

An image does not have to be included as a message attachment for the pro-

gram to display it with the text. The image can also be a link to an image

located on a remote server. Novell Evolution can display this type of remote

image if you enable the View > Load images option inside the message.
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Figure 18. Tab for configuring the display of remote images

These images are not displayed by default because they are often used by spam-

mers to obtain statistics on the efficiency of the message and other data con-

cerning the privacy of the recipient. This option can be customised in:

Edit > Preferences... > Mail Preferences > HTML Mail

If you receive an e-mail with a text attachment, you can save it to disk or open

it directly with an application. To save the file to disk:

1) Click on the attachment button arrow at the bottom of the message.

2) Select the location where you would like to save the message.

3) Click on OK.

Figure 19. Saving an e-mail attachment to disk

The process for opening an attachment with an application is very similar to

the one above.
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1) Click on the attachment button arrow at the bottom of the message.

2) Select the program you wish to use to open the attachment.

This will launch the program you have chosen and open the attachment in it.

Figure 20. Opening an e-mail attachment with an application

2.1.11. Composing e-mail messages

You can compose a new e-mail message by selecting the Messages > New Mail

Message option or by clicking on the New button in the toolbar when you are

in the e-mail application. You will see that, although the appearance of the

button varies depending on the application you are using, you can always use

the arrow next to it to select the new element you wish to create.

After selecting this option, the new message composition window will open.
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Figure 21. New message composition window

The message composition process is very similar for all e-mail management

programs. A brief description of the steps is as follows: enter the address of the

person you wish to send the message to in the To: text field, then add a Subject

and finally enter the message text in the box at the bottom of the window.

When you have finished writing the message, click on the Send button.

2.1.12. Drafts

If you are writing a very long and complicated message or you simply wish to

pause for a while, you can save a draft of your message in a special drafts folder

and pick up where you left off at a later time, knowing that your data is safe.

To do this, simply select the File > Save Draft menu option in the message

composition window.

Another of the program's features is the possibility of saving messages as text

files. For this, simply go to File > Save As and select a name for the text file.

2.1.13. Working offline

The Novell Evolution program has a Working Offline mode for computers that

do not have a permanent Internet connection. You can work as you normal-

ly would in this mode but actions requiring an Internet connection will be

completed when you next connect to the Internet. E-mail messages are saved

in the Outbox folder.
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Go to the File > Work Offline menu to turn on this mode and to File > Work

Online to reconnect.

The availability of e-mail messages during offline mode will depend largely on

the communication protocol you use to read messages on the server. If you

use POP, all of your messages will be available because they are deleted from

the server and copied to a folder on your computer. However, if you use other

protocols, such as IMAP, the messages are stored on the server and you cannot

generally access them without a connection.

If you work with one of these protocols, you can force the program to keep

a local copy of these messages for permanent access to them, regardless of

whether you are connected to the mail server.

To do this, select the folder, right-click on it and select Properties. Then select

the Copy Folder Content Locally for Offline Operation option. Now, when

Novell Evolution connects, it will copy the contents of this folder to the user's

local computer.

Figure 22. Offline folder selection tab

2.2. Advanced composition features

Now that we have seen the basic operation of the program's e-mail facility, we

will now look at the more advanced aspects of message composition that we

have not yet described.

2.2.1. Attachments

The use of e-mail solely for the purpose of exchanging text messages is a now

thing of the past. It is increasingly common to send documents attached to

messages nowadays.

Novell Evolution makes this a very easy task. To create an attachment, go to

the text composition window and carry out the following steps:

1) Click on the Attach button in the toolbar.

2) Select the file or files to attach to the message.
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3) Click on OK.

Figure 23. Creating an e-mail attachment

When you return to the message composition window, you will see that the

files have been added to the composition window. If you have selected the

wrong file, you can remove the attachments by right-clicking on them and

selecting Remove.

You can opt to display message attachments in the View > Display Attach-

ments main menu option. It is always a good idea to keep this option checked

for your reference and to avoid mistakes.

In addition to the option we have just seen, the program offers a very quick

alternative for automatically creating mail attachments that requires us simply

to drag the attachments to the composition window. When we do this, we

need to be sure that we are dragging the actual file with its contents and not

a link to it. In case of doubt, check the size of the attached file to see whether

you have made a mistake.

2.2.2. Entering recipients

All e-mail management programs allow us to enter three different types of

message recipient:

• Top-level recipients (To:)

• Second-level recipients (CC:)

• Third-level or hidden recipients (BCC:)
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Grouping recipients into a specific level is ultimately a matter of personal

choice and there are no hard and fast rules on which to base our decision. We

generally use the first level when we have just one or only a few recipients and

we combine the first and second when there are many, taking into account

how useful the message will be to these people.

We generally use the second level to send copies of messages to people not di-

rectly interested in the subject. CC is the abbreviation of Carbon Copy, which

is the method that was used in the past to copy documents.

The third level is more complex. BCC means Blind Carbon Copy. It is used

in the same way as the second level but these recipients are hidden from the

other message recipients. It can be used to send messages to large groups of

people who do not know one another or where privacy is required. If you

cannot see this field in the composition window, you can enable it using the

View > BCC field menu option.

One final feature of Novell Evolution is the possibility of setting up a different

reply address to the message sender address. In this case, if the recipients send

replies, they will be sent to this address rather than the address from which

the message was sent. To enable this field, select the View > ReplyTo field

menu option and enter the address.

Figure 24. E-mail message with all recipient fields active

With this program, you can quickly enter the names of recipients in your

contact list. To do so, simply click on the recipient field you require and in the

dialog box that appears select the people you have entered in your contact list.
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2.2.3. Replying to e-mail messages

To reply to an e-mail message, click on the Reply button on the toolbar or

select and right-click the message and choose the option you wish. This pro-

vides greater flexibility because we are given more options, such as replying

to sender only, replying to a list or replying to all message recipients.

Note: the Reply to All option does not include those who were added in the

BCC field of the original message because we cannot see them and hence do

not know their e-mail addresses.

When you reply to a message, the composition screen opens with the To:

and Subject: fields automatically filled in by the program, although you can

change these details if you need to. The full text of the previous message is

also inserted in the new one so you can use the previous text as a reference

for your reply if need be.

Figure 25. Automatic e-mail reply

2.2.4. Use of HTML elements for composing messages

Like most modern e-mail management programs, Novell Evolution can be

used to compose e-mail messages in HTML format. However, this option is

not enabled by default for the reasons we will see below.

It is generally preferable not to send messages in this format because, in our

view, it has only one advantage and many disadvantages.
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• The advantage is simply a matter of aesthetics. These messages are much

more attractive: we can insert graphics, adopt styles and use a range of

fonts with their respective formats etc.

• The disadvantages are numerous: not everybody uses e-mail clients that

accept HTML messages; these messages are much bigger than text-only

messages, which can be a problem for those who read their personal e-mail

on PDAs with memory limits using a mobile GPRS connection; Internet

distribution lists do not accept these messages and lastly, many people

prefer to receive messages in plain text format.

In the light of this, we can see that it is generally a bad idea to send text in

HTML format to people we do not know, Internet mailing lists or for serious

communication. However, we can use it without problems for sending per-

sonal messages to friends or people who we know will not have difficulty re-

ceiving them.

To change the format of an e-mail message during composition, go to the For-

mat > HTML menu option to check or uncheck it, depending on whether you

wish to use this format to compose this message. You can change this prefer-

ence globally by going to the Edit > Preferences... > Composer Preferences

> General menu and selecting the Give HTML Format to Messages option.

However, as we have explained, we do not recommend setting this as the de-

fault format unless you are going to be using the program to send messages to

friends or acquaintances you know can receive these messages without prob-

lems.

Figure 26. Message sending format selection tab
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We will now look at the HTML composition options of Novell Evolution. Click

on the Main toolbar to open a new message composition window. Then go to

format to ensure that HTML format is enabled. If not, you will need to turn it

on to be able to use any of the composition features indicated below.

The HTML formatting tools are located on the toolbar in the space immedi-

ately above the part of the window where you type the body of the message

and in the Format and Insert menus. When you hover over a button, a short

description will pop up to give you a clear idea of each button's function.

Figure 27. HTML formatting toolbar in the composition window

We will now look at each of these actions, grouped into categories based on

their features:

• Headers�and�lists

The left-hand side of the toolbar contains a list from which we can select the

style of text we wish to write in. We use Normal as the default message text

and the Header 1 to Header 6 styles for varying preformatted header sizes,

from large to small. Other styles include lists allowing us to organise message

contents more effectively.



GNUFDL • PID_00148478 34 Novell Evolution. E-mail manager and personal information manager

Figure 28. Message formatted with headers and lists

• Text�style

The text style buttons (bold, underlined, italics and strike through) determine

the appearance of the letters of the text we enter. If we select a text and then

select a new style, this style will be applied to the text. If we have not previ-

ously selected any text, the style will be applied to the next text we type.

Figure 29. Message formatted with text styles
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• Alignment

To the left of the style buttons we saw in the previous section, there are three

paragraph alignment buttons which, like the others, will no doubt be familiar

to readers. The button to the far left aligns the text of the paragraph to the

left, the one in the middle, centres it and the one on the right aligns the text

to the right.

Figure 30. Message with aligned texts

• Indentation

The button with the arrow pointing left reduces the paragraph indentation

while the one with the arrow pointing right increases it.
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Figure 31. Message with indentations

• Colour�selection

On the far right of the formatting toolbar is the colour section tool. The colour

of the button indicates the text colour currently selected. If you choose a new

colour while you have text selected, this colour will automatically be applied

to the text. If not, the new colour will be applied to the next text you type

in. You can only change text colour with this option. To change the colour of

the page, right-click the message text box and select Page. A dialog box will

appear where you can select the background colour as well as other options.
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Figure 32. Message with different coloured texts

Other options for enhancing the format of the document using HTML can be

found in the Insert menu of the message composition window. Their features

are as follows:

• Links

The Link option of the Insert menu, also accessible from the toolbar, can be

used to insert a link associated with a text. If you simply wish to insert a link

to a website that might be of interest to your recipient, you do not need this

option. Just type the web address in the message body and the program will

automatically detect it and convert it into a link.

If you have already written the text, select it and then enable the function.

You will see how the text automatically appears in the text field associated

with the link.
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Figure 33. Message with link and text with link

• Images

To insert an image in the text, go to the Insert menu and select Image or click

on the toolbar button.

Figure 34. Image insertion dialog box

An image insertion dialog box will appear in which you can select the loca-

tion of the image you wish to insert in the message, together with different

formatting possibilities and the possibility of converting the inserted image

into a link.

• Rules
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Another message composition possibility is to insert horizontal lines in the

text to divide it into different sections. To insert a horizontal line, select the

option from the Insert menu or from the toolbar. The Rule dialog box will

appear. Here, you need to select the type of rule from the available options,

along with size, alignment and style. After completing your selection, click

on the Insert button.

Figure 35. Rule inserting dialog box

• Tables

Tables are a much cleaner and elegant way of dividing text into different sec-

tions. As with the other options, you can turn them on in the Insert menu or

from the toolbar. In the Table insertion dialog box you can select a number of

templates to give a twist to the tables you create. You can, of course, change

attributes too, such as the number of rows, columns and space between them.

After customising the table to suit your needs, click on Insert to add it to the

document.
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Figure 36. Table insertion dialog box

You can edit a table after inserting it in a message by right-clicking on it. If

you select the Table option, it will take you to a very similar dialog box to

the previous one, where you can modify the features of the table. To insert or

delete rows or columns, use the Insert table and Delete table options.

Figure 37. Message formatted with tables

• HTML�templates
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Besides being able to individually insert elements of messages formatted in

HTML, the program also comes with a number of templates containing pre-

designed elements that we can use to enhance the appearance of our messages

very easily and with professional results. To use a template for a message, go

to the Insert menu and select Template or simply click on this button on the

toolbar. The template insertion dialog box will appear, where you can select

the template you require from those available, together with its size and align-

ment. Then click on Insert to position the template at the current cursor po-

sition. To customise the templates, click on the texts or images and replace

them with the ones of your choice.

Figure 38. Message formatted with HTML templates

2.3. Additional features of the e-mail manager

Thus far, we have seen the main tools and options for e-mail use and we have

seen all of the program's most important composition features. However, to

complete this overview of the program, we have yet to see some other key

features, even though they may not be used regularly by all users. We will now

look briefly at these.

2.3.1. Receiving invitations by mail

As Novell Evolution is a personal information manager as well as an e-mail

manager, it can be used to create events in the calendar and e-mail them using

the mail management tool. The invitation is seen as an attachment in iCal

format.
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Figure 39. Invitation received as an e-mail message attachment

To reply to a request, click on the attachment button and select the View

online option to see all of the information in it. Once you have read all this

information, you have a number of options:

• Accept

Select this option if you are sure that you will attend the meeting. When you

click on OK, the meeting will be automatically entered in your calendar.

• Tentatively�accept

This option indicates that you will probably attend the meeting but are not

100% sure. When you click on OK, the appointment will be entered in your

calendar but it will be marked as tentative.

• Decline

Select this option if you cannot attend the meeting. The meeting will not be

automatically added to your calendar but a reply will be sent to the event host

if the RSVP option was selected.

• RSVP

When this option is turned on, as recommended, a reply is sent to the event

organiser.
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Figure 40. Accepting invitations dialog box

We will see how to send these invitations later on when we look at the features

of the program's calendar.

2.3.2. Folder subscription system

If you use the IMAP protocol to connect to your mail server, one very impor-

tant feature is the possibility of subscribing only to certain folders to check

whether they have mail. There will generally only be one, two or three server

folders that we wish to check for new mail because this protocol operates re-

motely, meaning that these operations take up a considerable amount of time

and resources. The server can also contain empty folders and there is no point

in checking these for new mail.

We will now see how to subscribe to selected folders.

1) Go to the Folders > Subscriptions menu option.

2) Select the e-mail account that you wish to change your subscriptions for.

3) Select the folders you wish to subscribe to by clicking on them. Some

servers using the IMAP protocol can also display folders that are not e-mail

folders. In this case, ignore them and do not subscribe to them.

4) Once you have selected the folders using the above criteria, click on Sub-

scribe to add them to the list of subscribed folders.

5) Close the window.
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Figure 41. Remote folder subscription tab

2.3.3. Encrypting e-mail messages

Although the aim here is not to provide a detailed description of the complex

topic of encryption, we will need to deal with some concepts if we are to un-

derstand how this process works in relation to the features of Novell Evolution.

Encrypting is a technique that encodes messages so that only their recipients

can read them. Although a third-party could intercept the message before it

reaches the recipient, the contents will be illegible to this person.

Novell Evolution uses the GPG program to encrypt and decrypt messages.

The GPG program uses two types of key: public and private. With this tech-

nique, we can give out our public key to anybody who wishes to receive en-

crypted messages and we can also upload it to a public key server on the In-

ternet for public access to it. In contrast, a private key must be kept very safe

and you must never allow anybody access to it.

This dual key system is very secure but it is not very straightforward to use, be-

cause it requires us to carry out different actions depending on our intentions.

• Encrypting�an�entire�message�so�that�it�can�only�be�read�by�the�recip-

ient

To send an encrypted message to somebody, we need to encrypt the message

using the recipient's public key. Thus, to receive encrypted messages, we need

to make sure that the person who wants to send us a message has our public

key.
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• Write�the�message�in�normal�text�and�attach�an�encrypted�signature

so�that�everybody�can�read�the�message�and�the�recipient�can�use�the

encrypted�signature�to�confirm�its�authenticity.

To sign messages, we have to do the opposite. Encrypt the signature with our

private key so that the message recipient can use our public key to confirm

the authenticity of the signature and the message.

We can tell the program to always encrypt outgoing messages. To do this, go

to the Edit > Preferences...> Mail Accounts menu and select the account you

wish to use to always send encrypted messages from and then click on Edit. In

the mail account configuration screen that appears, click on the Security tab.

Then check the Always Sign Outgoing Messages When Using This Account

option.

Figure 42. Mail account security tab

Basic use of the GNU Privacy Guard (GPG) program

We have already seen that we need two encryption keys (one public and one

private) to digitally sign a message. We will now see step by step how we can

obtain these with the GPG program.

1) Open a terminal and type in "gpg -- abans era –genkey".
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2) When you are prompted for the encryption algorithm, select the one that

comes by default with the DSA and ElGamal program.

3) It is now time to select the key length. The longer the key, the more diffi-

cult it is for third parties to decrypt the message. The default option, 1,024

bits, is more than enough for today's needs.

4) You must now decide whether you want your keys to expire and when.

5) The next step is to enter your details: name, e-mail address and a com-

ment. The comment can be any information about you or the details you

have entered that you consider it necessary to add. For example, you could

point out that these are your personal keys, if you plan to create addition-

al professional keys. It is important to enter this information correctly be-

cause it will be used for your electronic signature.

6) You should then enter a password. It is very important not to lose this

because the keys would become invalid and you would be unable to read

coded messages sent to you by others. It is also a good idea to use a dif-

ferent key to any another used for the system to make it very difficult for

others to find out.

7) Once you have completed this step, the program will generate the keys.

Depending on the size of key chosen, the process can take a while. GPG

uses different computer status variables to generate random numbers, so

it is a good idea to move your mouse or launch a program while the keys

are being generated as this will create a better quality key.

To confirm that the process was successful, you can view your key information

using the command: gpg --listkeys as shown below:
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Figure 43. Terminal with the list of keys generated

While it generates the keys, the GPG program also creates a list of public and

private keys. These lists are found in different files in the user folder on the

~/.gnupg/ path. The public key file is called pubring.gpg and can be sent to

the people we want to have our public key so that they can send us encrypted

messages.

If you want your keys to be generally available, you can upload them to a

public key server. This means that anybody can access your public key and

send you encrypted messages or confirm your signature without contacting

you for the key. To do this, you need to continue inside the terminal window.

Firstly, you must obtain your key ID. The easiest way to do this is to type

the gpg -- abans era –listkeys command again and copy the eight-character

string after 1024D in the line beginning pub. In the above screenshot, this

is: 7A1DC5F7.

Once you have the key ID, enter the command: gpg -- abans era –sendkeys

–keyserver wwwkeys.pgp.net 7A1DC5F7. Enter the key password when re-

quested.

Before leaving this basic introduction to GPG, we will look at how to obtain

and import public keys from others in order to send them encrypted messages.

Although all operations are automatically performed by Novell Evolution, we

have to manually import the recipient's public key into our list.

The command for this operation, also entered from a terminal window, is:

gpg -- abans era –revkeys -- abans era –keyserver wwwkeys.pgp.net pass
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, replacing pass with the ID of our recipient. We will need to type in our pass-

word again before the key is automatically imported to our key list. Now, when

we send this person a message, Novell Evolution will allow us to encrypt it.

To import a key sent by e-mail, save it to disk as text and then use the com-

mand gpg file_name, where file_name is the path to the file that we saved to

disk with the key.

2.3.4. Encrypting in Evolution

Once you have your public and private keys, you can use Evolution to encrypt

entire messages or simply to sign them. We will now see the steps required

for this.

To enable encryption of an e-mail account, go to the Edit > Preferences menu

option, select the mail account you wish to use and click on Edit. In the Se-

curity tab, type in your key ID. Remember that you will need to enter the

gpg -- abans era –listkeys command to find out your key ID, as we saw in the

previous section. Once you have entered the key, the program will be ready

to use it.

Figure 44. Mail account security tab

Signing�a�message
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To sign a message, place the cursor in the composition window and select the

Security > Sign with PGP menu option. If the key was installed correctly, the

program will prompt you for your password. Enter it and click on OK. If all

goes well, the message will be signed.

Encrypting�a�message

The procedure for encrypting messages is very similar to the one used for sign-

ing messages that we just saw, but this time we select the Security > Encrypt

with PGP option.

Decrypting�a�message

To read an encrypted message, you will first need to decrypt it. As the sender

will have used your public key to send the message, you will need to type in

your password to view it. The program will prompt you for your password

when you try to view the message. Enter it and you will be able to view the

message correctly.

2.3.5. Message filters

Filters are used to classify messages received into different folders based on

predefined rules. We can have several filters running at the same time, which

means that a message can be copied to different folders.

To make full use of their possibilities, we need to know when these filters are

active. As we saw in other cases, the runtime depends on the type of protocol

we use to communicate with the mail server.

If we use POP (Post Office Protocol) and download mail for local use, the filters

will be applied whenever we check for new mail because this is when the

messages are downloaded from the server.

If we use IMAP (Internet Message Access Protocol) and work remotely, the

filters will be applied when we open the inbox folder on the server. If we

have a filter that moves messages from the server to a local folder, the e-mail

messages will only be available on the local computer where we read our mail

and not on the server.

The steps for creating a new mail filter are as follows:

1) In the main application menu, select the Edit > Message Filters menu to

open the filters dialog box.
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2) In the top part of the options dialog box, select whether you want the

filter to be incoming or outgoing. In most cases, you will choose incoming.

Click on the Add button.

3) You will now need a name for the filter. This should be something con-

nected to what it does so that you can identify what it does quickly. This

will be very important if you have a lot of filters running at the same time.

One rule that can be very useful is to use the name of the folder where the

filtered messages will be sent as the name of the filter.

4) For each filtering criterion, the first thing to do is to select the parts of the

message that the filter should analyse. Most of these parts are obvious but

some have certain nuances that we will now see:

• Sender: the sender's e-mail address.

• Recipients:�the recipients of the message.

• Subject: the subject line of the message.

• Specific�header: the filter can search in any part of the message header

that we tell it to search in. Type the header field in the first text box

and the text to search for in the second. Bear in mind that the program

will only search for the first instance. If the header contains two values

that are the same, filtering will only take into account the first one.

• Message�body: the actual body text.

• Expression: if you know Scheme programming language, you can use

this option to enter a search expression.

• Date�sent: messages are filtered by the date on which they were sent.

You must first choose the message condition (is, is not, is before, is

after) and then the date. The filter will compare the message date field

with the current system date and time or with a date specified in the

calendar. Messages can even be filtered by a specific time interval, such

as messages from the previous week.

• Date�received: this field is used in the same way as the one above but

compares the date on which we received the message not the date on

which it was sent.

• Label: e-mails have a standard priority scale that goes from –3 to 3,

from least to most important. These values can be used to perform a

variety of actions. We can also change this priority using other crite-

ria (sender, date received etc.) and subsequently filter these messages

ourselves based on this priority.
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• Size�(kb): the size of the message in kilobytes.

• Status: Messages can be filtered by their status. This can be: Read,

Replied To, Important and Draft.

• Flagged: indicates whether the message is flagged.

• Attachments: tells us whether a file is attached to the message.

• Mailing�list: this filter is used to establish whether the message comes

from a mailing list and to act accordingly. We can check whether a

message has come from a mailing list using the values in its header.

• Regex�match: if you have a knowledge of "regex" or regular expres-

sions, you can specify search criteria.

• Source�account: if you have more than one account set up in the

program, this option can be useful for filtering if you wish to apply

different criteria to the different accounts.

• Pipe�to�program:�this odd and seemingly complex name is an option

for advanced users to apply a terminal window command to the text

of the received message and to apply the rules based on the value re-

turned by the command.

5) Once we have selected the criterion we wish to use to apply the filter, we

will need to specify the condition for applying it. If we wish to use more

than one criterion for the filter (for instance, to apply it to messages from

a specific e-mail account), click on the Add Criterion button and repeat

the above step.

6) In the section of the dialog box marked Then, indicate the action that the

program should take when it comes across a message that meets the set

requirements. The available options are:

• Move�to�Folder: when this option is selected, the program moves the

message to the folder we have specified.

• Copy�to�Folder: this option copies the message to the specified folder.

• Delete: the message is marked as deleted. Remember that the message

can be restored until the folder is expunged.

• Stop�Processing: we can select this action if a number of filters affect a

single message and the necessary actions have already been performed

and the other filters are not required.
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• Assign�Color: this marks the message with the chosen colour.

• Assign�Score: we can assign a score to the message based on its impor-

tance. In subsequent filtering, we can use the score to further classify

the message by priority.

• Set�Status: this action is used to add a status to the message.

• Unset�Status: this option is used to remove a message status.

• Beep: if a message meets the filter criteria, the computer beeps.

• Play�Sound: similar to the above option, this allows us to select our

own sound. For this feature, the computer must be configured correct-

ly to play sounds.

• Pipe�to�program: this is a very powerful option allowing us to per-

form any action with a terminal window command when we receive

a message, providing excellent flexibility. For example, if we have the

necessary privileges, we can send an e-mail message to our computer

from anywhere in the world ordering it to shut down.

7) After specifying all of the elements required to perform an action, we can

add new actions with the Add Action button and repeat the process we

have seen.

8) To complete the creation of the filter, click on OK.

Figure 45. Filter editing dialog box
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Creating a filter often becomes a complex task because we do not always take

account of all the possibilities that we can come across in our everyday work

when we are creating the filter. You can edit or delete filters you have created

in the dialog box brought up by the Edit > Filters menu option. To change the

settings of an existing filter, select the filter you wish to edit and then click on

Edit. This will take you back to the filter editing dialog box you saw when you

created the filter. In this screen, you can change the various options that were

already configured. To get rid of a filter, simply select it and click on Delete.

Figure 46. Dialog box for configuring mail filters.

2.3.6. vFolders

One of the more advanced ways of classifying e-mail messages in Novell Evo-

lution, which we don't find in many other programs, is vFolders. This is the

name for an advanced method of displaying messages that can be very useful

if we receive a lot of e-mail messages and want to keep them organised.
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A vFolder is actually a combination of elements that we have already seen. It

looks like a normal folder but is created in the same way as we might create

a mail filter. With these two elements, we create a powerful display tool for

messages that are actually in other folders but which we see grouped by a

selection criterion.

If the messages that reach our mail server meet the filtering requirements of

a given vFolder, they will automatically appear in it. And, if we delete the

message, it will also be deleted from its original location and any vFolders that

it might be in. Thus, we can work with vFolders as we would with any normal

mail folder.

The latest versions of Novell Evolution come with predefined vFolders to help

us to understand this concept better. If we go to the folder selector beneath

the toolbar and select the vFolders group, we will see three vFolders that have

already been created: Important mail, Unmatched and Unread mail. Of these

three, the one that could cause the most confusion at this time is the second,

Unmatched, which is the destination for messages that cannot be placed in

the other folders because they do not match the criteria of any vFolders. The

Unread mail vFolder contains all mail marked as unread, while Important mail

contains all messages marked as important.

We will now look at the steps to take to create a vFolder. You will see that the

process is very similar to the one used to create mail filters, which we saw in

the previous section.

1) Select the Searches > Edit Saved Searches menu option.

2) Click on Add.

3) Type a name for the vFolder in the Rule name field.

4) Then select the search criterion for the messages you wish to add to your

vFolder. The message parts that can be used are:

• Sender: the sender's e-mail address.

• Recipients:�the recipients of the message.

• Subject: the subject line of the message.

• Specific�header: the filter can search in any part of the message header

that we tell it to search in. Type the header field in the first text box and

the text to search for in the second. Bear in mind that the program will

only search for the first instance. If the header contains two values that

are the same, filtering will only take into account the first one.
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• Message�body: the actual body text.

• Expression: if you know Scheme programming language, you can use this

option to enter a search expression.

• Date�sent: messages are filtered by the date on which they were sent. You

must first choose the message condition (is, is not, is before, is after) and

then the date. The filter will compare the message date field with the cur-

rent system date and time or with a date specified in the calendar. Mes-

sages can even be filtered by a specific time interval, such as messages from

the previous week.

• Date�received: this field is used in the same way as the one above but

compares the date on which we received the message not the date on

which it was sent.

• Label: e-mails have a standard priority scale that goes from –3 to 3, from

least to most important. These values can be used to perform a variety of

actions. We can also change this priority using other criteria (sender, date

received etc.) and subsequently filter these messages ourselves based on

this priority.

• Size�(kb): The size of the message in kilobytes, including attachments.

• Status:�Messages can be filtered by their status. This can be: Read, Replied

To, Important and Draft.

• Flagged: indicates whether the message is flagged.

• Attachments:�tells us whether a file is attached to the message.

• Mailing� list: this filter is used to establish whether the message comes

from a mailing list and to act accordingly. We can check whether a message

has come from a mailing list using the values in its header.

Once you have selected your criterion and confirmed your options, choose

the folders where you want to search for messages that meet the specified

characteristics. The available options are:

• Specific�folders�only. Obviously you will need to type in the names of

the folders in this case.

• All�local�folders.
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• All�active�remote�folders. Remote folders are considered active when con-

nected to the remote mail server. If you are not connected, the vFolder

will not contain any messages.

• All�local�and�active�remote�folders..

Thus far we have looked at Novell Evolution's main features for e-mail. We

think that you will have enough information here to begin using the program

to meet your average e-mail needs. In addition to these features, we should

point out that Evolution is a very powerful, user-friendly program that far

outshines similar programs for GNU/Linux or any other operating system.
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3. Contact manager

This section will look at how to use the program's built-in contact manager,

which lets users carry out this task in a very intuitive way. To access the con-

tact management tool, simply click on the Contacts button on the vertical

shortcut bar. This will bring up a very easy to use interface.

As you can see, the toolbar is very straightforward compared to the one used

by the e-mail management feature. The buttons on this toolbar are as follows:

• The New button changes here from a new e-mail message to a new contact.

While we are working with contacts, this will be the default value. Click

on it to create a new contact card. Another very quick way of creating a

new contact is to double-click on a blank space in the list of contacts.

• We can use the arrow that appears behind the New button to select the List

of Contacts option, which will then allow us to create a list of individuals

grouped by common features, such as a list of classmates.

• The Send/Receive button is used to synchronise contact information over

networks, should you use this feature (more common in business).

• The toolbar printer button is used to print one or more cards. The printer

must be configured correctly in the system to use this option.

• The trash button is used to delete selected contacts immediately.

• The button with a stop sign is used to stop network data synchronising if

you are working on a network.
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Figure 47. Main contact manager window

The rest of the screen contains your contact information. To the right of the

main window, we can see a series of buttons ordered alphabetically that are

used to select the contacts beginning with this letter. If the window is too

small to fit all of the letters in, a vertical scroll bar will appear automatically.

3.1. Contact editor

The contact editor is the tool used to add new cards or to edit existing ones.

If you want to edit an existing card, simply double-click on it to open the

contact editor. The fastest way of creating a new card is to click on the New

toolbar button as we saw in the previous section.

You can also create a contact card while you are using the e-mail or calendar

manager. To do so, right-click an e-mail address or message and select the

Create Card for this Address or Create Card for this Sender options. These

options will also take you to the program's contact editor.

The contact editor screen has three tabs. The Contact tab contains basic infor-

mation, Personal Information is used to add more detailed information about

this contact and Mailing Address is used to synchronise information on the

availability or calendar of this person over the Internet if the contact makes

this information public. You are unlikely to use this program feature.
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Figure 48. General contact editor tab

The Contact tab has seven sections, each with an icon indicating the type of

information you can enter: face, telephone, envelope, globe, house, filing cab-

inet and a suitcase, which represent, respectively: name and company, tele-

phone numbers, e-mail address, website, postal address, contacts and cate-

gories.

We will now look at the fields with advanced features:

• Full�Name

The Full Name field is used by the user to directly enter a contact's full name.

However, you can also click on the button of the same name to bring up a

wizard in the form of a dialog box to enter this information.
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Figure 49. Full name entry dialog box

A general guide for entering values in this dialog box is:

• Title

Here, you can enter a title yourself or choose one of the preset menu titles.

• Name

Here, you enter the name of the person.

• 2nd�name

If the person has a second name, you can enter it here.

• Surname

Enter the contact's surname here. Cards are sorted by this value.

• Suffix

If our contact has a suffix to his or her name, you can enter it in this field.

You can also use one of the preset options.

Be careful entering the names of your contacts because the program uses these

names to sort the contacts and it will be the most common search method

if you have many contacts. The name is also used as an ID to save card data

internally. Hence, it is very important to be coherent in the way you enter the

data and to always use this same criterion.

• Multiple�field�values

The arrows in the form of upside-down triangles next to some fields can

be used to enter additional data on the contact. Although the program

will only display one of the types of data selected, they will all be saved to

the card and we will be able to access them in the same way.

The Details tab is very easy to use and contains the following fields:
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• Suitcase, for the person's professional information.

• Face, for personal information.

• Map�of�the�world, for other information.

Figure 50. Contact editor details tab

3.2. Searching for contacts

The program offers the same search functions for contacts as it does for e-mail

messages. We can also use the search bar in the top part of the window, under-

neath the toolbar. For quick searching, first choose the location for the type of

search you wish to perform in the first drop-down list in the search bar, enter

the text and click on Search Now. When you have finished with the cards you

searched for, click on Clear to return to the normal contact view.

For an advanced contact cards search, select the Advanced option in the search

bar box containing the list of criteria or use the Tools > Search for Contacts

menu option. Either of these two options will bring up the advanced search

dialog box. We saw a very similar window for creating vFolders and message

searching so you should have no problems with this one.
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Figure 51. Advanced search dialog box

3.3. Contact groups

Organisation of the list of contacts is similar to that of the e-mail manager

in that we can use folders to organise it, although we cannot use vFolders.

Nonetheless, as we shall see, we can sort each contact card into different cate-

gories that we can create to suit our needs. We will now take a look at different

ways of organising cards using contact groups.

The easiest way to group contacts is with the use of folders, as we saw for

e-mail. Selecting contact cards as elements of one or more categories, however,

gives us greater flexibility. And thirdly, straightforward contact lists can be

used to send e-mail messages to the group of people in the list as if we were

sending a single e-mail message.

3.3.1. Folders

By default, all the contact cards we create are sent to a Contacts folder in our

local folders. As we saw in the e-mail manager, we can create a new folder

with the File > New > Folder menu option and locate it where we wish in

the folder tree. Obviously, you will need to make sure that you have created

a Contacts folder type, which will be the default option if you create it when

you are in the contact manager. To move a contact from one folder to another,

simply drag it as you would with an e-mail message. Note that you cannot

place a contact in two different folders.
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Figure 52. Creating new folders dialog box

3.3.2. Categories

Another way of grouping contacts is with the use of categories. We can place

each card in a specific category. For instance, you could put a classmate in

both the studies category and the friends category. To specify a category for

a new contact, open the contact editor (either by creating a new contact or

by double-clicking on an existing contact) and select it with the Categories

button in the bottom left of the window. This will open the categories editor

where you can select all the categories you would like for this contact or, if

necessary, create new ones.

Figure 53. Categories editor window

3.3.3. Lists of contacts

Lists of contacts are useful if we need to send an e-mail message to a group

of individuals as if they were just one person. The steps for creating a list of

contacts are:

1) Open the list creation dialog box using the New toolbar button or the File

> New > Contact List menu option.
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2) Enter a name for the list in the Contact List editor.

3) Enter the names or e-mail addresses of the contacts you wish to add or

simply drag them from the main window.

4) Choose whether to check the Hide Addresses When Sending Mail to This

List option. When this option is marked, the recipients of messages from

the list will not see the addresses of the other list contacts when they re-

ceive a message. It is best to keep this option checked, particularly if you

use long lists. This option has the same effect as using the BCC field for

recipient addresses in the e-mail program.

5) Once you have finished the list, click on Save and Close to save it. The

list will appear as another contact card and you can in fact use it as if it

were a normal card.

To send a message to the list, create a new e-mail message and enter the name

of the list you have created as the recipient. Another option would be to right-

click the list and select the Send Message to Contact option.
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4. Calendar

The last feature of the program that we will look at is the electronic agenda or

calendar. To access this, select Calendar from the vertical shortcut bar.

Figure 54. Overview of calendar management

The buttons to the far right of the toolbar can be used to configure the main

window calendar view. The program comes with a series of preconfigured op-

tions: Day, Work week, Week and Month, but you can customise these views

using the calendar in the top right of the window by selecting the days you

require. To select more than one day, hold down the left mouse button and

move the cursor over the days. The calendar view will automatically be up-

dated when you release the mouse button.

The Prev and Next toolbar buttons can be used to move back and forward

through the pages of the calendar. The scope of the movement will depend

on the selected view. The program moves from day to day in day view and

from week to week when we are in week view The Today button between the

two arrows takes us to today, as we might imagine.

To jump to a specific date, click on the Go to button and select it from the

calendar that pops up.

4.1. Creating appointments

As has been the case for most of the features we have seen, there are a number

of options for creating an appointment in the calendar. We can select the File

> New > Appointment menu option or click on the New toolbar button. A
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quicker and more intuitive option is to search for the time and date of the

appointment and click on the corresponding blank space in the calendar. If

you do this, you have two options. If you click once on the blank space, you

can enter the text summarising the appointment in the calendar. If you dou-

ble-click, the appointment editor dialog box will appear.

Figure 55. Appointment editor dialog box

Every appointment you create must have a start and end. If you did not bring

up the appointment editor in the calendar, you will need to manually enter

these values. You can also select the All Day option, in which case the ap-

pointment will appear in grey underneath the date. This will prevent conflicts

with other appointments. If you create an appointment at the same time as

another, the two appointments will appear one beside the other.

The program also supports time zone specification in the event that the cal-

endar is shared with other people in a different time zone to us. If this is the

case, it is important to specify your time zone correctly to avoid errors. The

steps for configuration of this feature are as follows:

1) Go to the Tools > Configuration...> Calendar and Tasks menu option.

2) In the General tab, go to the Time Zone section and click on the button

with a globe on it.

3) Click on your city or a city close by that is in the same time zone. Then

click on OK.

The Reminder tab can be used to configure a series of alarms to alert us of

appointments at a user-settable time before they begin. There are two types

of alarm:

• Display�a�message

A dialog box appears on screen with a reminder at the set time.

• Play�a�sound
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The system delivers a sound. Your computer must be configured correctly.

• Run�a�program

This option launches a program at the indicated time. You can enter the

name of the program in the text field or use the Search button to select it.

The Classification field is only used if your calendar is synchronised over a

network. The default category is Public, which means that it can be seen by

anybody with access to the network calendar. The Private category increases

the security level, which is maximum when Confidential is selected.

We are normally busy when we are in an appointment so the default value of

the Show Time As field is Busy. If a calendar is shared by several people, this

option can be useful for letting others know when you are free.

The program allows us to categorise appointments, which makes organisation

easier if we have a lot of them. To access these categories, click on the Appoint-

ments tab button. Inside the category selection dialog box, select the ones you

need by clicking on them. You can also create new categories and add them

to this list. In the selection dialog box, click on the Edit Master Category List

button and then on Click Here To Add A Category.

Categories can be used to group all of your appointments for similar activities.

To do this, enter them manually in the categories field of each appointment.

The Recurrence tab is used to define repeat appointments, which can range

from once a day to once every 100 years. This time range should be sufficient

for our needs. We can also choose a time or date for this event to stop recurring.

Recurrence is made more flexible by exceptions, which let us select individual

days on which the event will not recur.

Once you have finished entering all of this information, click on the disc but-

ton on the toolbar and close the editor dialog box. You can change all of the

data you have entered later on by clicking on the appointment in the calendar.

4.2. Sending invitations by mail

Novell Evolution has a quick and easy way of sending out invitations to people

who have to attend an appointment or meeting in which replies are managed

automatically.

When we create a group meeting, we can mark the people affected in sever-

al categories as attendees. When we save the details of the appointment, an

e-mail message will automatically be sent to each person with all of the infor-

mation about the event. The e-mail will give them the option of responding

to the invitation. If you simply wish to announce the event to certain peo-

ple and do not want to receive information from attendees, you can use the
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Actions> Forward as iCalendar option that appears when you right-click the

appointment. This will open a new e-mail message with the meeting informa-

tion attached but without the auto-reply message.

The steps for scheduling a meeting are:

1) Select an appointment created previously and right-click on it. Then select

the Schedule A Meeting option.

2) If you have more than one program identity, you will need to select the

correct one from the Organiser field.

3) Click on the space entitled Click Here To Add An Attendee and enter the

name and e-mail addresses of the people you wish to invite. You can also

select attendees from the cards in your list of contacts.

4) When we save a meeting, an e-mail is automatically sent to all attendees.

Meeting invitations are sent by e-mail as message attachments in iCal format.

To respond if the text message does not appear, click on this and select View

Attachment Inline. The recipient will then be able to view all the information

concerning the invitation and select the appropriate reply. The program offers

three preset options:

• Accept

• Tentatively�accept

• Decline

Figure 56. Invitation to a meeting sent by e-mail
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When you click on OK, a message is sent to the organiser with the response

you have selected. If you have agreed to participate, it will automatically be

added to your calendar. However, there is a slight problem with this. The event

can only have one organiser and any changes you make to it can be overwrit-

ten if the organiser updates the invitation. If you need to change something

in an invitation sent to you for any reason, it is best to contact your organiser

for him or her to make the relevant changes.

Figure 57. Response to an invitation received by e-mail

When you receive a reply, you must view it online in the e-mail viewer. To do

this, click on the attachment and select View Inline if the attachment is not

automatically displayed. Click on Accept at the end of the message to update

the list of attendees.



GNUFDL • PID_00148478 70 Novell Evolution. E-mail manager and personal information manager

5. Tasks

The tasks panel feature lets us save a list of tasks without assigning them to

a specific calendar date.

We can access the task panel from the calendar or from the shortcut on the

vertical bar. We can also access a task folder from the program's folder tree.

In the calendar application, this option is located in the bottom right of the

window but is much easier to access in Task View.

Figure 58. View of Novell Evolution's Task Manager

To create a new task, simply click on the space containing the text Click To Add

A Task and enter a name. Once you have typed in the name, press Enter for

the task to be added to the Task List. To configure more options, double-click

on it to bring up the Task Editor dialog box.
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Figure 59. Task Editor dialog box

This first screen contains a number of sections, which we will now look at

briefly:

• Summary:�description of the task that will appear in the To Do list.

• End�date: the date on which the task must be completed. This can be

entered in the text field or selected from the calendar.

• Start�date: the date on which you expect to begin to work on the task.

• Description: this field is used to add more detailed information on the

task than that offered in the summary. For instance, we can enter the

progress made with the task.

• Classification: if we are sharing the calendar on a network, this field in-

dicates the visibility of the task.

• Contacts: we can add contacts to the task to share it with others.

• Categories: if we have created a number of tasks, we can classify them

into different categories to help us organise them.

The Details tab can be used to set values such as the priority and progress of

the task. Lastly, the Assigned tab can be used to add contacts and their roles to

the task. After entering the necessary data, click on the Save And Close button

of the dialog box toolbar.
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Figure 60. Task editor details tab

To display or edit a task that you have created, double-click on it or select it

and then right-click on it and choose the Open option. Both of these options

will take you to the Task Editor we have just seen. To delete a selected task,

click on the Delete toolbar button. The task summary will be displayed with

strikethrough, as occurs with e-mail messages.

We can also organise task lists with the headers of the columns containing the

tasks. Click on these to choose the method and direction of sorting. You can

also add or remove columns.
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Summary

In this unit, we have seen how to install and configure Novell Evolution and

explained the key features that make it such an excellent group tool, including

its management of e-mail messages and its calendar.

Much of this unit has been concerned with the e-mail management program,

including how to create new e-mail accounts and users and how to compose

e-mail messages in HTML format.

Where possible, we have focused on the security of the program, as in the

possibility of sending and receiving encrypted messages through keys gener-

ated with the GPG program.
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Introduction

The OpenOffice.org suite, born of the project of the same name created by

the US company Sun Microsystems, represents of the biggest free software ad-

vances of recent years. To be able to compete face-to-face with other business

solutions and platforms, it is essential to have a tool that can boast the same

features as the competition. Nowadays, we cannot imagine a production en-

vironment without the ubiquitous Microsoft Office suite with its Word, Excel,

Access and PowerPoint. In this unit, we will look at an alternative that we

really need to start taking seriously.

This project dates back to the StarOffice package of a German firm called Star-

Division, which began to develop a comprehensive cross-platform tool for of-

fice work in the 1980s. This package became increasingly popular towards the

end of the 1990s in UNIX and free software environments, though it did not

have the blessing of the movement's gurus or many users because it was a

proprietary project. Nonetheless, many distributions began to include it as an

option in their commercial versions, which included proprietary programs.

In 1999, the German company was taken over by the multinational Sun

Microsystems, which launched the most recent version (5.2), based on the

original StarDivision code, in June 2000. This led to the creation of the

OpenOffice.org free software project, which would form the basis of the new

version of the program.

There are two versions of the program: OpenOffice.org, which is the free

software version with a dual LGPL licence (GNU Lesser�General�Public�Li-

cense) and SISSL (Sun�Industry�Standards�Source�License) and a proprietary

version called StarOffice, produced by Sun Microsystems from the original

OpenOffice.org code but with a number of improvements, such as support,

filters and commercial spellcheckers, templates etc.

This unit on OpenOffice.org will look at the general installation of the pro-

gram. It will focus primarily on the installation of the product as this is very

important if it is to run correctly and it can be rather complicated in network

environments. In the other units, we will look at the configuration of a range

of elements such as printers, fonts and user dictionaries, which can also create

problems.

The main purpose of this unit is to provide a reference should you need to

install OpenOffice.org yourselves and to provide information so that you can

weigh up the various installation options available.
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The main aims of this unit are:

1) to explain how to choose the most appropriate installation for your plat-

form and working environment, and

2) to describe how to install an OpenOffice.org version correctly. We will go

through the process step by step and look at all of the program's options.
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1. Installing the program

This section will look at installation of the application. Although it will focus

mainly on the GNU/Linux environment, we will also discuss its installation

on Microsoft Windows.

The first part of this unit is designed to be a comprehensive source of reference

for the diverse installation possibilities of the program. This means that we

will have to repeat some of the concepts common to the different types of

installation in order to keep the description very clear. However, we will try to

keep repetition to a minimum within the limits of the topic under discussion.

Most recent distributions already come with this program. Whenever we have

access to a package prepared for use with our distribution, this will be the best

one to use. This is basically because due to integration of the product with the

system (for instance, OpenOffice.org will appear in the desktop menus or a

document will automatically open in the appropriate application when you

click on it). The installation program is not always able to integrate with the

system because of the sheer number of distributions available.

1.1. Installation requirements

The minimum requirements for installing the program are not demanding by

today's standards but bear in mind that it might be slower if it is run on a

low-RAM machine. The other requirements are easily met by any computer

on which one of the latest distributions of GNU/Linux can be installed.

• Computer with Pentium or compatible processor.

• A kernel�version�of�2.2.13�or�higher. All distributions now have at least

version 2.4.

• A C standard system library, glibc,�version�2.2.0�or�newer. The latest ver-

sion is currently 2.3.

• An X server (usually Xfree86) for a minimum 256-colour display reso-

lution of 800x600 with�a�windows�manager. Although OpenOffice.org

works with any windows manager, it integrates particularly well with the

GNOME environments and some of the program's accessibility features

do require GNOME version 2.0 or higher.

• 128�Mb�RAM (minimum). Although, as always, the more memory the

system has available, the quicker and better programs will run.



GNUFDL • PID_00148475 8 OpenOffice.org. Program installation

• A�file�system�for�creating�symbolic�links, such as ext2, ext3, reiserfs etc.

All UNIX file systems can create symbolic links but Windows file systems

cannot. GNU/Linux has a file system called VFAT or Virtual FAT, which is

a clone of the Windows and MSDOS file system. OpenOffice.org cannot

be installed on a partition formatted with this file system.

If OpenOffice.org is installed on Windows, the requirements are as follows:

• Microsoft�Windows�98,�ME,�NT�(Service�Pack�6�or�higher),�2000�or�XP.

Although it runs correctly on 98, ME and NT, we recommend using a 2000

or XP system. Some older versions of OpenOffice.org run into problems

with Windows 98, although these do appear to have been resolved.

• Computer with Pentium or compatible processor.

• The OpenOffice.org documentation states that the minimum for system

memory is 64 MB of RAM. We have tried this and recommend 128�MB

for Windows 2000 or XP.

• Administrator�permissions on NT, 2000 and XP systems. For these sys-

tems, you will need to launch installation as the Administrator unless your

personal user already has these privileges.

OpenOffice.org can be used on an old Windows 95 system but only the very

outdated 1.0.x branch. Neither 1.1 nor 2.0 work with this operating system.

1.2. Obtaining a version of OpenOffice.org

There are a number of ways to obtain a version of the OpenOffice.org pro-

gram. One is to go to the program website and download it. However, as this

is a very big program, we recommend trying to obtain it in other ways (IT

publications, promotions etc.), particularly if you connect to the Internet with

a 56 Kb-modem.

The website address of the OpenOffice.org project is:

http://www.openoffice.org.

The site contains all of the documentation you will need to use the program

as well as the most recent versions. Unless you are an advanced user willing

to write and send bug reports, it is always best to use the last stable version

of the program, which is called the Legacy Build in this project. You will find

the link on the main page. There are also links to pages in different languages

offering translated versions of the program.
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There are versions of OpenOffice.org for Windows, GNU/Linux, MacOS X and

Solaris. This means that we can use the same office tool on different platforms

if we need to work on different ones.

Once you have selected your platform, you will be redirected to a page with

links to different servers around the world from to download the program.

Click on the link to download the program. This process will take a while,

even if you have a fast connection.

1.3. Decompressing the installation package

Once the download is complete, you will have the installation package, the

name of which will vary depending on the platform you selected.

If you use Windows and have version 1.1.x of OpenOffice.org, the file name

for Windows will be OOo_1.1_Win32Intel_install.zip. To decompress the file,

you can use Winzip, WinRAR or any other program. Unzipping the package

will produce a folder containing the program installation files.

To obtain the installation folder in GNU/Linux, you will also need to decom-

press the file. To do this, open a terminal and enter the following command:

$tar –xvzf OOo_1.1_LinuxIntel_install.tar.gz

This will create a new folder named OOo_1.1.0_Win32Intel_install or simi-

lar containing the installation files. In this example, to launch installation of

OpenOffice.org, we must enter in the terminal:

$ cd / OOo_1.1.0_Win32Intel_install

$./setup

In this unit, we will look at diverse ways of installing OpenOffice.org, which

means that we will also need to launch installation using different settings.

By typing in these commands, we will launch a standard installation.

If you are working in Windows, you will need to look for the setup.exe file

created during unzipping and run it by double-clicking on it. In both cases,

the welcome screen will appear and installation will launch.

If you want to install version 2.0 or higher of OpenOffice.org, you will already

have native installers for the application. These installers make light work of

installation because the user simply has to double-click on the installer icon

and the program installs almost automatically.
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However, before launching installation, you will need to decide on the type

of installation that best suits your needs. We will look at all of this in the next

section.

1.4. Types of installation

There are two possible ways of installing OpenOffice.org: installation for a

single user and multi-user or network installation. We will now explain the

differences between the two.

• Installation�in�a�single-user�environment allows a user who does not

have full system privileges to install the program in his or her personal

folder. This obviously applies to GNU/Linux but also to Windows versions

allowing multiple users with different privileges: Windows NT4, 2000 and

XP.

In this case, only the user who installed the program will have access

to it and there will only be one customised setup of the program. This

type of installation can be useful if, for example, you already have a copy

of OpenOffice.org installed on the system that works correctly but you

would like to install a new version for testing without modifying the sta-

ble version, which is the version you use for your work.

• Network�installation allows all system users to run OpenOffice.org from

a single installation and for each user to have his or her own profile with

custom settings. In this case, the typical client-server structure is used,

even allowing users to connect remotely to the server. This installation is

recommended for multi-user environments.

We will now describe the two types of installation for the two most com-

mon versions of OpenOffice.org, 1.x and 2.x. Even though we may only

work with one of the two versions, installation of the other one can be

used as a reference for discovering the internal workings of the program.
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2. Installing OpenOffice.org 1.x

As we saw in the previous section, installation for a single user installs the

application on a computer and, as the name implies, it is for the personal use

of the user who installed it. In GNU/Linux, the program is installed in the

user's personal folder (or any other folder to which the user has full access), so

this type of installation does not require superuser privileges. The downside

to this type of installation is that only the user who installed the application

can use it.

2.1. Requirements

The size of the installation will vary according to the elements you install. For

a single-user installation, 190 - 250 MB of free hard drive space are required,

plus another 80 MB for the installation process. These 80 MB will be used for

copying temporary files which will be deleted later, at the end of installation.

2.2. Installation

If you already have an earlier version of the program on your computer (per-

haps you have a version of OpenOffice.org installed on your system but would

like to try a newer one), you will need to modify certain files first. To do this,

go to your user folder. In GNU/Linux, simply open a terminal window or a

file browser (such as Nautilus or Konqueror) and this will take you to your

user folder.

Finding the user folder in Windows is rather more complicated. If you are

working in a system with multiple users, the path to the folder is usually:

C:\Documents and Settings\{Username}\Application Data where {Username}

is the name you use to log on to the system.

The files you need to modify are .sversionrc, if you use GNU/Linux, or

sversion.ini, if you use Windows.

These files contain the path to the version of OpenOffice.org installed on the

system and the number of this version. You will need to check the version

number to confirm that it is not the same as the one that you are about to

install. If it is, uninstall the previous version first. Two installations with dif-

ferent version numbers can coexist without problems on one computer or you

may prefer to update the previous installation, maintaining all of the setting

and data.
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If you have tried any beta versions of the program, it is very important to

uninstall these before launching installation. Beta versions are very useful,

serving for users to detect bugs so that they can be fixed for the final version,

but they can create problems if they are not deleted before the final version

of the product is installed.

At this point, installation can begin. To launch it, run the installation program

called setup.exe in Windows by double-clicking on it in your installation fold-

er. In GNU/Linux, go to the installation folder and run the setup script as we

saw in 1.3.

If everything goes according to plan, the OpenOffice.org installation program

will generate a welcome screen on a blue background. Before fully launching

the process, we will look at some of the general features of this program.

Clicking on the Cancel button at any point during installation will pause the

process. If the program had already started copying the files, we can now tell

it whether we want the installation folder and its contents to be deleted.

We can also access a range of information on the installation process by click-

ing on the Help button found in most of the dialog boxes prompting us to

make a decision. Once you have read the help text, click on the Back button

to return to the installation program window. If you click on the X button in

the top right of the title bar, this will close the application.

Figure 1. Cancelling installation dialog box
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2.3. Welcome screen

Figure 2. Welcome screen

The first screen you will see during installation is the welcome screen. It is an

informative screen so simply click on Next to continue the installation.

2.4. Updating screen

Figure 3. Updating screen

If the installation program finds an earlier version of OpenOffice.org or StarOf-

fice on the system, this screen will appear. The program cannot install very

old versions (only StarOffice 5.2 and OpenOffice.org 1.0 and above) nor can

it install the same version twice.

This window will give you the option of updating the older version or in-

stalling the new one in another folder. There is usually no reason to keep an

older version of the product because the new versions contain numerous im-

provements and corrections.
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After selecting your preferred option, click on Next.

2.5. Important information screen

The important information screen displays the contents of the README file,

which is located in the installation packages folder for later access.

Figure 4. Important information screen

Its contents may be standard but some versions and translations of

OpenOffice.org use it to point out certain features or known problems with

the version. Although this screen is generally ignored, we consider it necessary

to read the file contents at least once. This is particularly important when the

application is going to be used for serious work.

Read the contents and then click on Next.

2.6. License acceptance screen

Figure 5. Licence acceptance screen
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In the licence acceptance screen, you will need to accept the contents to con-

tinue the installation process. If you do not accept the licence, the program

will not install. To be able to accept the licence, you must read it to the end,

which means that you have to place the cursor at the end of the document

to enable the acceptance button.

2.7. Migration screen

Figure 6. Migration screen

If an earlier version of the program was installed on the computer and you

selected the new installation option in the updating screen, this screen will

appear to import your data into the new installation.

If you wish to migrate your personal data and settings, check the Import Per-

sonal Data option.

Then click on Next to continue the installation process.
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2.8. User Data screen

Figure 7. User Data screen

The data entered in this screen are voluntary and used by OpenOffice.org to

customise your templates or documents and to enter your data automatically

if asked. If you are concerned about the privacy of this data, note that it is

saved to your computer and not sent anywhere. You can therefore be abso-

lutely certain that it will only be used for the above purposes.

If you import your data from an earlier version, this screen will not be dis-

played and the imported data will be used instead.

At the end of the installation, you can access and modify these data using the

Tools > Options > OpenOffice.org > User Data menu option.

Enter the data you wish and click on Next to continue the installation process.
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2.9. Installation type screen

Figure 8. Installation type screen

For new installations, this screen allows us to select the type of installation we

require. The available options are:

• Standard�Installation

This installation is recommended for most users as it installs all of the

most common components and document filters. Most translations also

install the dictionaries for the language in question.

• Custom�Installation

If you are familiar with the diverse elements of the program, you can select

them individually with this option. It is useful when you want to install a

document or image filter that is not available in the standard installation.

• Minimum�Installation

This option should only be used if you have limited disk space. In this case,

the minimum components needed to run the application will be installed.

After selecting the type of installation, click on Next to continue.
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2.10. Component selection screen

Figure 9. Component selection screen

If you selected the Custom installation option, you will see this screen in

which you can select the application components you wish to install. When

you begin your selection, you will see that some components have already

been selected by default. These are the standard installation components,

which means that you cannot start the process from scratch; instead, you are

given a foundation on which to build by adding or removing features based

on your requirements.

The method for selecting and deselecting components is as follows: each mod-

ule or component has a plus sign (+) by its name. When you click on this, the

program collapses the list of subcomponents for each. You can click on each

of these subcomponents to check or uncheck them.

The colour of the box in front of each name indicates the component's indi-

vidual status:

• Semi-transparent:�the category contains subcomponents that have been

deselected.

• Dark�blue: all of the subcomponents have been selected.

• Light�blue: the category contains subcomponents that have not been se-

lected.

• White: this category will not be installed.

If you wish to begin the selection process again and mark the standard instal-

lation components, click on the Default button.
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Once you have finished selecting your components, click on Next to continue

the installation.

2.11. Installation folder screen

Figure 10. Installation folder screen

If you chose to update the product, the new version of OpenOffice.org will be

installed in the same location as the previous version. With new installations,

the installation folder or directory can be selected in this window.

The upper part of the window contains a list of all hard disks where the pro-

gram can be installed and the space available on each. The figure indicated in

required installation space is only a rough guide and may vary depending on

the characteristics of the drive's file system.

It is generally best to install the program in the folder proposed by the instal-

lation program. If, for any reason, you wish to install it in another location,

type in the name in the text field to replace the default path. You can also

select the folder by clicking on the Browse button. If the folder you enter does

not exist, the program will ask for confirmation to create it.

Click on Next to continue.
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2.12. Installation options confirmation screen

Figure 11. Installation options confirmation screen

This screen displays all of the installation options you have entered so that

you can check them before the actual copying and registering of files begins.

At this stage, you can still modify these options.

If you are sure that the installation options are correct, click on the Install

button to launch the process. If you need to modify any of the options, click

on Back to do so.

2.13. File type association screen

Figure 12. File type association screen
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The file type association screen is among those that have created the most

problems for Windows users who simply wanted to try out OpenOffice.org to

see what it was like. After uninstalling the program, they found that they could

not open their Word, Excel and PowerPoint documents by double-clicking on

them in Windows Explorer.

This is because some versions of the program came with these as the default

values and people installed OpenOffice.org without paying attention to the

program screens.

In this screen, you decide whether to associate Microsoft Office files with

OpenOffice.org. If you later uninstall OpenOffice.org, we will need to asso-

ciate these file types with Office again. The easiest way of doing this is as fol-

lows:

1) Open the Run dialog box using the Start > Run menu option or by using

the WINDOWS+R�key�combination.

2) Click on Browse and locate the Microsoft Office installation folder, which

is normally C:\Program Files\Microsoft Office\Office. Then find the ex-

ecutable for the application you wish to re-associate (WINWORD.EXE,

EXCEL.EXE, etc ). After selecting it, click on Open.

3) Return to the previous dialog box with the application path in the text

field and the Open: tag. Place the cursor inside the text field and add a

blank space at the end of the file path, followed by '/regserver'. The com-

mand should look very similar to this:
"C:\Program Files\Microsoft Office\Office\WINWORD.EXE" /regserver

4) You will need to repeat the process for each of the applications you wish

to re-associate, searching for the corresponding executable each time:

WINWORD.EXE for Word documents, EXCEL.EXE for spreadsheets and

POWERPNT.EXE for presentations.

If you do not have Microsoft Office on your computer or if you always want to

use OpenOffice.org to open your documents, check the appropriate options. If

you are working on a platform other than Microsoft Windows, you can check

these options without problems.

This window also lets you choose whether to use OpenOffice.org as the default

HTML document editor. You can mark or unmark this option following the

same criteria as above.
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2.14. JRE installation screen

Figure 13. JRE installation screen

Another installation screen that causes issues is the configuration or installa-

tion of Java Runtime Environment (JRE), which we shall now describe.

The two questions users need to ask themselves at this point are: "Is it nec-

essary to have the Java virtual machine installed to use the program?" and

"Which JRE version is the right one?" .

The answer to the first question is No. Most GNU/Linux distributions now

come with the OpenOffice.org program but not with the Java virtual machine

(remember that there is no free implementation of this programming lan-

guage yet although progress is being made in this field).

OpenOffice.org uses Java for a range of advanced options such as macros

and for additional functions that other programmers can implement because

OpenOffice.org can be programmed in this language. Moreover, if a Java run-

time environment is available, the program will use it to perform certain op-

erations.

Generally, if we want to use this program in a productive environment, it is a

good idea to have a Java virtual machine installed on the system. This brings

us to the question of which is the best version. If you can choose between

versions, we recommend:

• For OpenOffice�1.0.xJRE�1.3.1

• For OpenOffice�1.1.xJRE�1.4.1



GNUFDL • PID_00148475 23 OpenOffice.org. Program installation

The diverse versions of JRE can be downloaded from the following Sun Mi-

crosystems site: http://java.sun.com/j2se/, while the main page only allows us

to download the latest versions of the product.

This recommendation is based on the JRE version used during development

of the product. However, this does not mean that other versions will cause

problems.

After these initial considerations, we will now turn to look at the options

of this screen, where you simply need to select the JRE you wish to use for

OpenOffice.org. If you do not have a version installed on your system and do

not wish to install it, select the Do not use Java or JavaScript option.

After completing setup, click on OK to move to the next screen.

2.15. File copying screen

Figure 14. File copying screen

This is where the real installation of components on your computer begins.

The file copying screen is very straightforward and you do not have to do

anything here. The left-hand side of the screen displays the type of operation

being carried out and the estimated duration of the total process.
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2.16. Final installation screen

Figure 15. Final installation screen

Once installation is complete, the program brings up the final screen, where

you simply need to click on Finish to exit the installation program.

In Windows, the process has now concluded. If you use GNU/Linux, you may

be prompted to exit your window manager and re-enter to update the config-

uration. This will depend on the window manager you use.

2.17. Running OpenOffice.org in a single-user environment

In Windows, the installation program will create the application entries in

the Start > Programs menu. These options can be used to access the diverse

functionalities of the program.

You will also see an OpenOffice.org icon in the system tray, normally in the

bottom right of the screen. This is the Quickstarter program that preloads

OpenOffice.org in the memory during system startup for a quicker launch.

You can also access the different program functionalities by right-clicking on

it.

To run the program on GNU/Linux, you will need to find the installation

folder you specified and then type in:

$ cd /program

$ ./ooffice

Alternatively, you could add the folder containing the executable to your sys-

tem PATH variable or create a symbolic link to the windows manager desktop.

However, these other options are beyond the scope of this unit.
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Remember that in a single-user installation these menu options and icons will

only be available to the user who installed the program. The other system

users will be unable to access them.
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3. Installing OpenOffice.org 2.x

Installation for a single user installs the application on a computer and, as the

name implies, is for the personal use of the user who installed it. In version 2.x

of OpenOffice.org, which now includes native installers for each supported

platform, installation is much more straightforward. This section will describe

installation of OpenOffice.org on the Windows platform.

3.1. Requirements

Version 2.x for Windows requires Windows 98 or higher and 128 Mb of RAM.

The size of the installation will vary according to the elements you choose to

install. For installation, you will need approximately 200 MB of free space on

the hard drive plus a further 80 MB for the installation process. These 80 MB

will be used to copy temporary files which will be deleted later, at the end of

installation.

3.2. Installation

If you already have an earlier version of the program on your computer, the

native installer will uninstall the earlier version first, saving the custom set-

tings and user data, before automatically launching installation of the new

version. The updating described will take place if you update to versions of the

same branch. For example, if you have version 1.x installed on your system,

the installer will not uninstall the earlier version.

To install the program, simply run the installation program, which, in Win-

dows for example, will be called Ooo_2.0.4_Win32Intel_Install.exe (the name

of the installer includes the program version so this name will be different for

every new version) by double-clicking on it in your installation folder. The

executable is a native Windows installer so it can be run directly without the

need for unpacking or any other actions.

If everything goes according to plan, the OpenOffice.org installation program

will generate a welcome screen. Before fully launching the process, we will

look at some of the general features of the installation program. Clicking on

the Cancel button at any point during installation will pause the process. If

the program had already started copying the files, we can now tell it whether

we want the installation folder and its contents to be deleted.
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Figure 16. Cancelling installation dialog box

3.3. Installation preparation screen

Figure 17. Installation preparation screen

The first screen you will see during installation is the installation preparation

screen. It is an informative screen telling us that the OpenOffice.org installa-

tion files must be unpacked to a folder in order to begin installation. Just click

on Next to continue.
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3.4. Selecting unpacked file location screen

Figure 18. Selecting unpacked file location screen

In this screen, you need to indicate where you want to unpack the

OpenOffice.org installation files. This does not mean that OpenOffice.org will

be installed in this folder. The file downloaded from the Internet is actually

a package containing the various files needed to install OpenOffice.org. Here,

you are only indicating the folder on your hard drive where you want to save

the files that you will subsequently use to install OpenOffice.org. Once you

have selected the folder, click on Unpack.

3.5. Welcome screen

Figure 19. Welcome screen
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The first screen you will see during installation is the welcome screen. Simply

click on Next to continue the installation.

3.6. License acceptance screen

Figure 20. Licence acceptance screen

In the licence acceptance screen, you will need to accept the contents to con-

tinue the installation process. To be able to accept the licence, we must read

it to the end, which means that you have to place the cursor at the end of the

document to enable the acceptance button.

3.7. User Data screen

Figure 21. User Data screen
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The data entered in this screen are voluntary and used by OpenOffice.org to

customise your templates or documents and to enter your data automatically

if asked. If you are concerned about the privacy of this data, note that it is

saved to your computer and not sent anywhere. You can therefore be abso-

lutely certain that it will only be used for the above purposes.

If you import your data from an earlier version, this screen will not be dis-

played and the imported data will be used instead. At the end of the instal-

lation, you can access and modify this data using the Tools > Options >

OpenOffice.org > User Data menu option.

In this screen, you will also need to select the users for whom you want to

install OpenOffice.org. You can indicate that you only want to install the pro-

gram for the current user or for all users of the computer. Installation for all

users may require more privileges than those held by the current user, in which

case you will need to install OpenOffice.org from an Administrator account.

Enter the data you wish and click on Next to continue the installation process.

3.8. Installation type screen

Figure 22. Installation type screen

For new installations, this screen allows us to select the type of installation

we require.

The available options are:

• Standard�Installation
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This installation is recommended for most users as it installs all of the most

common components and document filters. Most translations also install the

dictionaries for the language in question.

• Custom�Installation

If you are familiar with the diverse elements of the program, you can select

them individually with this option. It is useful when you want to install a

document or image filter that is not available in the standard installation.

After selecting the type of installation, click on Next to continue.

3.9. Component selection screen

Figure 23. Component selection screen

This screen appears if you selected the Custom Installation option. Here, you

can select the components of the application you wish to install. When you

begin your selection, you will see that some components have already been

selected by default. These are the standard installation components, which

means that you cannot start the process from scratch; instead, you are given a

foundation on which to build by adding or removing features based on your

requirements.

The method for selecting and deselecting components is as follows: each mod-

ule or component has a plus sign (+) by its name. When you click on this, the

program collapses the list of subcomponents for each. You can click on each

of these subcomponents to check or uncheck them.

The colour or shape of the box in front of each name indicates the

component's individual status:
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• White: All of the subcomponents have been selected.

• Grey:�The category contains subcomponents that have not been selected.

• Red�cross:�This category will not be installed.

This screen also includes the installation folder. If you chose to update the

product, the new version of OpenOffice.org will be installed in the same lo-

cation as the previous version. With new installations, you can select the in-

stallation folder or directory in this window.

The upper part of the window contains a list of all hard disks where the pro-

gram can be installed and the space available on each. The figure indicated in

required installation space is only a rough guide and may vary depending on

the characteristics of the drive's file system.

It is generally best to install the program in the folder proposed by the instal-

lation program. If, for any reason, you wish to install it in another location,

type in the name in the text field to replace the default path. You can also

select the folder by clicking on the Browse button. If the folder you enter does

not exist, the program will ask for confirmation to create it.

Click on Next to continue.

3.10. File type association screen

Figure 24. File type association screen
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The file type association screen is among those that have created the most

problems for Windows users who simply wanted to try out OpenOffice.org to

see what it was like. After uninstalling the program, they found that they could

not open their Word, Excel and PowerPoint documents by double-clicking on

them in Windows Explorer.

This is because some versions of the program came with these as the default

values and people installed OpenOffice.org without paying attention to the

program screens.

In this screen, you decide whether to associate Microsoft Office files with

OpenOffice.org. If you later uninstall OpenOffice.org, we will need to asso-

ciate these file types with Office again.

3.11. Installation options confirmation screen

Figure 25. Installation options confirmation screen

This screen displays all of the installation options you have entered so that

you can check them before the actual copying and registering of files begins.

At this stage, you can still modify these options.

If you are sure that the installation options are correct, click on the Install

button to launch the process. If you need to modify any of the options, click

on Back to do so.
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3.12. File copying screen

Figure 26. File copying screen

This is where the real installation of components on your computer begins.

The file copying screen is very straightforward and you do not have to do

anything here. The left-hand side of the screen displays the type of operation

being carried out and the estimated duration of the total process.

3.13. Final installation screen

Figure 27. Final installation screen

Once installation is complete, the program brings up the final screen, where

you simply need to click on Finish to exit the installation program.
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4. Advanced installation topics

Before we end this section on the installation of OpenOffice.org, we will take

a brief look at some topics that could be useful to us when working with the

program. We will focus particularly on its uninstall process which, as we will

see, is very straightforward.

4.1. Uninstalling the product

There are two different ways to uninstall the product, depending on the type

of installation (single-user and multi-user), although they are essentially very

similar.

Whether we work in a single-user environment or in a network environment,

the first step is to uninstall the client application. So, in single-user environ-

ments, the uninstall process is carried out as though it were a network client

installation.

Before launching the uninstall program, you must have completely quit

OpenOffice.org; otherwise, the uninstall program will be unable to delete the

files loaded in the memory at this time. This naturally includes the Quick

starter program in the system tray if you use Windows. If you see the blue and

white OpenOffice.org icon in your system tray, right-click on it and select the

Exit option .

The first step is to launch the setup program. In Windows or GNU/LINUX, if

the program is integrated into windows manager, you can launch the Setup

option from within the OpenOffice.org programs menu. If you cannot find

it, it may be located in the program folder of the installation folder. It will be

called setup.exe in Windows and setup in GNU/LINUX.

In more recent versions of the program for Windows, setup can also be ac-

cessed from the Add or Remove Programs control panel.
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Figure 28. Setup program main screen

When you run the program, you will see different options that can be selected.

In this case, we will select the Uninstall option and then Next to continue the

uninstall process.

Figure 29. Deleting configuration files

In this screen, you can select whether to delete all of the configuration files for

the user profile and the documents you have created. After deciding whether

to delete them from the system, click on Complete to run the actual uninstall

process.
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Figure 30. Final uninstall screen

When you see the final uninstall screen, this means that the process has been

successful.

At the end of the uninstall process, if you associated OpenOffice.org with cer-

tain file types, you will not be able to open them from the GUI. This is par-

ticularly true if you use Windows. In this case, you will need to re-associate

the files you opened in OpenOffice.org with other programs in order to have

them open directly when you double-click on them.

4.2. Repair

The repair process can be useful if OpenOffice.org stops working correctly at

some point. Obviously, this program cannot eliminate every error we come

across but it will correct all those caused by the corruption or accidental dele-

tion of some of the component files.

The repair process of OpenOffice.org is very similar to the uninstall process.

Therefore, you will have to follow the same steps as in the previous section

until you reach the main OpenOffice.org setup screen.

At this point, select Repair instead of the Uninstall option. This will launch

the repair program, which will try to restore any files that may be damaged.

4.3. Installation of new components

You may find that you left out a component we needed during the installation

process. For example, you may need to import some obscure document or

graphics format available in OpenOffice.org but which you never thought you

would need.
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To install new components, run setup.exe in Windows, as we saw earlier, or

setup if you use GNU/Linux. Windows has another option that may be more

familiar to its routine users, which is to go to Control Panel and select Add

or Remove Programs. In the OpenOffice.org entry, there should be a Change

button, which will automatically take you to the setup program. This option

may not be available in Add or Remove Programs if you are using an earlier

version of Microsoft's operating system.

Once inside the main setup screen, select the Modify option and then click

on Next.

The component selection window we saw several times during the

OpenOffice.org installation process will appear. To make sure you are in-

stalling the right components and that you have enough disk space, it is a

good idea to mark all of the boxes next to the names in dark blue.

After selecting all of the components to be added, click on Continue to launch

installation, which we have already seen in detail in the previous sections.

4.4. Registration

When you launch OpenOffice.org, a dialog box will appear prompting you

to register. You can register then and there, ask that it reminds you later or

state that you are already a registered user to stop it from ever asking again.

Registration is not compulsory for use of the program. The program asks you

to register to give the OpenOffice.org community a rough idea of how many

people are using the product.

Figure 31. Registration window

If you are working in a multi-user system and wish to register, it is better that

each individual user of the product registers rather than just the server instal-

lation, as this will give the community more accurate statistics on use.
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If you decide not to register straight away and you change your mind later,

you can select the Help > Registration option from the main menu, which

will take you to the website and a registration form.

After registering, you will be assigned a username and password so that you

can change your registration data if necessary.

4.5. Location of components

One of the biggest problems we can have with OpenOffice.org is that if we add

elements that did not come with the installation, such as new templates or

dictionaries, we may not know the real location of certain components. This

can become very complicated if you use a network installation.

To access this information, select the Tools > Options > OpenOffice.org>

Paths menu option, which will bring up the following dialog box. To view all

of the values available, scroll down using the vertical scroll bar.

Figure 32. Path dialog box

If the list contains both the server and client installation paths, this means that

the server folder will contain the original files while the modified files will be

located in the client installation. For instance, the default program templates

will be located in the server installation folder and custom templates will be

in the client installation folder.

Our experience with the program tells us that most of the problems with

OpenOffice.org are caused by incorrect configuration of these settings. In or-

der for the program to function correctly, the paths indicated here must take

us to the right components and files.



GNUFDL • PID_00148475 40 OpenOffice.org. Program installation

Summary

In this unit, we have seen that OpenOffice.org can be installed in two different

ways: for single-user environments and for network environments using the

typical client-server structure.

From a cross-platform perspective, we saw how to download the installation

package from the website, how to unpack it and how to launch the installation

program. We focused mainly on Windows for this and, more importantly, on

GNU/Linux.

We then followed the installation process step by step for each of the instal-

lation modes and as we did so, we looked at the diverse problems that users

can come across and how these can be resolved.
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Introduction

This unit will look at the various options for configuring OpenOffice.org that

will enhance our experience of the program. As usual, we will focus on GNU/

Linux, but we will also deal with the problems that can arise using Windows.

To feel at ease with a computer program, we believe that users must know the

diverse options and features that could cause problems and learn how to solve

these. This make us more confident in our use of the product.

We will focus on the three areas that generally cause the most problems

for users: printer configuration, the compatibility of OpenOffice.org docu-

ments with Microsoft Office and the installation of new dictionaries for the

program's spellchecker.

The main aims of this unit are:

1) to explain how to install and configure a new printer in OpenOffice.org,

2) to analyse the compatibility issues that we could come across when im-

porting or exporting documents to Microsoft Office formats and other

platforms, and

3) to describe the process of installing a new language dictionary for the

program's spellchecker.
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1. Installing and configuring printers in GNU/Linux

If you use the Windows platform, OpenOffice.org can use the printer or print-

ers installed in the system in a transparent way for users. When you want to

print a document, simply select the printer you wish to use and the system

will do the rest. Unfortunately, this is not possible in GNU/Linux.

OpenOffice.org has a utility for configuring printers and fax machines and

for installing typefaces for use in the program's production environment. It is

called oopadmin. We will now explain how to use it.

To run the program, go to the installation folder and type:

$ cd /program

$ ./oopadmin

In a moment, the main window of the printer administration tool will pop up.

Figure 1. Oopadmin main window

This program must be launched following an OpenOffice.org server installa-

tion. The system administrator must then run the oopadmin program as a

superuser. This is so that the printers created can be used by all users of the

computer. Otherwise, each user would have to create his or her own.

After launching the program, the system administrator must create a file with

the general printer options. This file will be located in the /share/psprint/

psprint.conf folder of the main server installation folder. Any change to this

file would have an immediate effect on all client users of OpenOffice.org.
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The system administrator can also add new typefaces, made available to all

client users, but these changes will not be immediate like the printer settings;

instead, users will need to restart the program first.

The following sections deal with the options available in the program.

1.1. Printer setup

The configuration of printing devices is dramatically improved with each

new version of OpenOffice.org. In some GNU/Linux platform environments,

the program can automatically detect the printers installed on the system.

Nonetheless, we will probably still need to manually install these devices in

OpenOffice.org to ensure that the system works properly. We will see that,

although the theory may seem a little complicated, installing a printer is a

relatively straightforward process.

1.1.1. Installing a new printer

We will now look at the procedure for installing a printer:

1) Click on the New Printer option in the bottom left of the window. The

device selection window will appear:

Figure 2. New Device selection dialog box

2) Select the Add Printer option. The driver selection window will now appear.
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Figure 3. Device driver selection window

3) Select the driver for your printer. If you cannot find your model or your

printer does not support PostScript technology, select the generic printer.

In GNU/Linux, the program can only print to printers with PostScript tech-

nology support. If you install a printer on your system that does not support

this technology, you will need to configure the system to be able to use it in-

directly. You can use a conversion program for this. Ghostscript is probably

the most comprehensive of these programs and will no doubt come as stan-

dard with your distribution.

If you have a printer of this sort, you will need to install it as a generic printer

in OpenOffice.org and ensure that the margins are correct when you configure

it.

If your printer supports PostScript, you will need to install the description file

that you will find on the disk or CDROM containing the drivers. You will

be able to identify this file quickly because it has the extension .ppd. You

need to install this to be able to access the advanced features of the printer

(clearly, these will depend on the brand and model of the device), which you

would be unable to access with a generic controller. Moreover – and this is very

important – you can use the default typefaces. Obviously, if you just want to

print, you can also select a generic printer and then set the margins correctly.

As with Windows, most distributions now come with drivers for different

printers, so you will probably already have a PPD that works with your print-

er. If not, you will probably find it on the manufacturer's drivers disk. If this

is not the case, Adobe has a large PPD file on its site: http://www.adobe.com/

products/printerdrivers/.
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If your printer can work internally with more typefaces than a normal

PostScript printer, you will also need to load the AFM files for these typefaces.

Copy these to the /share/psprint/fontmetric folder of the server installation

or to the client installation /user/psprint/fontmetric folder.

The steps for importing drivers during the creation of a new printer are as

follows:

• Click on Import in the device driver selection window.

• Select Browse to locate the folder containing the unpacked PPD files.

• Return to the device driver selection screen and select the driver that you

have just installed.

You can also delete the device driver when you create a new printer. Simply

select the driver and click on Delete.

If you want to delete a device control, be careful not to delete the generic

driver because OpenOffice.org will not work properly if you do. As we ex-

plained earlier, if you delete a driver, it will disappear from all clients using

this OpenOffice.org installation as a server.

Figure 4. Command Line selection window

4) In the command line selection window, select the command that

OpenOffice.org will use to print on the printer. This command is lp –d queue,

where queue is the name of the printer queue. After selecting it, click on Next.
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Figure 5. Printer name selection screen

5) Enter the name of the printer in this window. This is the name you will

see in OpenOffice.org in the printer selection dialog box. You can also decide

here whether to make this your default printer. Once you have made your

choices, click on End.

6) When you return to the main screen, click on Test Page to check that the

configuration is correct. If the page does not print or prints incorrectly, you

will need to check the printer settings.

1.2. Changing the settings of a printer

After installing a printer, we can modify its settings using the oopadmin pro-

gram. Launch the program and select the printer you wish to modify from the

main screen and then click on the Properties button.
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Figure 6. Properties window Commands tab

The properties window will appear with several tabs. Here, you will need to

specify the characteristics based on the PPD file for the selected printer. To do

this, select the command from the list. You can also delete commands that

you do not need using the Delete button.

Figure 7. Properties window Paper tab

The paper tab is used to specify options such as the printer's paper size and

format, as well as tray properties. The values entered here will be the default

printer values in OpenOffice.org. Remember that not all values are available

for all printers as these will depend on the specifications in the PPD file.
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Figure 8. Properties window Device tab

The device tab is used to enable the printer's special options. For example, if

your printer can only print in black and white, you should specify Grayscale

in the list of colour options. These commands and their meanings should be

in the printer manual or on manufacturer's website. If their function is not

entirely clear, look there first.

Figure 9. Properties window Font Substitution tab



GNUFDL • PID_00148480 14 OpenOffice.org. Basic program setup

The Font Substitution tab is used to select an internal printer typeface for

each of the fonts installed on your computer. This will considerably reduce

the volume of data sent to the printer and the time taken to print documents.

We can enable or disable substitution for each individual printer installed on

the system.

Figure 10. Other Options tab

In the Other Options tab, you can enter the correct margins for your printer if

you are having printing trouble. You can also add a description of the device

in the Comment text box, which will be displayed in the OpenOffice.org print

dialog box.

Remember that many of these settings can be specified in the OpenOffice.org

Print or Print Settings dialog box, so it is not necessary to launch oopadmin

to modify settings. In fact, we recommend only using it to access the device's

advanced features.

1.3. Changing the name or deleting a printer

You can change the name of a printer or delete it from the main window of

the oopadmin utility. To do so, select the printer you wish to delete or change

the name of and select the button to perform the action.

If you wish to change the name, type a new one in the dialog box that appears

and then click on OK. This name cannot be the same as that of any other

printer installed on the system and it must be meaningful enough for you to

find it quickly if you have a lot of devices installed (if you work on a network,
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for example). The printer names must be the same for all users because during

document exchange, the selected printer will not change if a user has the same

printer available with the same name.

If you wish to delete a printer, bear in mind that the default printer created

by the system administrator cannot be deleted from this window.

Another option in this window is the possibility of making an installed printer

the default OpenOffice.org printer. To do this, double-click on it in the list of

names and mark the Default Printer option.

1.4. Configuring a fax machine

The oopadmin utility can also be used to configure a fax machine if a package

such as Efax or HylaFax is installed on your system. These and similar packages

with the same features usually come with the GNU/Linux distribution or you

can easily find packages for it.

To use a fax in OpenOffice.org, we need to install it in much the same way as

a printer. The steps are as follows:

Figure 11. Oopadmin main window

1) In the oopadmin main window, select the Add Printer option by clicking

on the corresponding button.
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Figure 12. New Device selection dialog box

2) In the new device selection dialog box, click on Connect a fax device fol-

lowed by Next to continue the process.

Figure 13. Driver selection dialog box

3) In this window, you can select whether to use the default driver or a specific

driver. If you decide to use a specific driver, a window will pop up where you

can select it. Click on Next to continue.
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Figure 14. Command Line selection window

In this window, just as we did with the printers, we need to enter the command

that OpenOffice.org uses to communicate with the fax device. When entering

data in this window, we need to take into account two variables:

• (TMP) which will be replaced by a temporary file. If this variable is in

a terminal window, the fax PostScript code will be transmitted in a file.

Otherwise, standard piping will be used.

• (PHONE) which will be replaced by the fax number of the recipient.

After entering the relevant command line, click on Next to continue.

Figure 15. Printer name selection screen
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In this window, you must name your fax device and determine whether the

fax numbers marked in the text of the document should be deleted when

printing. Click on Finish to complete the creation of a new fax device.

You can now start sending faxes with OpenOffice.org. To do so, you will need

to print the document with the device you have created.

To indicate the fax number of the recipient, enter a text in the document. You

can also create a text field to insert this number from any database activated

in the program. The telephone number format is:

@@#[telephone_number]@@

Where [telephone_number] is the recipient's fax number. A valid fax number

entry might be: @@#9342060801@@.

If these characters, including the telephone number, are not printed, you must

enable the Fax number is deleted from printout option in the Properties op-

tion of the command line selection tab. Nonetheless, if you do not enter a tele-

phone number in the document you send, a dialog box will appear prompting

you to enter it after sending the document to print with the fax device.

In OpenOffice.org, we can enable the option of automatically sending docu-

ments to the default fax. To do this, right-click on the Function bar and then

select from the drop-down list:

Visible Buttons > Send Default Fax.

Select the default fax in:

Tools > Options -> Text Document > Print.

Figure 16. Text Document Print options
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Remember that documents have to be printed as separate jobs for each fax that

you need to send. Otherwise, the first recipient will receive all of the faxes.

Hence, you will need to open the Print Options dialog box by going to File >

Print...> Options and marking Create single print jobs.

Figure 17. Print Options dialog box

1.5. Converting documents to PDFs

The most recent versions of OpenOffice.org already offer the option of au-

tomatically converting documents to PDF format simply by clicking on this

button in the program's Function bar.

It is also possible to create a printer that sends the document to a conversion

program such as Acrobat Distiller on Windows or Ghostscript if you use GNU/

Linux. For reference, we will take a brief look at the steps to take to create this

type of printer with oopadmin:

1) In the oopadmin main screen, select the New Printer option. This will open

the New Device selection dialog box.



GNUFDL • PID_00148480 20 OpenOffice.org. Basic program setup

Figure 18. New Device selection dialog box

2) Select the Connect to PDF converter option and then click on Next to con-

tinue.

Figure 19. Driver selection dialog box

3) In this window, you will need to select the driver you wish to use. If you

are using GNU/Linux, it is a good idea to use the generic driver. In Windows,

the best option is to use the Acrobat Distiller driver if you have this product

installed on your computer. Click on Next to continue.
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Figure 20. Command Line selection window

4) In this window, enter the command for the PostScript to PDF converter

that OpenOffice.org will use. You must also enter the folder in which to save

the PDFs created; if you do not enter a folder, the program will use the user's

personal folder. The variables we can use in the command line are as follows:

• (TMP) which will be replaced by a temporary file. If this variable is in a

terminal window, the PDF PostScript code will be transmitted in a file.

Otherwise, standardpiping�will�be�used).

• (OUTFILE) which will be replaced by the target file, the name of which

will be created from the name of the document.

If Ghostscript or Adobe Acrobat Distiller are in the file search path, you can

simply use one of the preconfigured default command lines. Otherwise, you

will need to modify them.
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Figure 21. Printer name selection screen

5) In this last window, enter the name of your PDF converter and click on

End to finish.

Now, to convert a document to PDF, simply print it to the PDF converter you

have just installed.

1.6. Font configuration

After working with the program for a while, you will realise that

OpenOffice.org does not display the same number of typefaces in all of the

documents you use. This is because not all available fonts can always be used.

We will now look at some of these features:

• Only typefaces in the document's font selector that can also be printed

will be displayed. The program assumes that you will only want to use the

fonts that can be printed out.

• If you are working with a HTML document or online, only the fonts that

can be displayed on screen will be available.

• In contrast, when you use Open Calc or Open Draw, you can use any of

the typefaces that can be printed and displayed on screen.

Where possible, OpenOffice.org always attempts to use the same typeface on

screen and in the printed document. This is referred to as WYSIWYG (What

you�see� is�what�you�get). The program displays any incompatibilities and

problems with fonts in the bottom section of the Characters window, which

can be opened using the Format > Character option in the main menu.
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Figure 22. Character formatting window

1.6.1. Adding new fonts

We can add new typefaces to OpenOffice.org. Depending on whether you are

using an up-to-date or earlier version of OpenOffice.org, these fonts may or

may not be available outside the program. The latest versions of the program

allow font sharing with other applications. This is not the case with 1.0.x

versions, which we can still find in many GNU/Linux distributions.

OpenOffice.org can display and print PostScript Type 1 and TrueType fonts.

The program works best with the latter type so we recommend you use these

wherever possible.

The steps for adding new typefaces to OpenOffice.org are as follows:

1) Launch the oopadmin program as we saw earlier and click on the Fonts

button in the main application window.

Figure 23. oopadmin fonts window
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2) The fonts window displays all typefaces added to OpenOffice.org. Click on

the Add button.

3) A dialog box will pop up where you can enter the name of the folder where

you wish to add new fonts or click on the ellipsis (...) button to select it.

Figure 24. Font selection dialog box

4) A list will appear in the font selection dialog box with all available typefaces

in the folder you specified. To add them all, simply click on the relevant but-

ton. One useful option in this dialog box is the one to create symbolic font

file links, which means that the files will be used from their current location

rather than copied to the OpenOffice.org font folder. If you install fonts from

a device that will not always be available, such as a CDROM, unmark this

option to copy the files. Click on OK to complete the addition of the fonts.

When working on a server installation, fonts must be installed through this

so that the new fonts will be available to all users. If the user has write access

to the server installation folder, the fonts will be installed in the relevant in-

stallation folder of the workstation so that the user who installed them will

have access.
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1.6.2. Deleting and renaming fonts

Figure 25. oopadmin fonts window

In the oopadmin fonts window, you can delete any typefaces you wish. To do

so, simply select them and click on the Delete button. In this window, you

will only be able to delete the typefaces you have added to the program.

You can also change the name of the fonts you install. For this, select the font

and then click on the Rename button. A new dialog box will pop up prompting

you for the new name of the font. If the font has several names, these will be

listed in the list field where you can enter the new name as a suggestion. After

entering the name, click on OK to complete the process.

If you select more than one font to rename, a different dialog box will appear

for each. This will also happen if you select a TrueType Collection (TTC), which

groups several fonts in a single file.
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2. Document interchange issues

One of the most useful features of OpenOffice.org is to be able to use the

same program on different platforms and interchange documents more or less

automatically with Microsoft Office, which is now the most widely used office

suite in the world.

Although compatibility between the two products is very good, particularly

when exporting documents, the formats used by Microsoft are very complex

and only partially documented, which means that absolute compatibility is

impossible. Even different versions of Microsoft programs have difficulty read-

ing documents written in previous versions of the program.

This section will attempt to clarify certain aspects of document interchange

that can create problems for users.

2.1. Document interchange with Microsoft Office programs

We will look at the diverse options to create smoother integration between

OpenOffice.org and Microsoft Office, divided into a number of subsections.

2.1.1. Options for greater compatibility with Word

Although one of the most important and indeed, famed, characteristics of

OpenOffice.org is its compatibility with Microsoft Office documents, difficul-

ties can be found in converting and importing documents to this format. We

will now look at OpenOffice.org's features for improving compatibility.

Firstly, we have to remember that format definitions are not the same in all

word processing programs. However, we can enable certain options to make

Writer behave in a similar way to Microsoft Word, thus enhancing compat-

ibility between the two. The settings we will now see are only available for

documents in use and cannot be defined globally for all documents. Hence,

they must be manually entered for each document with formatting problem

issues relating to these options.

To access the dialog box for enabling these options, go to the main menu

option:

Tools > Options > Text document > General.
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Figure 26. Compatibility settings window

The compatibility section contains three options that may be of use here.

These are:

• Add�spacing�between�paragraphs�and� tables. Open Writer marks the

space between paragraphs differently to Microsoft Word. If you enter a

space before and after a paragraph, this space is inserted in Microsoft Word

documents, whereas Open Writer only inserts the bigger space. If you want

Writer to always insert two spaces, check this option.

• Add�paragraph�and�table�spacing�at�tops�of�pages. When this option is

enabled, the space before the paragraph is also inserted at the top of the

page or column if the paragraph is found at the start of the document.

This also applies to page breaks. If you import a document from Microsoft

Word, the spaces are automatically added in the conversion process.

• Align�stop�tab�position. When this option is enabled, paragraphs con-

taining centred or right-aligned tabs are formatted together in the centre

or to the right. If this option is not enabled, only the text to the right of the

last tab is aligned to the right and the text left of the tab stays where it is.

2.1.2. Automatic conversion of Microsoft Office documents

The easiest and most intuitive way of converting a Microsoft Word, Excel or

PowerPoint document to the corresponding OpenOffice.org format is to open

it and save it in Writer, Calc or Impress format, respectively. OpenOffice.org

can also convert Office documents from Word to an older or more recent for-

mat.
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At this stage, we should point out one exception: password-protected Mi-

crosoft Office documents cannot be imported. Microsoft has not documented

the system it uses to protect its files, so it is impossible to open them. Any

protected documents that you wish to open will simply be skipped.

OpenOffice.org can import documents in a range of formats but it only has a

tool for automatically importing Word, Excel and PowerPoint documents and

their respective templates. One of its top features is the possibility of simulta-

neously converting whole folders of documents and templates.

For our peace of mind, the document converter does not modify the original

documents; instead, it makes copies of them.

The document conversion tool can be launched from the following menu

option:

File> AutoPilot> Document Converter.

The steps to this process are as follows:

Figure 27. First document converter screen

1) In the first screen, you will need to select the type of Microsoft Office doc-

uments you wish to convert. After selecting them, click on Continue.



GNUFDL • PID_00148480 29 OpenOffice.org. Basic program setup

Figure 28. Second document converter screen

2) In the second screen of the converter, select whether to convert the tem-

plates, documents or both and indicate the source and target folders. Click on

Continue to move on to the next step. If you have selected more than one

type of file, this screen will appear for each of the Microsoft Office file types

you marked.

Figure 29. Last document converter screen

3)� This screen confirms the data you have entered. Check it to make sure that

all of the options you have entered are correct. When you are sure that every-

thing is correct, click on the Convert button to launch the process. Informa-

tion on the process will appear on the converter screen. Once conversion is

complete, click on End to close the window.
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When the converted documents are displayed, you will notice that Word doc-

uments of 260 kb are reduced to a size of 50 kb. This dramatic reduction in

size may cause concern initially, but it does not mean that information in the

Word document has been lost.

The reason for it is that Word (like all Microsoft Office documents) uses a bi-

nary format, while OpenOffice.org documents use a plain text file that can be

read with any text editor. This considerably reduces the size. In addition, the

OpenOffice.org format also automatically compresses files, so the document

you are seeing is really a compressed XML document.

If you open this document in Windows with WinRAR or WinZip, you will

see that it is actually a series of text files organised into different folders. This

means that we can be safe in the knowledge that, even if the OpenOffice.org

product were to disappear, we would still be able to recover the information

created with the program. If this were to happen with Microsoft Office, the

problems would be far more serious.

2.1.3. Automatically saving documents in Office format

If you often work with Microsoft Office documents, you may find it tedious

to use the native OpenOffice.org format and always have to convert the doc-

uments to Office format before sending them to others. There is an option

that you can use to define the default format in which to save the document

in the File > Save menu option or when you click on Save document in the

Function bar.

To do this, go to the Tools> Options...> Load/Save> General menu option.

The following window will appear:

Figure 30. General options dialog box for saving documents
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In the Default file format group, you can select a type of document and then

select the default format in which to save it from those available for each

type of document. In this dialog box, select the Microsoft Office format (for

example, Microsoft Excel 97/2000/XP for spreadsheets).

2.2. Interchanging documents between platforms

The previous section looked at the process of installing new fonts that can

be used on-screen and/or printed out, but we have not yet discussed one of

the basic points that need to be considered if we interchange documents with

people using OpenOffice.org on other platforms.

We may well find ourselves in a situation where we need to write a document

such as a presentation on GNU/Linux. We may then have to display our pre-

sentation on a computer with a version of OpenOffice.org installed on Win-

dows. When we do so, we will see that it is displayed very differently to how

we saw it when we were composing it and that the quality of the typeface used

to display the texts is considerably poorer than the original.

This is because we used fonts that were available on our GNU/Linux system but

which are not available on the version of Windows on which we are viewing

our presentation.

There are two basic options for solving these problems. The first and recom-

mended option is to use the same fonts on all platforms. If you have a Mi-

crosoft Windows licence, you can install its fonts on a GNU/Linux computer

or an installation with a different partition. Most distributions have automat-

ic recovery utilities.

If this is not possible, you can use the replacement table for the various fonts

you use on the different platforms. The idea behind this is that if the system

cannot find the font of a document, it will use a standard typeface, which

is very often different to what we expected and very possibly of an inferior

quality.

To make substitutions, go to the Tools > Options... > OpenOffice.org > Fonts

menu option.
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Figure 31. Font substitution screen

1) The first thing you must do is to activate font substitution by marking the

Apply replacement table option.

2) Select the original font and then the font to replace it. One example would

be to replace the StarMath font with Wingdings for working in Windows

or vice versa if you are using GNU/Linux. Then click on the green tick.

3) In the font list, check the Always option for the substitution you have just

made.
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4. Installing and configuring spellcheckers

There are a few easy steps that need to be taken before using a new spellcheck-

er in OpenOffice.org. Small utilities are currently available for installing new

dictionaries more or less automatically depending on our platform. However,

here we will study the manual process because it is the safest and will work in

all scenarios. As we shall see, the process is not at all complicated.

There are two parts to the process. The first is the installation of the dictionar-

ies to a specific folder in our system and the second is enabling of the dictio-

naries so that we can correct our documents with them. Dictionaries consist of

two files with different extensions. One has the extension .DIC and contains

the list of words, while the other has the extension .AFF and includes the affix

combination rules.

Dictionaries can be downloaded as compressed packages from the

OpenOffice.org project website:

http://lingucomponent.openoffice.org/download_dictionary.html.

Most packages contain a document with installation instructions. Nonethe-

less, we will describe the process briefly.

1) Firstly, you must quit the program. In Windows, if you use the Quickstarter

option, you will need to right-click the OpenOffice.org icon in the status bar

and select Exit Quickstarter.

2) You must then copy the decompressed files from the zip package to your

user profile folder, /user/wordbook.

3) You now need to edit the dictionary.lst file, which is located in the folder

where you just copied the decompressed files. For example, you will enter the

following for the Spanish dictionary:

DICT es ES es_ES

This line tells OpenOffice.org that it must use a dictionary containing two files

named es_ES (es_ES.aff and es_ES.dic) in the local configuration specified as

es ES which, in this case, is Spanish of Spain. As you can see, the name of the

affix file and list of words must be the same if OpenOffice.org is to register it.

Now that your dictionary has been registered correctly, you will need to acti-

vate it. Dictionaries are not enabled by default because program performance

is very slow if several are running at the same time. You must therefore man-
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ually enable the dictionaries you wish to use and only ever leave active the

ones you regularly use. This will considerably enhance the performance of

OpenOffice.org. The steps for enabling a dictionary are as follows:

4)�  Launch OpenOffice.org again and go to the following option in the

program's main menu:

Tools > Options... > Language Settings > Writing Aids

and then click on Edit in this window.

Figure 32. Edit modules dialog box

The Edit modules dialog box contains a list of all available languages. The

names of the languages with a blue tick and the letters ABC before them are

the languages for which we have a registered dictionary. As explained earlier,

just because a dictionary is registered, this does not mean that it is enabled.

5) To enable a dictionary for a language, mark the OpenOffice MySpell

SpellChecker option in the spelling group.

If this group does not appear it is because there is no registered spellchecker

for this language. If you have followed all of the steps correctly, make sure that

the values you entered in the dictionary.lst file were correct. All dictionaries

come with a Help file in the compressed package explaining this procedure.

If in doubt, look here for information.

4.1. Advanced dictionary configuration

This section will describe how to install dictionaries on a server installation

and look at some of the problems we may come across when installing dictio-

naries for the OpenOffice spellchecker and their possible solutions.
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4.1.1. Installing dictionaries on a server

From version 1.0.1 of OpenOffice.org onwards, it is possible to install dictio-

naries on a server for remote access by all users. In the previous section, we

saw how to install a dictionary for a specific user, where the files were copied

and changes made in the user profile folder. It is a good idea to allow users

to install the dictionaries they need but it can also be useful to install group

dictionaries for all of the clients of a server installation. This means that inex-

perienced users will not have to install the dictionaries themselves.

The system administrator or anybody with superuser permissions can install

group dictionaries in the /share/dict/ooo/ server installation folder. These dic-

tionaries will be available to all system users. There is no need to describe the

procedure here as it is the same as the one we have just seen.

However, users will not be able to use the dictionary until they exit

OpenOffice.org completely and enable the dictionary using the Tools > Op-

tions... > Language Settings > Writing Aids menu option and the Edit button.

4.1.2. Dictionary paths

Most problems with dictionaries occur because OpenOffice.org cannot find

them, so make sure that the values that were entered in the program are correct

before you start investigating other possibilities.

These values can be accessed from:

Tools > Options... > OpenOffice.org > Paths.

Figure 33. Path configuration dialog box
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In this screen, check that the values for Dictionaries and User-defined Dictio-

naries are correct and that the specified folders actually contain the dictionary

files and dictionary.lst. If you need to edit these values, click on the Edit but-

ton and select the correct path.

4.1.3. Font issues

If the dictionary has been registered and enabled but does not correct (for

example, it highlights all of our words although they are correct), the typeface

used is probably not supported by the spellchecker engine. The two most likely

reasons for this is that you are using a symbol font or that you are working

with a typeface that has not been installed on your system.

This can occur with a font called Thorndale, which is the default font in many

OpenOffice.org versions but which will not be installed on your system un-

less you have installed StarOffice at some point in the past. It can lead to

OpenOffice.org being unable to correct a document properly, though this does

not apply to all versions of the program.
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Summary

In this unit, we have seen diverse ways of configuring and installing devices

in the OpenOffice.org program, which is the main root of problems for users,

and we have looked at possible solutions for these.

We have focused particularly on aspects such as compatibility between

OpenOffice.org and Microsoft Office documents, which is usually one of the

main sources of headaches for users since, for better or for worse, we live in

an information society dominated by Microsoft products.





Open Writer.
OpenOffice.org
word processor
 
David Megías Jiménez (coordinator)
Jordi Mas (coordinator)
Ana-Elena Guerrero Roldán (coordinator)
Jesús Corrius i Llavina
 
PID_00148476



GNUFDL • PID_00148476 Open Writer. OpenOffice.org word processor

Copyright © 2010, FUOC. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free
Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections,
no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled "GNU Free Documentation
License"



GNUFDL • PID_00148476 Open Writer. OpenOffice.org word processor

Index

 
Introduction............................................................................................... 5

 
1. The Writer working environment................................................ 7

1.1. Customising the toolbars ............................................................ 8

1.2. Customising menus .................................................................... 10

1.3. Setting keyboard shortcuts ......................................................... 12

1.4. Changing the size of program elements ..................................... 13

 
2. Basic Open Writer functionality................................................... 15

2.1. Creating a sample document ...................................................... 15

2.2. AutoText ...................................................................................... 18

2.2.1. Specifying new paths ..................................................... 19

2.2.2. Creating new categories ................................................ 19

2.2.3. Inserting AutoText in documents .................................. 20

 
3. Document formatting...................................................................... 21

3.1. Character formatting .................................................................. 21

3.1.1. Creating custom colours ............................................... 22

3.1.2. Using the Stylist in Fill Format Mode ........................... 23

3.1.3. Character formatting dialog box ................................... 24

3.2. Paragraph formatting .................................................................. 29

3.2.1. Tabs ................................................................................ 29

3.2.2. Paragraph formatting dialog box .................................. 30

3.3. Bullets and numbering ............................................................... 36

3.3.1. Creating an outline ....................................................... 38

3.3.2. Configuring numbering, bullets and outlines ............... 38

3.3.3. Position and spacing between levels ............................. 40

 
4. Word Completion and AutoFormat.............................................. 42

4.1. Configuring AutoReplace ............................................................ 42

4.2. Configuring automatic uppercase ............................................... 43

4.3. Turning off AutoCorrect ............................................................. 45

4.4. Word Completion ....................................................................... 48

 
5. Using graphics and sounds.............................................................. 51

5.1. Using the OpenOffice.org picture and sound gallery ................. 52

5.1.1. Creating gallery themes ................................................. 53

 
Summary...................................................................................................... 57





GNUFDL • PID_00148476 5 Open Writer. OpenOffice.org word processor

Introduction

Open Writer is the OpenOffice.org text document creation application. As we

shall see, the program can carry out the same functions as any other program

of this nature on the market and offers filters for other types of document

(Microsoft Word included), graphics support, the creation of books and tables,

non-consecutive selections of blocks of text, version control and the automat-

ic creation of tables of contents.

This unit will deal with general use of the program, but it will not cover the

basics of document composition and editing because it is not the aim here. We

will look at the features of OpenOffice.org for users who routinely use other

text editors, such as Microsoft Word or WordPerfect, so that they can weigh

up the possibility of using OpenOffice.org as an alternative. Nonetheless, we

will cover key concepts when considered necessary.

The main aims of this unit are:

1) to describe the working environment of the Open Writer program in order

to familiarise students with it,

2) to teach students how to use the basic tools for composing and formatting

text documents, and

3) to explain how to set up the text composition help features in order to

adapt them to our working needs.
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1. The Writer working environment

This section looks at the working environment of the Open Writer program,

offering an introduction to familiarise readers with the environment and how

it can be customised. Some of the concepts covered here will also prove useful

for other components of OpenOffice.org.

Writer can be launched from any OpenOffice.org application by selecting the

File > New > Text Document menu option.

Tips can be very useful for learning about the different features of the program.

Tips are displayed for each of the labels and icons on the screen so we can find

out what they do simply by pointing the mouse at them. You can enable or

disable this option using the Help > Tips menu option.

If you need help with a dialog box or window, you can always click on the

Help button or press F1. OpenOffice.org is a very well documented program

and its Help is very good. You should learn to use it whenever you have a

query about something as this will enhance your experience as users.

Figure 1. The Writer working environment
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We will now describe the diverse elements in the program's workspace:

• The Menu�bar contains the various actions that can be carried out global-

ly across the OpenOffice.org program and those that are specific to Writ-

er. New entries can sometimes appear in this bar, such as when you are

working with tables.

• TheFunction�bar indicates the full path of the file being edited and pro-

vides a shortcut to the program's global features.

• The Object�bar is used to apply formatting to the objects you are working

with at a given time. It will most often display text formatting tools but

it may also contain table and drawing tools if you are working with these

elements.

• The horizontal�ruler displays the page dimensions and can be used to

insert tab stops. The measurement units of the ruler can be changed very

quickly by right-clicking on it. Though not enabled by default, the pro-

gram has a vertical ruler too, which is very useful for working with draw-

ings and tables. We will see it shortly.

• The Main�toolbar, positioned vertically down the left-hand side of the

document, gives quick access to the most common word processing func-

tions.

• The Status�bar at the bottom of the screen has a number of functions,

which include viewing page numbers, applying page styles (by right-click-

ing on Standard), changing zoom percentage and changing the default

type of text selection.

1.1. Customising the toolbars

All OpenOffice.org components display lots of icons on screen simultaneous-

ly so that the user can access functions very quickly. To display all of the tool-

bars, select them in the drop-down list that appears after selecting the View

> Toolbars menu option. Here, you can select the toolbars that you want the

program to display. We recommend that you always keep the Function, Ob-

ject and Main toolbars checked as these give access to most of the actions that

you will need.

Most toolbar buttons only carry out one action, which is the one indicated in

the tip that appears when you hover over it with the mouse. However, some

buttons have several functions, in which case you will see a green arrow next
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to the button image. To see all of the button's options, click and hold down

the left mouse button over the image. This can either produce a new toolbar

or display a drop-down list of options.

For example, if you click on the Insert button, the first one on the Main tool-

bar, the Insert Table dialog box will appear. However, if you hold down the

left mouse button as you click on it, a toolbar will appear containing more

buttons with drop-down lists.

Figure 2. Element insertion toolbars

If you often use the various toolbar options, you can click on the blue space

around its title to make it into a real toolbar that can be dragged to any point

of the screen for direct access to its various functions.

The appearance of the Object bar changes according to the context in which

you are working. For example, its buttons will vary if you are in the middle

of a paragraph of text or a table.

Figure 3. Object bar in text context

For paragraphs, it displays basic text formatting elements, which you will be

very familiar with at this stage.

Figure 4. Object bar in table context

If you are inside a table, it will display the most common actions for working

with tables. Very often in a table we need to use text formatting tools. To do

this, simply click on the button with the blue arrow at the end of the Object

bar. This button allows us to manually toggle between the two contexts.

If you find that the buttons on the Object bar are the fastest and most conve-

nient way of formatting text, you may need to add new features to the bar's

default ones. OpenOffice.org only includes the most common ones by default.

To view all of the available options, simply right-click the relevant toolbar and

select the Visible Buttons option from the menu. This will open a drop-down

list where you can select all of the available actions for the bar that you just

clicked on.
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If, besides modifying the available buttons, you wish to organise them using

a different criteria to the program, you will need to use the customise toolbars

tool. To call it up, right-click on the toolbar you wish to customise and select

the Customize option.

Figure 5. Customise toolbars tool

The left-hand list contains all of the program's functions grouped into cate-

gories, which you can add to your toolbar by clicking on the Add button.

The Move Up and Move Down buttons move the added actions along the bar

while the Icons button is used to customise the button images. Note that some

of the program features (the least common ones) do not have a predefined

image. To restore the toolbar to the default program values, simply click on

the Default button.

1.2. Customising menus

Finally, some computer programs have adopted a strategy of hiding menu op-

tions when they are unavailable. In this case, the menu options that cannot be

accessed simply disappear instead of being greyed out. This can lead to con-

fusion as users may think that the program feature does not exist or that there

is a problem with the program. In contrast, if an option is greyed out and dis-

abled, the user will realise that the option is not available in this context. The
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OpenOffice.org program behaves differently here, depending on the version

you use. To enable inactive menus, go to Tools > Options > OpenOffice>

View and mark the Inactive menu items option.

It is possible to customise application menus, just as we did with toolbars.

Normally, however, it is much quicker to access functions through toolbars,

so we would recommend using these for the more common activities. Besides,

customising menus is for very advanced users. Your average user would not

modify default program options.

To go to the menu configuration tool, go to Tools > Configure and select the

Menu tab.

Figure 6. Customise menus tool

Each of the different OpenOffice.org applications (Writer, Calc, Impress etc.)

has its own menus, so be sure to access this option from the application you

wish to customise. Customised menus are saved in files with the .cfg extension

in the /user/config folder of the personal profile of each user. When we create,

modify or save menus, we make changes to these files.

The customising procedure is similar to the one seen above. New menus and

items can be created and existing ones can be deleted. In this case, the func-

tions are divided into categories and subfunctions in the two windows in the

lower half of the dialog box.



GNUFDL • PID_00148476 12 Open Writer. OpenOffice.org word processor

1.3. Setting keyboard shortcuts

Another useful option of this configuration dialog box can be found in the

Keyboard tab. We can also access it from Tools> Configure...

Figure 7. Customise keyboard tool

In OpenOffice.org, actions can be assigned to keys or – as is more often the

case – key combinations. Some keys already have default actions assigned to

them by the program. These include F11, which launches the Stylist box, and

F5, which launches the Navigator. Some actions depend on the application

you are in at the time. In Writer, for example, F12 turns numbering on or off

while in Calc it is used to define a group of cells.

In addition to the program's functions, keyboard shortcuts can also be as-

signed to the macros we create. This allows users to create key combinations

that can be used, for instance, to insert a text for which we would otherwise

need to press a number of keys and set a number of formatting options every

time if we were to create it manually.

The required steps for creating a new keyboard shortcut are:

1) In the key combination list, select the key or combination of keys to which

you would like to assign a function.
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2) In the list of categories, specify the category of the function you wish to

assign. To assign a macro, select the category where you created it. The

actions available in this category will be shown automatically in the func-

tion window.

3) Select the command you wish to assign to the key in the function window.

4) Click on the Modify button. The name of the command will be inserted

alongside the name of the key in the list of key combinations.

Even if you do not want to assign or modify a program key, this dialog box

is the quickest reference for the program's shortcut keys and can be useful for

finding out which key or key combination can be used to perform a given

action.

1.4. Changing the size of program elements

For people with some form of visual impairment or those who simply wish

to work more comfortably, it is important to be familiar with the accessibility

options of OpenOffice.org.

Although it is not the aim of this unit to cover these topics in detail, we will

look at how to change the size of program elements to make them bigger than

normal. To do this, bring up the following dialog box by going to the menu

option:

Tools > Options... > OpenOffice.org > View.

Figure 8. Display options dialog box

Although this window contains various settings, such as the appearance of the

program windows, the options of interest to us here are Scale and Icon size.

For example, we can select a scale of 120% and a Large icon size and click on

OK for the changes to take place immediately in the program interface.
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Remember that any changes made to these options will only affect the pro-

gram display. If you increase the scale, text fonts will appear bigger but their

actual size (the size they will be if they are printed and the size at which other

people will see them) will be determined by the size of the font.
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2. Basic Open Writer functionality

This section will look at how Writer can be used for everyday word processing.

We will begin by creating a sample document that will serve to introduce us to

the basic features of the program and we will then look at the various options

for formatting our text.

2.1. Creating a sample document

We will create a text document to familiarise ourselves with the Writer envi-

ronment. To do so, follow these instructions step by step.

1) Launch OpenOffice.org and create a new text document by selecting the

File > New > Text Document option from the main menu. This will open a

new window.

2) Type the following text in the blank document: "Planning for UOC work".

3) Press the F11 key to open the Stylist and check that the title of the dialog

box reads "Paragraph Styles" by clicking on the first button on the toolbar

inside the box. If you click on the other buttons, you can see the different

styles available in the program.

Figure 9. Stylist displaying paragraph styles
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4)� If the size of the text on the screen is too big or too small to work with

comfortably, you can change the scale of the zoom using the View > Zoom

menu option or by double-clicking on the percentage in the program's status

bar.

5) We will now look at the Stylist. The first thing to do here is to click the

mouse to position the cursor somewhere in the text you have entered, and

then double-click on the Heading 1 style in the Stylist. The text will automat-

ically change to adapt to the selection.

6) Press the End key to move to the end of the text and then press Enter to

go to the next line.

7) Type the list of subjects you have this term, separating each one with a new

line. Once you have completed the list, select them all with the mouse and

click on the Bullets On/Off button in the Object bar.

8) With the text selected, click on the Increase Indent button. This will indent

the text to the right.

9) We will now change the formatting of the first paragraph. To do so, go to

the "Planning for UOC work" text, right-click on it and select Paragraph from

the context menu.

Figure 10. Paragraph formatting window

In the spacing below paragraph box, increase the value to 0.5 cm, for example.

When you click on OK, you will see that the distance between the title and

the text has increased substantially.
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10)�To make the title appear more attractive, we are going to change the colour.

To do this, select it again and go to the Format > Character main menu option

and select the Font Effects tab in the dialog box.

Figure 11. Character formatting window

In the drop-down font Color list, select your favourite colour from those avail-

able. Click on OK to see the colour change.

11) Go to the end of the text you have written. If this is the text you have

formatted as bullet points, you will need to press Enter twice: once to move

on to the next line and one to automatically stop bullet formatting. We will

now insert a table.

12) Go to the Main toolbar and press and hold the Insert button until the

Insert toolbar appears. Go to the Insert table button and select the number

of rows and columns you wish to insert. Use two columns and the number

of subjects you typed in for the number of rows, plus one extra for the title.

Therefore, if you entered three subjects, the table will be 4 × 2.

13) In the first row, write "Subject" in the first column and "Hours' study" in

the second. In the rest of the rows, type in the name of the subjects and the

hours you plan to spend studying for them. When you have completed the

table, click outside it.

14) Finally, we are going to insert a header in the document. To do this, go

to the Insert > Header > Default menu option to automatically insert a text

field at the top of the page.
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15) Position the cursor inside the header by clicking on it with the mouse and

then select the fields you wish to insert. For this step, go to the Main toolbar

and click on the Insert Fields button but do not release the left mouse button

until the insertable text fields menu has appeared. Here, you can select the

Date or Page Number options, for example. Inside the header, if you click once

on the tab, you will be taken to the centre of the field and if you click twice,

you will be taken to the far right.

If you have followed this example word for word, you will already be familiar

with the basics of the program and can start working on your documents with

total peace of mind if you are used to working with office suites.

2.2. AutoText

The AutoText feature is used to enter a text or a text combined with other

elements very quickly. It is very useful if you often find yourself writing the

same text over and over, such as an e-mail signature or a document header.

We will now look in detail at how we can customise the program to insert

these items.

1) In a Writer document, create the text you wish to convert into autotext.

You can also add graphics.

2) Select the text you have typed with the mouse and click on the Edit Auto-

Text button.

Figure 12. AutoText dialog box

3) Enter a name for the AutoText in the Name field and its shortcut in the

same field. Choose this carefully because it is very important as we will see

in a moment.

4) In the list underneath the name and shortcut fields, select the category it

should belong to. Categories are simply folders in which to organise our texts.
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5) Click and hold the left mouse button on the AutoText button and select the

New option from the menu. The AutoText is now created. You will be able to

see it in the category you selected and you can insert it if you click on Insert.

2.2.1. Specifying new paths

If you want to use other folders besides the default ones of the OpenOffice.org

program to save AutoText items, you will need to indicate them by clicking

on the Path button, which will bring up the dialog box below.

Figure 13. Select Paths dialog box

This dialog box displays the default paths but new ones can be added by click-

ing on Add and then selecting the folder. To change the program's default

AutoText paths, go to Tools > Options > OpenOffice.org > Paths.

2.2.2. Creating new categories

As we mentioned above, AutoText categories are simply recipients for organ-

ising AutoTexts. The program already comes with some categories but you will

probably need to create new ones to organise these texts according to your

needs.

To create a new AutoText category, call up the AutoText dialog box by clicking

on the Edit AutoText button in the Main toolbar and clicking on the Cate-

gories button. This will bring up the following dialog box.

Figure 14. Edit Categories dialog box

In the Category text field, type in the new name for the category you wish to

create and select the path to its location. If the desired path does not appear

in the list of paths, you will need to create it in the way we saw in the previous
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section. After selecting the name and path of the new category, click on New

to add it. You can also delete categories you no longer need in this dialog box.

Click on OK to save the changes made.

When you return to the AutoText dialog box, you will see the new category.

At this point, you may wish to re-classify elements into the new category you

have created. To move an AutoText from one category to another, simply select

it, and without letting go of the mouse button, drag it to the new category.

As you drag it, a bar will appear to indicate which category you are dragging

the autotext to.

2.2.3. Inserting AutoText in documents

Thus far we have seen how to create AutoTexts and how to organise them, but

we have not seen how they can be used in our documents. The easiest option

is to position the cursor where you want to insert the text and then click and

hold down the Edit AutoText button on the Main toolbar. A list of available

categories will appear. Simply select the AutoText you require to automatically

insert it in the document.

A much quicker way of inserting an AutoText is to use its shortcut. Obvious-

ly, it can be very difficult to remember all of our shortcuts but it is not too

hard to remember the ones we use most often. To insert an AutoText with a

shortcut, type the latter in the document and press F3. For example, to insert

an AutoText called My AutoText with the MAT shortcut, type these three let-

ters in the document and then press F3. This will insert the contents of the

AutoText you have created.
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3. Document formatting

Formatting a text or section of text is one of the basic functions of any word

processing program. In fact, it is essential considering that, when it comes to

creating documents, we spend most of our time on formatting. As a result, we

think that it is important to mention some of the formatting possibilities of

OpenOffice.org.

3.1. Character formatting

To format characters quickly using basic operations, such as changing font

and size and applying styles such as bold type, italics and underlining, we

can use the program's Object bar. This bar will be very familiar to users who

have worked with word processing programs before, but there are two features

worth mentioning here: Character color and Character background, located

at the end of the Object bar.

If you click and hold on these buttons, you can select the font or highlighting

colour.

Figure 15. Character color selection dialog box

Simply clicking on the selected text will apply the last font or highlighting

colour you chose. Any of the colours in the palette can be used or you can

even create your own custom colours.
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3.1.1. Creating custom colours

To define a new custom colour, go to the following menu option: Tools >

Options... > OpenOffice.org > Colors, where you will see the colours in the

system palette.

Figure 16. Colour preferences dialog box

To add a specific colour, select RGB�or CMYK and enter the combination of

values. If you do not know the values or prefer to use your intuition, click

on Edit...

Figure 17. Color selection dialog box

Once you have chosen the colour you require, click on OK to return to the

previous window. In the Name field, delete the name of the current colour and

type in the name you wish to give to your new colour (e.g. "Lettuce green").

Finally, click on Add to insert your new colour in the program palette.
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3.1.2. Using the Stylist in Fill Format Mode

If you have ever used Microsoft Word, you will probably be familiar with the

Format Painter tool, which copies the formatting features from one element

to another. OpenOffice.org has a similar tool called Fill Format Mode. We will

see step by step how this characteristic can help us with our work.

1) Open the Stylist using the Format > Stylist menu option or by pressing

F11. The Fill Format Mode button has a picture of a pouring can on it and is

located in the upper section of the window. Click on it to enable it. The colour

of the button background will change.

Figure 18. Stylist

2) Select the category you wish to apply to the text from the available styles

list. You may wish to apply a style that has not yet been defined to the text,

in which case right-click on the list of available styles and then select New

to set the new style you want to use. If you do not want to enter all of the

options and simply wish to copy the text style as quickly as possible, select

the text with the original style in the document and click on the New Style

From Selection button in the Styles and Formatting box.
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Figure 19. Create Style dialog box

This will bring up the Create Style dialog box, where you will need to enter a

name for the style you have created from the text format.

3) Once you have selected the style, position the cursor in the text or on the

object you wish to format and click on it. The style will be applied to every

element you click on. When you have finished formatting, close the Stylist or

click on the Fill Format Mode button.

3.1.3. Character formatting dialog box

Thus far, we have looked at the more basic features of character formatting.

The advanced options are located in the Character formatting dialog box. To

access these, select the text you wish to format and then to go to the Format

> Character menu option, or right-click the text and select this option from

the context menu. In this section, we will look at the options offered in this

dialog box.

When you select the text to apply character formatting to, be careful not to

select the spaces between the selection and the rest of the text because these

will also be formatted and the result will probably not be as you had planned.

To avoid this, select words by double-clicking on them. If you want to select

more than one word, double-click on one and drag the cursor across the rest

of the words. This will give you greater control over the elements selected.



GNUFDL • PID_00148476 25 Open Writer. OpenOffice.org word processor

Figure 20. Character formatting font tab

In the Font tab, we can configure the following character style settings:

• Font displays the current typeface and allows us to select any of the avail-

able fonts.

• Style allows us to choose a style to apply to the selected font. The list of

styles will vary depending on the characteristics of the font.

• Size allows us to select the size of the font. We can choose one of the preset

values or enter the font size we require, such as 13.5.

• Language mainly used to tell the program which spellchecker to use in the

fragment of text. If you do not select the right language, the spellchecker

will not work properly. Languages with a blue tick on their left have a

dictionary installed in OpenOffice.org, so they can be used for correcting

documents.

The bottom part of the dialog box displays a preview of the selected text as

it will look when the specified changes have been made. Below this box is a

text informing the user of any conflicts with the selected typeface. If we see

the text "The same font will be used on both your printer and your screen",

this tells us that there are no conflicts.



GNUFDL • PID_00148476 26 Open Writer. OpenOffice.org word processor

Figure 21. Character formatting Font Effects tab

This tab contains more advanced aspects of font formatting. These are:

• Underlining allows us to choose between different types of underlining

for the selected font. The font is not underlined by default. The colour of

the underlining may differ from the colour of the font, so we must also

select a colour.

• Effects can be useful if you need to automatically control character capi-

talisation. For instance, this feature can be used to automatically change

all of the letters in the selected text to capitals.

• Strikethrough�is used to select different types of strikethrough effects for

the selected font. Letters appear without strikethrough by default.

• Relief�lets us specify whether to give the font a relief effect and what the

characteristics of this will be.

• Font�Color is used to change the colour of the characters based on the

options available in the system palette. We have already seen how to create

custom colours in this unit.

• Individual�words is a very interesting feature that can be turned on if

you enable font underlining or strikethrough. When this is checked, un-

derlining and strikethrough are not applied to spaces in the document.

• Outline,�Shadow�and�Blinking are some of the other effects that can be

selected individually or in combination with others.
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Figure 22. Character formatting Position tab

We have divided the options inside this window into their three broad sec-

tions:

• Position is useful for specifying the subscript and superscript options, as

we can manually enter their height and relative size. Or we can mark the

Automatic option to accept the program's default values.

• Rotation�/� scaling rotates the text on a vertical axis so it is read from

bottom to top (90°) or from top to bottom (270°). If you want the text to

take up all of the available space on the page, check the Fit to line option.

You can also customise font width in this section using the Scale width

option. Values above 100% will make the font wider while values below

this figure will make it narrower.

• Spacing allows us to expand or condense the space between characters by

the number of points entered in this field. If you check the Pair kerning

option, letters will be placed closer together to enhance the appearance

of the text.
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Figure 23. Character formatting Hyperlink tab

If you want to make the selected text into a hyperlink, this tab has all the

options you might need.

• URL, enter the name of the website or file you want to open when the

hyperlink is clicked in this field. You can also select it by clicking on the

Browse button.

• Text allows you to enter the hyperlink text that will be seen in the text

document.

• Name allows you to enter a name for the hyperlink. OpenOffice.org uses

the HTML NAME label for this.

• Target�frame used to indicate the name of the frame in which the associ-

ated file or link should be opened. You can also select one of the standard

default frames. If you leave this option blank, the link will open in the

current location.

• Events this is very useful if you want a given event to take place when

the hyperlink is clicked. For instance, if we want a program macro to run.

You will need to specify the action in the dialog box that appears when

you click on the button.

• Visited�links allows us to specify the style of links with this status. For

this, select an available style from the Stylist.

• Unvisited� links, as above, it allows us to specify the style for this link

status.
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Figure 24. Character formatting Background tab

This tab is used to choose the background colour for the selected text. You can

use a colour from the program's standard palette or one that you have created

yourself. To clear the background colour, select the No Fill option.

3.2. Paragraph formatting

Character formatting requires the text for formatting to be selected. However,

to use paragraph formatting, simply position the cursor inside the paragraph

to which you want to apply the formatting changes.

As with characters, it is best to use the Object bar for basic formatting features.

This can be used to justify or indent the paragraph, or to change the back-

ground colour. We will also see how to use the ruler to define basic paragraph

formatting settings.

To change a paragraph indent quickly without going through the paragraph

formatting dialog box, you can use the program's horizontal ruler. To do so,

select the paragraph you want to indent by positioning the cursor in it and

then move the triangle on the lower part of the ruler to specify the left indent

(the top triangle will move with it).

3.2.1. Tabs

The horizontal ruler can also be used to insert and move tabs for one or more

paragraphs in the document. To configure tabs, first select the paragraph you

want to indent by positioning the cursor in it. In the small box on the left

edge of the horizontal ruler, you can select the type of tab you wish to insert

by clicking on it repeatedly. The available options are:
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a) Left tab

b) Right tab

c) Decimal tab (which allows us to align texts such as amounts by their dec-

imal point when clicked).

d) Centered tab

To add a tab to a point on the ruler, simply drag it to the desired position.

To delete a tab, drag it outside the edges of the horizontal ruler. If you are

working on a document that has no specified tabs, OpenOffice.org's default

tabs will be used.

3.2.2. Paragraph formatting dialog box

This section will look at the dialog box containing the paragraph formatting

options. This and the character formatting dialog box complement each other.

For instance, to select the paragraph font, mark it and go to the character

formatting dialog box as we have already seen.

To bring up the Paragraph formatting dialog box, position the cursor or mouse

pointer in the paragraph you wish to format and right-click the mouse to select

Paragraph in the context menu. A dialog box with different tabs will appear.

Figure 25. Paragraph formatting Indents & Spacing tab

The Indents & Spacing tab contains the following options:

• Indent lets us specify the distance between the text and the page margins.

The First line option is used to indicate the distance of the paragraph's



GNUFDL • PID_00148476 31 Open Writer. OpenOffice.org word processor

first line in Before text. If you mark the Automatic checkbox, the default

indent will automatically be applied.

• Spacing used to configure the space above and below the paragraph. This

space will not be applied if the paragraph is at the top or bottom of the

page. Adjacent paragraphs will use the largest separation value.

• Line�spacing allows us to choose from the different line spacing options,

which can be customised in some cases.

• Register-true gives us the option of aligning ends of paragraph with the

lines of adjacent columns.

On the right of the window, the program offers a preview of the values being

modified so that we can see exactly what we are doing.

Figure 26. Paragraph formatting Alignment tab

The Alignment tab is used to configure the following:

• Options used to select the Left, Right, Center or Justified options. If you

select the latter, you can align the last line of the text separately. For in-

stance, if the last line is very short, you can align it to the left to avoid

large spaces between words.

• Text-to-text lets us specify the vertical location of the text if line spacing

is greater than the text.

On the right of the window, the program also offers a preview of the values

being modified so that we can see exactly what we are doing.
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Figure 27. Paragraph formatting Text Flow tab

• Hyphenation if we select the Automatically option, the program will

separate the last word of the line into syllables. We can control

OpenOffice.org's hyphenation system by specifying the number of char-

acters that need to be present at the end and start of the next line and the

maximum number of consecutive lines that can be hyphenated.

• Breaks used to select the page or column break option for the selected

paragraph. If you choose the Before option, the current paragraph will be

moved to the next page or column; if you select After, the next paragraph

is moved. When you move on to the next page, you can choose the style

for the new page from those available.

• Options useful for setting the minimum number of lines to appear on

the previous page (orphans) or the next one (widows) when a paragraph

continues on to the next page.
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Figure 28. Paragraph formatting Numbering tab

• Numbering�Style allows us to apply predefined numbering styles to the

selected paragraph.

• Numbering used for lists of numbered paragraphs when we wish to restart

numbering. In Start with, you can specify the first number of the series.

• Line�numbering if you use line numbers in the document margins, you

can use the line numbering options to control whether the paragraph has

to be numbered and how this should be done.

Figure 29. Paragraph formatting Tabs tab

• Position inserts a new tab position, measured from the page margins.
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• Type lets us select the type of tab. Earlier, we looked at the tabs available

on the vertical ruler.

• Fill�character very useful if we want the specified characters to appear be-

tween the position at which the tab key was pressed and the tab position.

To add a tab that you have created, click on the New button. You can also

delete one or all tabs from the paragraph by clicking on the corresponding

button. If you are working on a paragraph with no specified tabs, the default

OpenOffice.org tabs will be used.

Figure 30. Paragraph formatting Drop Caps tab

This tab is used to format the initial letters of a paragraph. The available op-

tions are:

• Settingslets us activate this feature when we mark Display drop caps. You

can specify Whole Word to use the first word as text. If you do not select

this option, you can specify the number of characters to use. You can also

indicate the number of lines to use and distance to text.

• Contents used to specify a different text to the one at the start of the

current paragraph. A character style can also be applied to the specified

text.

On the right of the window, the program offers a preview of the text we are

modifying so that we can see exactly what we are doing.
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Figure 31. Paragraph formatting Borders tab

• Line�arrangement, we can click on the different types of line to apply

the type of border they represent. We can also click on the blank box to

delete all line settings. The grey box in the User-defined box represents the

paragraph. We can add or delete lines around the paragraph by clicking

on them.

• Line, in this section we can choose the type and colour of line to use.

• Spacing�to�contents allows us to specify the distance between the para-

graph and the outermost shadow line. If we modify a value and wish to

apply this change to all of the other values, mark the Synchronize option.

• Shadow�style allows us to select the position at which to apply the angle

of shade to the line. The first of these boxes disables shadow configuration.

The drop-down Color list is used to change the shadow colour, which is

grey by default.
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Figure 32. Paragraph formatting Background tab

The Background tab can be used in two ways: it can colour in the background

and it can make the background into an image:

• Color this is used to change the background colour using the options in

the system palette. We have already seen how to create custom colours in

this unit. Select the No Fill option to turn off background colour.

• Graphic this offers a number of options for using graphics as paragraph

backgrounds. When you click on the Browse button, a selection window

will appear in which you need to select the graphic to use. The Link option

creates a symbolic link to the graphic. This will reduce the size of your

document but the graphic will need to be available in order to see it. If the

graphic is smaller than the paragraph, use the Type options to position it

in relation to the paragraph.

3.3. Bullets and numbering

As we saw in the last two cases, for quick formatting with bullets and num-

bering, it is best to use the options available in the program's Object bar. To

do so, simply select the text to number or convert to bullets and click on the

relevant button in the Object bar.

The bullets or numbers appear in grey boxes to help locate them better in the

document. These grey boxes will not be printed with the document. If you

find them distracting though, you can turn them off with the View > Field

Shadings menu option.
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The program's default bullet and numbering options are basic but they can be

customised to adapt them to our needs. The procedure for this is as follows:

1) Select the paragraphs you wish to number or change to bullet points or

position the cursor on the blank line where you wish to begin numbering.

2) Go to the Format > Numbering/Bullets menu option and select the tab

you require from Bullets, Numbering type and Graphics; if you select this last

option, the following dialog box will appear:

Figure 33. Numbering/Bullets Graphics tab

This dialog box allows us to use much more attractive tabs than the program's

default ones. If you choose a graphic, it is very important to check the Link

graphics option in the bottom part of the window because if you need to send

the document to others, they will be unable to see the bullets if the graphics

are not installed on their computer or if the path to the graphics is not the

same as on yours. As these graphics take up a minimum of space, it is not

necessary to link them to the document instead of inserting them.

3) After selecting the style you wish to use, click on the OK button.

If you are starting a new list, enter your first text and press Enter. The new

paragraph will also be a list item. To exit list mode, press Enter twice on a

blank line or turn off the list from the Object bar.



GNUFDL • PID_00148476 38 Open Writer. OpenOffice.org word processor

3.3.1. Creating an outline

We can use the system we saw in the above section on bullets and numbering

to create an outline, as the procedure is very similar. There is no quick way to

create an outline in OpenOffice.org like there is for bullets and numbering.

The steps to the process are as follows:

1) Position the cursor in the document where you wish to start the outline.

2) Go the Format > Numbering/Bullets menu option and select the Outline

tab.

Figure 34. Numbering/Bullets Outline tab

3) In the Outline tab, select the style of outline you wish to use and click on

the OK button. The first level of the outline will appear in your text.

When you press Enter at the end of a line of text, you will remain at the same

numbering level but the numbers will increase. If you want to move within a

level, press the Tab key on the keyboard. To return to the previous level, use

the Shift+Tab�key�combination.

3.3.2. Configuring numbering, bullets and outlines

There are several settings options for numbering, bullets and outlines. The

main reasons for configuring these would be to change symbols and indents,

as well as numbers and typefaces. The process for configuring these is as fol-

lows:
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1) Select the paragraphs you wish to number or change to bullet points or

position the cursor on the blank line where you wish to begin the list of items.

2) Go to the Format > Numbering/Bullets menu option and select the Options

tab.

Figure 35. Numbering/Bullets Options tab

3) Select the level number from the Level field. The level numbers correspond

to the text indent level. The higher the level, the greater the indent.

4) In the Numbering field, select the type of numbering or bullets you wish

to use for this level. The formatting options differ according to the type of

numbering selected.

• If you select a numerical�format in the Before and After text fields, you

can enter the text that will appear before and after the number. You can

also choose the character style you wish to use for the numbering. This

option allows different styles to be used in the paragraph numbering and

text. The Show sublevels and Start at fields are used to specify the number

of sublevels to include in the numbering and their initial level, respective-

ly.

• If using graphics, click on the Select button to determine which graphic

to use. You can enter the width and height of the selected graphic but

it is always preferable to leave the Proportional option marked to avoid

distorting the image. Finally, in Alignment, you can enter the alignment

position in relation to the baseline of the text.
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• If you select the Bullet�option, you can choose the character style and

select a special character for the bullets. To do this, click on the ellipsis (...)

button to the right of the Character option.

5) Select the appropriate options for the level you have chosen. To configure

another level, mark it, define its settings and then click on the OK button.

3.3.3. Position and spacing between levels

Another settings option is to change OpenOffice.org's default position and

spacing for bullets and numbering. The process for changing these settings is

very similar to the one we have just seen. The steps are as follows:

1) Select the paragraphs you wish to change or position the cursor on a blank

line where you wish to begin the list of items.

2) Go to the Format > Numbering/Bullets menu option and select the Position

tab.

Figure 36. Numbering/Bullets Position tab

3) Select the level number from the Level field. The level numbers correspond

to the indent. The 110 field applies the changes to all levels.

4) Change the level settings. The changes that can be made here are to modify

the distance between the number or bullet and the page margin, the minimum

and maximum distances between the text and the number or bullet, and lastly,

the alignment of the bullet or number with the space created. Click on the

OK button to exit the dialog box and accept changes.
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The lower part of the window has a preview area where you can see the visual

effects of the changes as you make them.
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4. Word Completion and AutoFormat

One of the most useful features of OpenOffice.org is its ability to complete

words and format text automatically and to correct common typographical

errors. However, one thing is clear, these options can either be very useful or

very bothersome. It all depends on the person using the program. What can

sometimes be a great feature for some, may put others off using the program

precisely for that reason. This section will describe how to adapt these features

and functionalities to our needs and how to turn them off.

4.1. Configuring AutoReplace

This can be a very useful feature if you tend to make the same spelling mistakes

or grammatical errors all the time or if you regularly type the letters of a word

the wrong way round. It can also be used to automatically change letters for

their corresponding symbol. For example, "(c)" can be used for the copyright

sign or "(r)" for the registered sign. If you have used any other word processor,

they will probably have had this feature too. We will now look at how to

configure the feature in OpenOffice.org.

To access Replace, go to the Tools > AutoCorrect/AutoFormat menu option

and select the Replace tab in the AutoCorrect dialog box.

Figure 37. AutoCorrect Replacement tab
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The first thing to do is to select the language of the document or the language

in which you usually work, as the replacement table is different for each. To do

this, select the required language from the list in Replacements and exceptions

for language. Most languages already have their own replacement table that

you can modify if you need to.

In the Replace text field, type the word or character that you would like to

automatically replace with another and write the substitution in the With text

field. Once you have completed this step, click on the New button to add it

to the replacement table.

To type a symbol or special character in the substitutions text fields, right-click

the text field and select the Insert Symbol option from the context menu,

which will bring up all of the symbols for the fonts installed on the system

for you to choose from.

Figure 38. Symbols selection dialog box

To delete a default replacement or one that you created yourself, first mark it

in the replacement table and then click on the Delete button. Use this method

to delete all substitutions affecting your work instead of disabling the function

altogether.

4.2. Configuring automatic uppercase

By default, the OpenOffice.org program automatically changes the letter fol-

lowing a full stop and blank space into uppercase. This can be very useful but

it can also be irritating if you often type abbreviations.

The program automatically changes words that start with two consecutive

uppercase letters, converting the second uppercase letter into lowercase. The

feature was designed for people who type very quickly, as the program thinks

that the user has not had time to release the shift key before typing the second
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letter. Nonetheless, at some point during use of this program we will no doubt

need to type a word with two consecutive uppercase letters, such as the name

of a company or product.

Note that this rule only applies to words that begin with two uppercase let-

ters. When the program detects three or more consecutive uppercase letters,

it assumes that this is not a mistake and that the user has intentionally typed

the word like this. As we shall see, this feature can be turned off completely

or we can create exceptions to the general rule.

To do so, go to the Tools > AutoCorrect/AutoFormat menu option and select

the Exceptions tab from the AutoCorrect window.

Figure 39. AutoCorrect Exceptions tab

After confirming that the language is correct, enter the exceptions for Auto-

Correct to Uppercase in this dialog box. The top section includes a list of ab-

breviations not followed by uppercase letters, while the bottom section con-

tains words beginning with two consecutive capitals. You can enter exceptions

in the appropriate text boxes and then click on the New button to add the

exception. To delete an exception, select it and click on the Delete button.

Each of the items in the two groups of exceptions include options marked by

default with the word "AutoInclude". These are applied as you edit your docu-

ment. If you correct an AutoCorrect to Uppercase that the program automat-

ically entered and then carry on typing, the correction will be automatically

added to the list of exceptions. For this to happen, the AutoInclude option

must be checked.
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4.3. Turning off AutoCorrect

OpenOffice.org comes with a wide range of AutoCorrect options, which we

will introduce here. To locate them, go to the Tools > AutoCorrect/AutoFor-

mat menu option and select the Options tab from the AutoCorrect window.

A dialog box like the one below will appear:

Figure 40. AutoCorrect Options tab

We will deal with these one by one. Some have a very obvious function but

others do not. Moreover, the original meaning of some of the options may

have been lost in translation.

• Use�replacement�table allows the program to use the replacement table

from the Replace tab we saw earlier.

• Correct�TWo�INitial�CApitals automatically converts the second consec-

utive capital into a lowercase letter. You can add exceptions to this rule in

the Exceptions tab of the AutoCorrect dialog box.

• Capitalize� first� letter�of�every�sentence changes any letter after a full

stop and a space into a capital. You can enter exceptions to this rule in

the tab we saw above.

• Automatic�*bold*�and�_underline_ automatically converts a word to bold

if you enter an asterisk before or after it. This functionality also applies

to words with an underscore before and after them, though this time the

words are underlined.
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• URL�Recognition converts a group of characters that the program thinks

is a web link into a URL. For example, if you enter "http://www.uoc.edu",

the program will effectively convert it into a link to this web page when

you click on it. If this autoformatting is useful most times but not so use-

ful at others, you can restore the original text by selecting the full link

and right-clicking it before clicking on the Default option. You can also

undo autoformatting with the key combination Ctrl+Z after it has been

converted.

• Replace�1st...�with�1^st... this option is useful if you write documents in

English. It automatically superscripts ordinals in English.

• Replace�1/2...�with�½�... converts the three characters of a fraction into a

single character with the corresponding symbol. This change only applies

to character sets with the corresponding fraction symbols. Character sets

normally only have three or four fraction symbols.

• Replace�dashes converts minus signs into true dashes as long as they at

least have a space on either side.

• Delete�spaces�and�tabs�at�beginning�and�end�of�paragraph deletes the

spaces and tabs at the start of a paragraph if the Apply Styles option is

checked.

• Delete�spaces�and�tabs�at�end�and�start�of�line deletes the spaces and

tabs at the start of each line if the Apply Styles option is checked.

• Ignore�double�spaces makes sure that there is only one space between

two characters.

• Apply�numbering��symbol�X converts a number followed by a full stop

plus space and any text into a numbered list when you press Enter. This is

a quick way to access the same feature in the Object bar. Instead of typing

in a number, you can use a dash or an asterisk for numbering with dashes

or bullets, respectively. You can change the character for turning on bullet

numbering by clicking on the Edit button.

• Apply�border allows you to create a line below the paragraph when you

enter three consecutive characters and press Enter. To restore the original

text, select and right-click on it and select the Default option. The follow-

ing table illustrates the types of border that can be created:

 0.5pt single underline

___ 1.0pt single underline

=== 1.1pt double underline
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*** 4.5pt double underline

~~~ 6.0pt double underline

### 9.0pt double underline

• Create�table if this option is turned on, you can automatically create a

table in your document simply by using the keyboard. The + key represents

a column border and the  character represents the width of the column.

After combining the two characters to suit your needs, press Enter. Valid

columns must begin and end with the + character. For example: "++

++".

• Apply�Styles allowsOpenOffice.org to automatically apply paragraph for-

matting when using the Default style. When you begin a paragraph with

a capital letter and do not end it with a full stop, press the Enter key twice

at the end of the line and the paragraph style will automatically change to

Heading 1. If you press the Tab�key twice before typing in text, Heading

2 will be applied. If you press tab three times, the Heading 3 style will be

applied, and so on.

• Remove�blank�paragraphs if this feature is turned on, when you choose

Format > AutoFormat > Apply, all blank paragraphs in the document will

be removed.

• Replace�Custom�Styles when use the Format > AutoFormat > Apply fa-

cility, this converts the custom styles of the document into the equivalent

standard styles of the program.

• Replace�bullets�with:�X when using the Default style, this option allows

you to change all paragraphs starting with a number, asterisk or dash fol-

lowed by a space (or tab) and text into a list when you choose Format >

AutoFormat > Apply. You can change the character for turning on bullet

numbering by clicking on the Edit button.

• Replace�standard�quotes�with�custom�quotes when this option is turned

on and you choose Format > AutoFormat > Apply, all single and double

quotes in the document are changed to the characters indicated in the

Custom Quotes tab of the AutoCorrect window that appears when you

select the Tools > AutoCorrect/AutoFormat menu option.

• Combine�single�line�paragraphs�if�length�greater�than�... when using

the Default style, you can choose Format > AutoFormat > Apply to com-

bine consecutive paragraphs that only have one line. Single-line para-

graphs must be at least the specified percentage of the width of the page.

You can change this percentage by clicking on the Edit button.
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4.4. Word Completion

We will now look at what is probably the most visible automatic feature

of the entire program. When writing a document in text or HTML format,

OpenOffice.org will try to predict the word you are typing and automatically

supply the rest of the letters in the word, which can either be extremely help-

ful or very irritating if not configured correctly. In this section, we will try to

explain how it works and look at some of its limitations.

The best way of using this feature to our advantage is to limit the number

of words for which the program offers suggestions. For example, if you are

working on a scientific document with very long or complicated words that

come up again and again, you can add them to the program so that it provides

automatic suggestions and ignores others. This would make your task less te-

dious and considerably increase your productivity.

Remember that the Word Completion feature can only be used with single

words. If you want to enter longer texts with more than one word, you will

need to use OpenOffice.org's AutoReplace feature.

To set up this function, go to the Tools > AutoCorrect/AutoFormat menu op-

tion. Once inside the AutoCorrect dialog box, select the Word Completion

tab, which will look like this:

Figure 41. AutoCorrect Word Completion tab

The options in this window are:
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• Enable� word� completion enables OpenOffice.org's Word Completion

function. If you do not want to use this feature, unmark the box.

• Append�space adds a space after completing the word.

• Show�as�tip displays suggestions from the program's list of words like a

help tip much like the one we see when we hover the mouse pointer over

a button, rather than like the rest of the word highlighted in blue. This

makes word completion much less intrusive for users.

• Collect�words tells OpenOffice.org whether or not to collect words for

the list of suggestions. You can collect words regardless of whether or not

the Word Completion feature is turned on. It is generally a good idea to

collect words once you have the most common ones in the list. This will

prevent the program from suggesting words that you never use instead of

the ones you often do.

• When�closing�a�document,�save�the�list�for�later�use�in�other�docu-

ments allows us to reuse words in other texts. Words are generally only

collected for the current document.

• Accept�with allows us to select the key to use to complete words. The

default key is Enter.

• Min.�word�length controls the words added to the list by specifying a

minimum number of characters for words to be added. The default value

of 5 is ideal so it is best not to change it unless there is an important reason

for doing so.

• Max.�entries allows us to specify the maximum number of entries for the

word list.

The field on the right of the window lists the words that OpenOffice.org will

attempt to complete as they are typed in a document. The program will au-

tomatically add the words you type to the list if the Collect words option is

enabled, provided that the words meet the specified requirements.

If you have mistyped a word or added one by mistake and the program is al-

ways suggesting it, you can delete it in this window. Simply select the mistyped

word and click on the Delete Entry button.

If you have two or more words formed from the same root, such as "process"

and "procedure" and OpenOffice.org suggests the word you do not want, you

can scroll up or down the list to select the right one. To go to the next word,
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press Ctrl+Tab. To go to the previous one, press Ctrl�+�Shift�+�Tab. This feature

allows us to scroll through the full list of words, but we can also use it to scroll

back and forth in groups of words with the same root.
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5. Using graphics and sounds

Almost any type of graphics file can be inserted into a document, including

GIFs and JPEGs. We can also work with less common graphics formats, since

OpenOffice.org has filters for most of these. However, remember that only the

most usual ones are installed by default. To work with a rare graphics format,

you will need to modify your installation to install filters.

To insert graphics in a document, follow these simple steps:

1) Position the cursor where you want to insert the graphic and click.

2) Click and hold the left mouse button on the Insert button and select Insert

Graphics. The default Insert button will then change to adapt to the last se-

lected action. This means that you now need only click on Insert to insert a

picture in the document. You can also use the program's main menu by going

to Insert > Graphics > From File... The result is the same in both cases.

Figure 42. Insert Graphics dialog box

Besides the typical actions of any file selection dialog box, this window has a

graphics preview feature, which is very useful if you do not use meaningful

names for your graphics files. To enable this feature, check the Preview option.

Another option that can be very useful, but also quite risky, is Link. When you

check this option, the graphics are not physically inserted in the document;

instead, the program inserts a symbolic link to their location. On a practical

level, this means that if you want to send this document to others, you will

also need to send the pictures with it, as you would for a web page.
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So, if you link a graphic from a given folder (for instance, img) to the docu-

ment, you will need to send it to the recipient in a folder of the same name.

5.1. Using the OpenOffice.org picture and sound gallery

We have seen the basic method for adding graphics to documents but

OpenOffice.org also has a very powerful tool for classifying and working with

graphics and sounds called the Gallery. To enable it, select the Tools > Gallery

menu option or click on this button in the Function bar.

Figure 43. OpenOffice.org displaying the gallery

The gallery is displayed as a series of images and/or sounds that can be classi-

fied into different categories although, in fact, they are a group of links. So,

for example, each of the graphics that we see in a single category may be in

different locations on our hard drive.

To insert an image into your current document, simply select the theme on

the left of the screen and then drag the image on the right to the desired

position in the document.

The program comes with a number of default gallery images and sounds. These

will depend on the installation you used as some are not installed with stan-

dard installations.
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5.1.1. Creating gallery themes

You can add your own graphics, sounds and animations to an existing theme

or you can create new themes to suit your needs. This section will look at how

to create a gallery theme and add graphics to it. The method is very similar to

adding elements to an existing gallery. The steps of the process are as follows:

1) The first thing to do is to open the gallery by selecting the application's

Tools > Gallery main menu option or by clicking on the Function bar button.

If the gallery is selected but you cannot see it, it is probably hidden. To display

it, click on the small arrow at the edge of the workspace of the current docu-

ment. Clicking on this arrow will show the gallery.

2) To create a new theme, click on the New Theme button in the top left of

the gallery.

Figure 44. Properties of New Theme dialog box

3) This will bring up the Properties of New Theme dialog box, which has two

tabs called General and Files. In this first screen, type in the name of the theme

you wish to create and click on the Files tab to add the contents.
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Figure 45. Properties of New Theme Files tab

4) In the Files tab, first select the type of file you wish to add to the theme.

If you mark the All Files option, you will be able to select all OpenOffice.org-

compatible files in the folder. Click on the Find Files button.

Figure 46. Folder selection dialog box

5) In this window, simply select the folder of the files you wish to add and

click on the OK button to continue the process. The program will search for all

elements compatible with the gallery in the specified folder and its subfolders.
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Figure 47. Files tab with found elements

6) This will take us back to the Files tab but you will now see that the left-hand

side of the dialog box is displaying the elements found in the specified folder

that matched your file type selection. If you check the Preview option, you

can view the pictures or listen to the sounds in the files. However, note that

if these images are very big or very small, they will be considerably distorted.

7) To add a file to the gallery you are creating, select it and click on the Add

button. If you want to add all of the files from the folder and subfolders, click

on the Add All button. As explained above, the added files are not copied; the

gallery simply adds a reference to them in order to access them. If you delete

a file added to the gallery from its original location, you will no longer be able

to use it. After selecting all of the files, click on OK to create the new gallery.
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Figure 48. Gallery with new theme

To add new sounds or images to an existing theme, right-click the name of

the theme and select the Properties option. This will bring up the Properties

dialog box we saw earlier where we can add new file references.

It is much easier to delete a file reference in a gallery theme. Right-click on the

icon and select Delete from the context menu that appears. A dialog box will

appear asking if you really want to delete the object. Note that you are only

deleting the gallery reference here, not the original file.



GNUFDL • PID_00148476 57 Open Writer. OpenOffice.org word processor

Summary

In this unit, we looked at the OpenWriter working environment and learnt

how to use and configure it for routine word processing operations. We fo-

cused particularly on the formatting possibilities of OpenOffice.org as these

are the most commonly used features for writing documents.

We also dealt with the configuration of the program's text composition help

tools so that we can customise them to suit our needs. These features can often

be very irritating to users if they have not been sufficiently adapted to their

expectations.

Lastly, we saw OpenOffice.org's organised system for saving images and

sounds, although we will probably only need to work with pictures.

From what we have learned in this unit, we should be able to discover for

ourselves the other OpenOffice.org tools for creating text documents.
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Introduction

OpenOffice.org also has a component for working with spreadsheets called

Open Calc. This unit will describe its main features, which include the follow-

ing:

• Filters�for�other�spreadsheet�formats. The Microsoft Excel one is partic-

ularly good.

• Support�for�inserting�all�types�of�graphics�format. The standard instal-

lation includes the most common ones, but you can also install custom

formats.

• Version�control. You can save different versions of a document and return

to previous versions if need be.

• List�sorting. You can sort cell items by specific criteria.

• Conditional� format. It is possible to apply formats conditionally to

spreadsheet cells.

• Automatic�conversion�of�databases to spreadsheets and vice versa.

• Cell� protection. To avoid accidentally modifying important values or

functions.

• Control�of�input�values. We can specify, for example, a range of values

in a cell.

• Scenarios. We can change a given value depending on the selected sce-

nario. For instance, the interest on a mortgage will depend on the bank.

• Automatic�completion�of unknown values based on the values of other

cells.

This unit will describe the basic features of the program and its most common

options, functions and utilities.

The main aims of this unit are:

1) to teach the basics of how to use the OpenOffice.org spreadsheet applica-

tion,
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2) to explain to students how to perform basic operations with numbers and

how to use functions to enhance their work, and

3) to illustrate, step by step, the creation of charts using data from a spread-

sheet.
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1. Basic use of the program

Calc can be launched from any OpenOffice.org application by selecting the

File > New > Spreadsheet menu option.

Tips can be very useful for learning about the different features of the program.

Tips are displayed for each of the labels and buttons on the screen. You can

enable or disable this option using the Help > Tips menu option.

1.1. The working environment

As with the other applications, if you need help with a dialog box or window,

you can always click on the Help button or press F1.

Figure 1. The Calc working environment

We will now describe the diverse elements in the program's workspace:

• The Menu�bar contains the various actions that can be carried out globally

across the OpenOffice.org program and those that are specific to Calc.
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• The Function�bar indicates the full path of the file being edited and pro-

vides a shortcut to the program's global features.

• The Object�bar is used to apply formatting to the objects you are working

on at a given time. The most useful of these will be the text display and

cell formatting tools.

• The�Formula�bar allows you to enter formulae, create quick sums, launch

the AutoPilot features and browse different areas of a spreadsheet.

• The Main�toolbar, positioned vertically down the left-hand side of the

document, gives quick access to the most common spreadsheet functions.

• The�Status�bar at the bottom of the screen has a number of functions,

which include displaying the spreadsheet number and the total number of

spreadsheets, applying page styles (by right-clicking on Standard), chang-

ing zoom percentage and changing the default type of text selection.

• The tabs can be used for easy scrolling through the spreadsheets of a doc-

ument.

• The Stylist�is used to automatically apply cell and page styles. To show or

hide the Stylist, press F11 or use the Format > Stylist menu option.

1.2. Creating a sample document

We will now look at the basics of this program by creating a sample spread-

sheet. To do so, follow these instructions step by step.

1) Launch OpenOffice.org and create a new spreadsheet document by select-

ing the File > New > Spreadsheet option from the main menu. This will open

a new window with a blank spreadsheet.

2) In this blank sheet, go to cell A1 and enter the following text: "Calculation

of credit card use" and change the font size to 20. To do this, either go to the

program's Object bar or right-click the cell and select Format Cells from the

context menu. In the Format Cells dialog box, go to the Font tab.
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Figure 2. Format Cells Font tab

3) Select the entire row by clicking on the grey square with the row 1 label

and change the background colour of the title using the Background Color

button on the Object bar.

4) In cells A4,�B4,�C4 and D4 type "Annual percentage rate", "Monthly in-

terest", "Starting balance" and "Monthly payment", respectively. You will see

that the text does not fit in the column space. You can change the size of

the columns by dragging their borders but you can also fit the text on more

than one line. To do this, select these cells by clicking on cell A4 and without

releasing the mouse button, move across to D4.

5) Select the Format > Cells menu option and click on the Alignment tab

in the Format Cells dialog box. In this tab, check the Automatic line break

option.
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Figure 3. Format Cells Alignment tab

6) With the text still selected, format it in italics and centre it using the

program's Object bar. We will now create a border for the selected cells. Go to

the Object bar and click and hold the left mouse button on the Borders button

and select the bottom border.

Figure 4. Borders window

7) Position the cursor on cell A5 and click on the Number Format: Percent

button to indicate the cell format and enter ".20", where the full stop is the

decimal point. Then press the tab key to move to the next cell.

8) In cell B5 , click on the % button in the Object bar and type in the following

formula "=A5/12", which divides by 12 months the annual value recorded in

cell A5.

9) In cells�C5 and D5�, click on the Number Format: Currency button to in-

dicate that you are going to enter a value in € in these cells. Type the values

"6000" and "125", respectively, in these cells.
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10) In cells A8 to D8 enter the following text: "Payment Number", "Interest",

"Capital" and "Balance" respectively. Then format the text in the same way as

you did with cells�A4 to D4.

11) In cell A9 , type the number "1".

12) Position the cursor on cell B9 and check the Number Format: Currency

option before typing in the following formula "=$B$5*$C$5". This multiplies

the contents of cell B5 (the monthly interest rate) by the contents of cell C5

(the credit card balance). When we use the $ signs, we are telling the applica-

tion that the cell address is an absolute reference. We will explain the meaning

of this concept later when we look at cell references.

13) In cells C9 and D9, after clicking on the Number Format: Currency button,

type the following formulae: "=$D$5B9" and "=$C$5C9". The first formula

subtracts the amount of interest paid this month from the monthly payment,

which gives us the amount of capital taken from the total card balance. The

second formula subtracts the monthly capital payment from the starting bal-

ance of the credit card.

14) We will need to add a new row of data to be able to use the incremental

data filling feature. So, in cell A10 , type in "2" and in the rest of the cells of

the row ( B10 to D10), enter the following values: "=D9*$B$5", "=$D$5B10"

and "=D9C10".

15) We can now use the automatic incremental data fill process. To begin,

select the row of cells from A10 to D10. You will now see a small black square

in the bottom right-hand corner of the selection. Position the cursor on it and

the square will become a cross. Now, right-click the mouse and drag this cross

to row 20. Release the button when you reach this row.

16) You will see that the cells have been filled automatically. If the cell values

are the same, press F9 to force OpenOffice.org to recalculate the spreadsheet.

17) We will now calculate the total interest payable based on the number

of payments we have made. Go to cell�E9 and click on the Number Format:

Currency button. Enter this text "=SUM(" and then use the mouse to select all

of the values in column B, starting at B9. Once you have selected these, close

the formula with a bracket. The result should look like this: "=SUM(B9:B20)".

The best thing about spreadsheets is that when we change a value, the other

values in the spreadsheet are automatically updated. To see this, change the

original values of row 5. Be very careful about changing cells that contain

formulas rather than values, because the results are never what we were hoping

for when we change them.
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1.3. Cell references

Cell references are cell addresses that have been inserted into a formula. These

references make spreadsheets very flexible because the reference remains the

same even if its contents change. We do not need to manually enter cell ref-

erences in a formula because the program does this automatically if we click

on the cell we want to use as a value while we are creating the formula. We

can also select a set of formulae and use them as an argument in formulae

that allow this.

OpenOffice.org has two types of cell references:

• Relative�references: when we select and cut or copy a group of cells with

a calculated value to a new location, OpenOffice.org will change the ref-

erences used in the formula so that the calculated values remain as they

were. This is possible because the formula references were relative to the

rest of the cells. It does not matter if we move them because their relation-

ship to the rest does not change. By default, all references are relative.

• Absolute�references: there may be times when relative references do not

fully meet our needs, such as when we reference cells whose location is

never going to change. We say that these cells have an absolute position. In

spreadsheets, we mainly use absolute references when we use incremental

data filling tools which, as their name suggests, increase cell values and

references. However, we do not always want these references to increase.

To indicate that a reference is absolute, we need to add a dollar symbol, $,

in front of the name of each coordinate. For example: "$A$3".

For absolute references, there is no need to enter the dollar sign before the row

and column name every time. We can use different combinations of relative

and absolute references, depending on the incremental filling operation we

wish to use.

• To use incremental filling across columns (left and right), simply put the

dollar sign before the column letters. For example: "$A1".

• To use incremental filling up and down columns, simply insert the dollar

sign before the column number. For example: "A$1".

• To reference cells that are never going to change location, put the dollar

sign before the column letter and row number. For example: "A$1".

To change these settings quickly in a formula, simply select the elements to

be changed (or the whole formula) and use the key combination Shift+F4.
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2. Calculations and functions

In this section, we will look at the process for making calculations and creating

formulae to use in our spreadsheet documents.

2.1. Basic operators

Operators are the symbols used to tell the program to perform different calcu-

lations. The most important of these is the = symbol, which means that what

follows is a formula rather than a text. We will now look at the list of operators

that we can use in our formulae:

Opera-
tor

Description Example of use

= Equals sign. All formulae begin with this =1+3

^ Exponent. Increases the number on the left
by the power of the number on the right

=2^8

* Multiplication =2*5

/ Division =21/7

+ Addition =A1+25

 Subtraction =B3A1

< Less than =if(A1<3; "Good";"Bad")

> Greater than =if(A2>10; "Good";"Bad")

<= Less than or equal to =if(B3<2; "Good";"Bad")

>= Greater than or equal to =if(C1>4; "Good";"Bad")

<> Different =if(A1<>B1; "Good";"Bad")

: Range of cells. Includes all cells from the value to
the left of the symbol to the value on the right.

=sum(a1:a10)

; Separates non-consecutive cells
and different parts of a formula.

=sum(a1;a3;a5)

! Intersection =sum(a1:b3!b2:c7)
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2.2. Order of evaluation of expressions

We need to take into account the order of evaluation of expressions when we

make a calculation. OpenOffice.org evaluates expressions from left to right

using the rules of algebraic order. it multiplies, then divides, then adds and

finally subtracts. However, if we use exponents, these are calculated before

multiplication and division.

So, for the following sum: "=1+10*220/2+4", the result is 15, because the mul-

tiplications and divisions are made first, giving us =1+2010+4.

However, as in algebra, it is possible to alter these rules using brackets. In this

case, OpenOffice.org solves the operations inside the brackets first and then

works out the rest of the formula following algebraic rules.

When we use brackets in our formulae, the use of other brackets to con-

trol evaluation of the expression is inevitable. In these cases, OpenOffice.org

works out the brackets from innermost to outermost. For example: =(8*(122)

/((7*2)(2*2))+ 12) equals 20.

2.3. Entering formulae

Thus far we have seen the basic operations available in OpenOffice.org for

working with values, but the program's most interesting feature is the use of

formulae. The sum formula, for example, allows us to select a range of cell

references. Without this, we would have to enter the name of each cell one

by one.

As formulae are an essential part of spreadsheet work, OpenOffice.org has a

variety of built-in functions. These allow the user to calculate anything from

a sum or square root to conditions that make a cell display a certain text if

an expression is true or false (the 'IF' function). In this section, we will look at

some of the program's more useful features.

2.3.1. Quick sum

OpenOffice.org allows columns or rows to be added very quickly with a single

mouse click. Simply click on the cell where you want the sum to be inserted

and then click on the Sum button in the Formula bar.

OpenOffice.org will automatically select a range of cells for the sum function.

You can use the suggested default range or you can change it if it is incorrect.

Simply drag the selection across the spreadsheet cells and change their size

by clicking and dragging the black square in the bottom right-hand corner of

the selection border. To mark cells in spaces that are not adjacent, press Ctrl

as you click on them.
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After ensuring that the selection is correct, press Enter to calculate the formu-

la.

2.3.2. Subtotals

If you have a column of numbers that you wish to add up, you can use

OpenOffice.org's Subtotal function to generate automatic balances. This fea-

ture inserts a new row for the subtotals it generates so that references to other

cells, where used, can be modified. As a result, you will need to use absolute

references in your formulae here.

The steps to the process are as follows:

1) Select the area in which to generate the subtotals.

2) Go to the Data > Subtotals option in the main menu, which will bring up

the Subtotals dialog box.

Figure 5. 1st Group tab of the Subtotals dialog box

In the Group by field, select the column in which to group the data. You can

use the other tabs of the Subtotals dialog box to create new groups, if need be.

In the Calculate subtotals for list, mark the columns for which you want to

generate subtotals and select the type of operation to use in Use Function.

3) To modify any of the Subtotals options, go to the Options tab.
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Figure 6. Subtotals dialog box Options tab

In the Groups section, you can specify whether to insert a page break between

different groups, whether to respect word case when generating subtotals and

whether to pre-sort the area according to groups.

In the Sort section, you can enter any further group sorting options.

4) After defining the settings, click on OK to close the dialog box.

You will see that when OpenOffice.org creates the subtotals, it allows us to

expand and reduce the groups created using a new toolbar.

2.4. Use of the AutoPilot: Functions

OpenOffice.org has a tool called AutoPilot: Functions that can be used to insert

formulae very easily. The steps for launching the tool are as follows:

1) Position the cursor in the cell where you want to place the function.

2) Click on the AutoPilot: Functions button in the Function bar.

3) In the first AutoPilot: Functions dialog box, select the function you wish

to use and click on Next.
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Figure 7. First AutoPilot: Functions dialog box

In the Category field, you can specify all of the available functions or just those

from a certain category. In Function, select the function to use. A description

will appear on the right.

4) In the second AutoPilot: Functions dialog box, enter the formula.

Figure 8. Second AutoPilot: Functions dialog box

The second AutoPilot: Functions dialog box displays each element required

for the function. Click on a function field to view a description of the element.

You can type values directly in the function fields or click on the minimize

button to the right of each field. When you click on this button, you can se-

lect the cells from your spreadsheet. The selected cells will be automatically
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inserted in the formula when the window is restored. You can also insert a

formula inside an element of another formula. To do this, click on the fx but-

ton to the left of each field.

The Formula field displays the formula as you create it. You can also edit it

in this field.

The Function result field indicates whether the values you have entered are

valid.

5) Once you have completed the formula, click on the OK button.

AutoPilot: Functions is a very useful tool that can help us to learn how to use

the program's functions in a straightforward way.
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3. Creating graphs from data

One of the most eye-catching elements of spreadsheets are graphs used to

display results. OpenOffice.org offers many types of predefined charts that can

be used to create graphs in just a few clicks.

3.1. Creating a graph

This section will look at the steps required to create a graph with the AutoFor-

mat Chart tool.

1) Select the data to use for your spreadsheet graph. You can select numerical

data only but it is also possible to mark text, which OpenOffice.org will use

for the legend and even the title.

Figure 9. Data selected in a spreadsheet

2) In the Main toolbar, click and hold the mouse on the Insert Object button

until the Insert Object toolbar appears. Then click on Insert Chart.
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3) The mouse pointer will change into a cross with a bar chart in the bottom

right-hand corner. Click on the cells you selected previously to bring up the

AutoFormat Chart tool.

Figure 10. Selection of source data

4) In the Range field, enter the location of the data you are going to use to

draw the chart. If your selection was incorrect, click on the button at the end

of the text field to select the data again. You can also create titles for the graph

by marking the First row as label option, which turns the first row of selected

cells into the label content, or check First column as label to use these data

for the chart legend. Click on Next to continue.

Figure 11. Type of diagram selection

5) In the Chart Type selection dialog box, select the type of chart you wish

to use to represent the information. Note that not all charts can be used to

represent all types of tables of information. The Data series in option can be

used to specify the type of information displayed on the axes and the type

shown in the legend. To preview the result, you can mark Show text items in

preview. Click on Next to continue.
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Figure 12. Chart variant selection

6) The next window is used to select a variant of the type of chart selected.

You can also decide whether it should display different gridlines for each data

axis. Click on Next to continue.

Figure 13. Data representation

7) Finally, you can enter the title of the chart and any of its axes in the last di-

alog box. To display or hide a title, check or uncheck it according to your pref-

erences. Click on the Create button to insert the chart in the current spread-

sheet.
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Figure 14. Chart inserted in a spreadsheet

3.2. Modifying a chart

Although your first attempt may produce a perfect chart, more often than

not you will want to modify its appearance to adapt it to your expectations

after creating it. To modify a chart, simply double-click on it to display a new

toolbar that will replace the program's Main toolbar.

This toolbar is fairly straightforward to use. Simply hover the mouse over a

button to find out what it does.

Besides the features of this toolbar, we can also modify the format of the in-

dividual elements in the chart. To do this, simply double-click on the element

you wish to modify. This will bring up a dialog box with different tabs con-

taining the available customising options for the selected element. Not all el-

ements have the same customisation options. The possible tabs are now de-

scribed briefly.
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Figure 15. Data Series dialog box Lines tab

• The Lines�tab is used to select the line or border style, colour, width and

transparency of the selected object.

Figure 16. Data Series dialog box Range tab

• The Area�tab is used to select a colour, gradient, pattern or bitmap for

the area of the selected object. It is also possible to enter more options,

depending on the object.
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Figure 17. Data Series dialog box Transparency tab

• The Transparency�tab is used to define the transparency settings for the

options specified in the Area tab. The greater the transparency, the less

intense the colour, gradient, pattern or bitmap. It is also possible to specify

gradient options to modify the colour intensity gradually.

Figure 18. Data Series dialog box Characters tab

• The Characters�tab is used to customise the features of the source of the

selected element.
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Figure 19. Data Series dialog box Font Effects tab

• The Font Effects� tab is used to apply extra effects to the source of the

selected object.

Figure 20. Data Series dialog box Data Label tab

• The Data�Label�tab is used to add a value (such as a number or percentage)

and a label to the selected element.
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Figure 21. Data Series dialog box Statistics tab

• The Statistics�tab is only available for 2D charts and is used to display

statistical information on chart data such as variance, default deviation,

percentage deviation, maximal error and constant value.

Figure 22. Data Series dialog box Options tab

• The Options�tab is used to display a secondary Y axis and to enter the

distance between the data and the chart.

After creating your chart, you can modify the data you entered using the wiz-

ard you created it with. To do so, right-click the chart and select the AutoFor-

mat option from the context menu. To finish modifying, click on the Create

button.

You can also automatically change the type of chart you chose without going

through the wizard again by right-clicking the chart and selecting the Chart

Type option from the context menu.
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Figure 23. Changing Chart Type dialog box

In the Chart Type dialog box, you can quickly change the type of graph you

would like to use to represent the selected data.

To change the default graph colours, go to the Tools > Options > Chart >

Default Colors menu option, select each colour you wish to change and specify

a new one form the system colour palette.

Figure 24. Chart – Default Colors options dialog box.
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Summary

In this brief unit, we looked at the basics of how to use Open Calc by creating

a sample spreadsheet. This exercise allowed students to familiarise themselves

with the OpenOffice.org working environment for spreadsheets.

We also looked at the system used by the program to perform basic arithmeti-

cal operations and the possibilities of Open Calc's default formulae.

Lastly, we saw how to create charts using one of the program's many wizards.



Open Impress.
OpenOffice.org
presentations
 
David Megías Jiménez (coordinator)
Jordi Mas (coordinator)
Ana-Elena Guerrero Roldán (coordinator)
Jesús Corrius i Llavina
 
PID_00148477



GNUFDL • PID_00148477 Open Impress. OpenOffice.org presentations

Copyright © 2010, FUOC. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free
Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections,
no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled "GNU Free Documentation
License"



GNUFDL • PID_00148477 Open Impress. OpenOffice.org presentations

Index

 
Introduction............................................................................................... 5

 
1. Basic use of the program................................................................. 7

1.1. The working environment .......................................................... 7

1.2. Creating a sample presentation using AutoPilot ........................ 8

1.2.1. Creating the presentation ............................................. 8

1.2.2. Modifying the presentation ........................................... 12

1.2.3. Displaying the presentation .......................................... 16

 
2. Adding content to the presentation............................................. 17

2.1. Adding items of text ................................................................... 17

2.1.1. Defining editing options ............................................... 17

2.1.2. Creating a text frame .................................................... 18

2.1.3. Modifying text frame options ....................................... 19

2.1.4. Writing the text ............................................................. 21

2.2. Inserting graphics ........................................................................ 22

 
Summary...................................................................................................... 23





GNUFDL • PID_00148477 5 Open Impress. OpenOffice.org presentations

Introduction

OpenOffice.org comes with a component for presentations called Open Im-

press, which can be used to create professional presentations in the style of

Microsoft PowerPoint. Impress has the same drawing features as the Open

Draw component, which we will see in the next unit. Before getting down to

work with the program, we will run through some of its key features:

• Creating�presentations�from�other�sources. With the Open Impress Au-

toPilot, we can collect attributes, introduction pages, formats, presenta-

tion backgrounds and more from templates and examples.

• Different� formats. OpenOffice.org can import different document for-

mats such as PowerPoint and export presentations created in many others,

such as Macromedia Flash.

• Exporting�to�HTML�or�WebCast. The program can export presentations

and drawings created in HTML format, with or without frames. The ex-

ported documents can be run automatically or they can be used in web-

casts.

• Special�effects. Objects and animated texts, sounds and custom transi-

tions can be inserted in documents to enhance their appearance.

• Text�format. Impress offers the same text formatting capabilities as Writer.

The FontWork tool can also be used for the creation and advanced han-

dling of text effects.

• Custom�presentations. You can save different versions of a presentation

in a single document without losing or modifying the existing slides.

Notes can even be added to each one.

• Inserting�other�documents. One of the top features of Impress is the pos-

sibility of inserting other documents into a presentation. We can insert a

range of documents, from spreadsheets to graphics such as OLE objects,

which means that we can edit their contents even after they have been

embedded. We can also add a graphic either by inserting it or by using the

drawing functions of Open Draw, available in Open Impress.

The main aims of this unit are:

1) to explain how to use the AutoPilot feature to create presentations and

slides quickly with templates from the program, and
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2) to study the process of inserting graphics and texts in presentations to add

content.
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1. Basic use of the program

Open Impress can be launched from any OpenOffice.org application by se-

lecting the File > New > Presentation menu option.

Tips can be very useful for learning about the different features of the program.

Tips are displayed for each of the labels and buttons on the screen. You can

enable or disable this option using the Help > Tips menu option.

1.1. The working environment

As with the other applications, if you need help with a dialog box or window,

you can always click on the Help button or press F1.

Figure 1. The Impress working environment

We will now look at the different elements of the workspace in Open Impress:

Impress has five possible display modes and not all of the elements are avail-

able in each.

• The Menu�bar contains the various actions that can be carried out globally

across the OpenOffice.org program and those that are specific to Open

Impress.

• The Function�bar indicates the full path of the file being edited and pro-

vides a shortcut to the program's global features.
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• The Object�bar is used to apply formatting to the objects you are working

with at a given time. In Impress, it is almost identical to Open Draw and

gives the user access to the drawing functions.

• The workspace�view�buttons are located in the top right of the window,

just above the scroll bar, and are used to select the different modes avail-

able in Open Impress.

• The Presentation�menu is used to move through, edit and insert new

slides. To display this window, select the View > Toolbars > Presentation

main menu option.

• The Main�toolbar, positioned vertically down the left-hand side of the

document, gives quick access to the most common drawing functions and

3D and animation effects.

• The Status�bar, located at the bottom of the screen has a number of func-

tions, which include displaying the number of the slide being viewed and

the total number of slides in the presentation, applying page styles (by

right-clicking on Standard), changing the zoompercentage and changing

the default type of text selection.

• The tabs can be used for easy scrolling through the slides of a presentation.

• The Stylist is used to apply automatic styles and effects to program objects.

To show or hide the Stylist, press F11 or use the Format > Stylist menu

option.

• The Navigator is used to switch from one slide to another, insert new

slides etc. To display the Navigator, press F5 or click on the Navigator but-

ton in the Function bar.

1.2. Creating a sample presentation using AutoPilot

In this section, we will look at how to create presentations using the AutoPilot

Presentation tool. To do this, we will use a fictitious presentation to help us

to try and understand the basics of Open Impress.

1.2.1. Creating the presentation

In this section, we will discover the features of the AutoPilot tool by creating

a sample presentation. The selected options will determine whether the pro-

gram displays all of the dialog boxes described.
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1) In the OpenOffice.org main menu, select the File > AutoPilot > Presenta-

tion option, which will bring up the first AutoPilot dialog box.

Figure 2. First AutoPilot dialog box

In this dialog box, we can choose whether to create a blank presentation for a

presentation of our own or to create a presentation from a template. The third

option simply allows the user to open an existing presentation. If you select

the Template option, you will need to select a category followed by a name.

It is important to keep the Preview option checked to see how the template

we are creating is going to look.

2) For our example, we will select the Template option and Introducing a New

Product from the list of presentations. Click on Next.

In the second AutoPilot dialog box, we select a style for our presentation back-

ground. If using a template, we can select <Original> to use the template's

default background.

We can also tell the system how we are going to display the presentation. If

we are going to use a computer for this, we will need to select Screen. If we are

using a template, we can use the default option by checking Original. Howev-

er, in the more recent versions of OpenOffice.org, these settings generally do

not have a major impact on the presentation.
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Figure 3. Second AutoPilot dialog box

3) Select one of the options from the Select a slide design field. This will be

the background for your presentation. Click on Next.

Figure 4. Third AutoPilot dialog box

Unless we are advanced users of this program, it is very important in this

screen to mark the Preview option to view a live demo of the effects that we

can select from the Effect field. You can try them all out until you find an

effect you like although the descriptions are clear enough.

You can change slides manually but you can tell the program to do it for you

after a specified time interval.

4) From this list of effects, select Fly in From Left and in type of presentation,

select automatic with a 5-second duration of page. Once you have made your

selection, click on Next.
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Figure 5. Fourth AutoPilot dialog box

In the fourth window, we need to enter a description of the presentation. The

What is your name or the name of your company field will be positioned

below the main title of the presentation, which will be the text entered in the

What is the subject of your presentation? field.

In the Further ideas to be presented? field, you can type in the text that will

be used as a secondary point, below the presentation title.

5) Type in your name and the following product presentation. "Open Calcu-

lation Tutorial". In the Further ideas to be presented? field, type "Learning to

use AutoPilot to create presentations". Click on Next to continue.

Figure 6. Fifth AutoPilot dialog box
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Each template contains predefined slides. In this screen, you select the ones

you wish to use. If you are not sure at this point, you can come back to this

step later, since the program allows slides to be added or deleted at any time.

The result with the text entered in the previous screen is displayed on the

right-hand side of the window, so long as the Preview option is enabled.

If you do not want to use any of the predefined slides, simply unmark the list.

The text in each slide is displayed when it is collapsed using the arrow to the

left of its name.

You can automatically create a table of contents at the end of the presentation

by marking the Create summary option.

6) For our presentation, unmark the Customer Wishes slide and mark the Cre-

ate summary option. Then click on the Create button to display the presen-

tation.

1.2.2. Modifying the presentation

In this section, we will modify the presentation we created automatically in

the previous section, which only described the process of creating presenta-

tions. The steps that we will take to do this are:

1) Press the F5 key to open the Navigator and select the Next Steps of Action

slide. If the Navigator gets in your way when you are working, you can hide

it again by pressing the same key.

Figure 7. Navigator window

2) In the Next Steps of Action slide, type: "Study a lot", "Write up my notes"

and "Cram for my exam". Each of these texts needs to go on a different line.

Select the second and third lines and click on the Demote button in the Object

bar. You will see that the Object bar has changed now that you are inside an

item of text.
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3) We will now change some elements of the presentation's formatting. To do

this, go to the Format > Numbering/Bullets main menu option and select a

new bullet style. Then click on OK to exit this dialog box.

Figure 8. Numbering/Bullets Bullets tab

4) Select the last item of text in the slide and change the typeface. To do this,

right-click the selected text and select the Character option from the context

menu. Select a new font and click on the OK button.

Figure 9. Font tab in the Character formatting dialog box
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5) So far, we have seen how we can change the default format of elements of

a slide. We will now look at how to change format settings globally for the

whole presentation. Select the View > Master > Drawing option from the

main menu. Using the tools you are now familiar with, modify the title text

to make it smaller and change the colour to green. When you have finished

formatting, return to the previous screen using the View -> Slide menu option.

All of the slide titles in the presentation should have changed.

6) Position the cursor on a slide and right-click. In the context menu, select

the Slide > Insert Slide option. In the Insert Slide dialog box, enter the name

New Slide and select your preferred autolayout. Click on the OK button to

create the new slide and insert it in the presentation.

Figure 10. Insert Slide dialog box

7) Now, using the Navigator, go to the Strengths and Advantages slide and

change the layout from one column to two. For this, select the Format >

Modify layout main menu option, which will bring up the dialog box we saw

earlier when we inserted a new slide. Select a two-column design like Title, 2

text blocks and click on OK. This may bring up a warning dialog box.

8) In this step, we will create an effect for an element of a slide. To do this,

select the title of the current Strengths and Advantages slide and click on the

Animation Effects button on the Main toolbar. Select your chosen effect from

those available in the different categories and click on the green tick to apply

it to the selected item.
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Figure 11. Animation Effects dialog box

9) We will now look at how we can change the order in which slides are pre-

sented. To do this, click on the Slide View button in the workspace view but-

tons. You can drag any slide you wish to another part of the presentation. You

can also change the time and effects between one slide and the next using the

Object bar of this workspace.

10) In this step, we will save the presentation we created. To do so, go to the

main menu and select the File > Save option. The file Save As dialog box

will appear. In this dialog box, check that the Automatic file name extension

option is marked. Enter the name you wish to use to save the presentation

without adding an extension and click on Save.

Figure 12. File Save As dialog box
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1.2.3. Displaying the presentation

We can view the presentation we have created by clicking on the Start Slide

Show button of the workspace view buttons in the top right of the screen,

by pressing F9 or by selecting the Presentation > Presentation main menu

option.

We can quit the presentation by pressing ESC.
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2. Adding content to the presentation

One of the keys to working with presentations is the correct use of text, as

these are the items that will allow us to explain concepts and express our ideas

to our target audience.

2.1. Adding items of text

To add text to presentations created from scratch, the required steps are: to

define the editing options, create a text frame (if necessary) and, lastly, to write

the text.

2.1.1. Defining editing options

To define the editing options, go to the program's Option bar. To enable the

Option bar, select the View > Toolbars > Option Bar menu option. An option

is turned on if the corresponding button is recessed.

When you use Open Impress and Open Draw, you will probably find that

the best option is to mark only the option Double-click to edit text to avoid

confusion when working with other items.

The available options are as follows:

• The Allow�Quick�Editing option is used to edit a text simply by clicking

once on it. This option can make it difficult to interact with the other

elements of the slide. One of the things it does, for example, is that it

makes it much harder to select text frames.

• Select�Text�Area�Only is an option that, when enabled, tells the program

that we cannot click on a text to select the entire text frame and move

or delete it. To select a frame, we must first switch to text editing mode

by clicking or double-clicking on the text frame. It is best not to use this

option unless you very rarely use text frames.

• Double-click�to�edit�Text allows us to edit texts quickly by double-click-

ing on them with the mouse. With this option, we will never accidentally

select text when we actually wanted to work on other elements of the slide.

Now that we have seen all of the options available in the program, we need

to set our editing options. To make life easier, we generally recommend only

selecting the last option and turning the other two off.
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2.1.2. Creating a text frame

Text frames are the spaces in which the slide text is inserted and which let

us know its position inside the composition. OpenOffice.org can create hori-

zontal and vertical text frames. To turn on vertical text, choose the Tools >

Options > Language Settings > Language main menu option and check the

Enabled option in the Asian languages support section.

Figure 13. Language settings dialog box

We do not generally recommend creating your own text frames for presenta-

tions because the slides or templates you use already come with their own text

frames. There is a very simple reason for this. It is much quicker and easier

to create professional presentations using predefined text frames than it is to

create text frames with the program's tools.

This is because the templates and slides contain a wide range of formatting

options that would take a long time to reproduce. Another feature of templates

is that the text frames are visible even when they have no text inside, which

is not the case when we create new text frames with the text tools.

The items needed to work with text frames are located in the Text button of

the Main toolbar, to the left of the workspace. When you click and hold the

left mouse button on the text button, the Text items bar will appear.

Figure 14. Text items bar

The three buttons on the text items bar are as follows:
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• The Text button creates a text frame, which is very useful when we want

to control text wrapping in the frame, such as when we want to define a

specific line size. This will generally be the tool to use for creating most

text frames in presentation slides.

• The Fit�Text� to�Frame tool can be useful in small text frames or if we

want to quickly and roughly define the size of the text in a frame. The text

adapts more or less to the size of the frame we draw. However, the lines

of text do not adjust to the frame. The text begins in the centre of the

frame and extends both left and right as you type, even spilling outside

the borders of the workspace.

• The Callouts button draws a line and a text frame at the same time. To use

this feature, click on the spot where you would like the line to begin and

drag it to the area where you want to enter the text. You can adjust the size

of the frame and double-click inside it to enter the text. By default, the

lines of text do not wrap to the frame but this can be changed by right-

clicking the text and selecting Text from the context menu, followed by

Fit width to text in the Text tab. We shall see this dialog box in a moment.

If you have enabled Asian languages support, these buttons will be duplicated

for horizontal and vertical text.

2.1.3. Modifying text frame options

The following procedure can be used to modify the options for any text frame,

regardless of whether you created it yourself or it came from a presentation or

slide template. These options also apply if you have inserted text in an object

by double-clicking on it. The steps required to modify these options are as

follows:

1) Go to Drawing View by clicking on the Drawing View button in the

workspace view buttons.

2) Select the text frame or object you wish to customise and choose the Format

> Text option from the application's main menu. This will bring up the Text

frame properties dialog box. After making the necessary changes, click on OK

and close the window.
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Figure 15. Text frame properties dialog box

We will now look at the configuration options in this dialog box:

• The Fit�width�to�text expands or narrows the text frame to adjust the

widest line of text to the text frame. If the width of the text changes, the

frame will adjust to fit while the number of lines of text will remain the

same.

• If you select the Fit�height�to�textoption, the text frame will be lengthened

or shortened to fit the highest text in the text frame. The frame will adjust

to changes in text height.

• The Fit�to�frame option adjusts the size of the text to fit the area of the

drawing or text object.

• The Adjust�to�contour option is related to the FontWork tool contour.

When this option is selected, the text disappears and only its outline is

visible.

• The Spacing�to�borders section is used to enter the distance required be-

tween the text and the selected object. Negative values can be used, which

will make the text spill out of the text frame.

• In the Text�anchorsection, you can indicate the position of the text in

the text frame. If you select the Full width option, the text will be scaled

to fill the entire object.
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2.1.4. Writing the text

This is clearly the most important part of creating the presentation because

this is where we write the ideas we want to get across. There are several ways

of entering text in OpenOffice.org, which we shall now look at in turn.

• The first is the most obvious option: we can type the text inside a text

frame by double-clicking on the frame to enter the contents of our pre-

sentation. Remember that the way we access the text inside the frame may

vary according to the editing options we defined.

• We can also add content by�inserting�a�file in the presentation. The con-

tents of this file will be automatically imported into a new frame. If you

import contents from a file in HTML format, links to web addresses will

continue to work in the presentation, which can be a bonus. To insert a

text file, click on the Insert File button that appears when you click and

hold on the Insert button of the program's Main toolbar. In the Insert File

dialog box, you can select the file you wish to insert. The Insert Text dialog

box will appear.

Figure 16. Insert Text dialog box

The selected file will appear in the Insert Text dialog box. You can check the

Link option here if you need to. When you create a link, you are only linking

the inserted file to the presentation; the file contents will be automatically

updated in the presentation every time this file is edited. On the downside,

problems will occur if you change the location of the file as the presentation

will no longer be able to display it. Therefore, be very cautious about linking

to remote websites, since you will need a permanent Internet connection to

access their contents.

• The pasting�text from another document option is usually quicker and

more satisfactory than importing a file. To paste text, simply position the

cursor inside the text frame and use the�Ctrl+V key combination or use

the Edit > Paste menu option. If you do this outside a text frame, the

program will create a new frame.
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• A less orthodox option is to write�text�inside�an�object.. Simply double-

click and start writing. The text will spill outside the borders of the object,

so you need to keep an eye on the size of the font. You can also right-click

the text and select the Text > Fit to frame option we looked at earlier.

2.2. Inserting graphics

We can insert empty graphics frames in presentation slides, which we can then

manually edit, or we can insert existing graphics files, which is the method

that we will describe here. The steps for inserting graphics from files are as

follows:

1) Click on the Insert Graphics button from the toolbar displayed when you

click and hold the Insert button of the program's Main toolbar. You can

also use the Insert > Graphics main menu option.

2) Select the file you wish to insert and click on Open.

If, on the other hand, you would like to insert a drawing in the current slide,

the steps are as follows:

1) Go to Drawing View by clicking on the Drawing View button in the

workspace view buttons.

2) Choose the Insert > Object > OLE Object main menu option.

Figure 17. Insert OLE object dialog box

3) In the OLE object dialog box, you can create a new object or you can create

one from an existing file. If you choose to create one from an existing file, the

contents of the selected file will be inserted in the current slide.
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Summary

In this introduction to Open Impress, we have seen how to create slides and

presentations quickly and easily using OpenOffice.org's program for the cre-

ation of presentations. We now know that these are available on the Internet

and that we can create our own.

We have also seen the procedure for adding content to presentations created

automatically. With what we have learnt in this unit, although merely an

introduction, we should now have a solid basis for creating a whole range of

presentations with this program.
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Introduction

Unlike Microsoft Office, the OpenOffice.org program has an excellent tool for

creating vector drawings and editing graphics called Open Draw. This program

is halfway between poorer programs like Paint and top-of-the-range applica-

tions like GIMP and Photoshop. Open Draw is easy to use and offers users

several advanced features. In this introductory section, we will describe its key

features, which include:

• Creation�and�formatting�of�a�wide�range�of�objects. Open Draw offers

the possibility of working with and formatting 2D and 3D graphics, lines,

text etc.

• Integration�with�other�applications. Open Draw's drawing features and

utilities can also be accessed from Open Writer, Open Calc and Open Im-

press, allowing us to use them directly in any OpenOffice.org document.

• Full�text�formatting. Just as the drawing tools are available in other com-

ponents of OpenOffice.org, most of the features of Open Writer can be

accessed from Open Draw. This means that we can use styles with the ob-

jects, lines and texts that we create.

• The�FontWork�utility We can use this to create stunning text effects, such

as curves and distortion.

• Inserting�files,�OLE�objects�and�graphics. We can insert a wide range

of file formats in Open Draw, as well as OLE objects such as charts and

spreadsheets.

• File�formats. Besides being able to import and export many graphics for-

mats, we can also export Open Draw and Open Impress documents to

HTML format. We can also export to the EPS and SVG formats, the latter

being an XML-based scalable vector graphics format.

• Creating�basic�objects If we don't want to complicate matters and just

want to do simple drawing operations, the standard polygons are very easy

to use.

• Special�effects. Special effects and filters can be applied to graphics created

with the program.
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• Colour. We can control all aspects of colour and apply different conver-

sions, such as greyscale or black and white. Certain colours in an image

can also be swapped for others.

The main aims of this unit are:

1) to familiarise students with the use of the key drawing functions of Open

Draw by creating a sample document, and

2) to describe the process of creating and formatting the most common draw-

ing objects.
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1. Basic use of the program

Open Draw can be launched from any OpenOffice.org application by selecting

the File > New > Drawing menu option.

Tips can be very useful for learning about the different features of the program.

Tips are displayed for each of the labels and buttons on the screen. You can

enable or disable this option using the Help > Tips menu option.

1.1. The working environment

As with the other applications, if you need help with a dialog box or window,

you can always click on the Help button or press F1.

Figure 1. The Open Draw working environment

We will now describe the diverse elements in the program's workspace:

• The Menu�bar contains the various actions that can be carried out globally

across the OpenOffice.org program and those that are specific to Open

Draw.
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• The Function�bar indicates the full path of the file being edited and pro-

vides a shortcut to the program's global features.

• The Object�bar is used to control object attributes. When we work with

different objects, the Object bar will change to display the attributes of

the selected object. For example, if we are using text tools, the Object bar

will display the text formatting tools.

• The horizontal�and�vertical�rulers indicate the dimensions of the page

and the objects on it. The units of measurement units of these rulers can

be changed very quickly by right-clicking on them.

• The Main�toolbar, positioned vertically down the left-hand side of the

document, gives users quick access to the most common functions. It can

be used to create and align objects, insert new objects and much more. To

display all of the features of the buttons on this bar with submenus, hold

down the mouse button as you click on them.

• The Options�bar can be used for accurate customising of the position of

text, lines and objects in the drawing, as well as some more advanced

options.

• The Color�bar is used to select the colour of an object as you would with

the Object bar but is more intuitive and much quicker.

• The Status�bar , located at the bottom of the screen has a number of func-

tions, which include displaying page numbers, applying page styles (by

right-clicking on Standard), changing the zoompercentage and changing

the default type of text selection.

We have just described the Open Draw workspace but the program has a sec-

ond workspace for working with graphics. In this workspace, the Object bar

can be used to make a number of changes to an image, such as adjusting

colours, converting it to black and white or rotating it.
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Figure 2. The Open Draw working environment for images

If you click on the magic wand button to the left of the Object bar, you will

access the program filters that can be applied to the image you are editing.

Another very useful Open Draw tool is the eyedropper, which can be used to

replace a colour in an image with another of your choice. To use this feature,

select the Tools > Eyedropper main menu option.

Figure 3. Eyedropper dialog box
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Once inside the Eyedropper dialog box, click on the Eyedropper button in the

top left of the dialog box, then click on the first colour you wish to replace and

enter the tolerance in this same dialog box. It is best to play it safe by starting

with a tolerance of 10% and working your way up if the results are not to your

satisfaction. In the Replace with field, select the colour you want to replace the

original one with. Finally, click on the Replace button to change the colour.

1.2. Creating a sample drawing

We will now create a sample drawing to discover the basic features of the

program and familiarise ourselves with its workspace. Follow the steps below

closely for this:

1) Launch OpenOffice.org and create a new drawing document by selecting

the File > New > Drawing option from the main menu. This will open a new

window with a blank drawing document.

2) In the program's status bar, double-click on the value indicated as the per-

centage of zoom. This will bring up the document scaling settings dialog box.

Enter a Variable scale of 90% here.

Figure 4. Document scaling settings dialog box

3) Click on the Rectangle button on the Main toolbar and hold down the

mouse button until the Rectangles bar appears. Click on the filled rectangle,

which is the normal Rectangle button. Draw a rectangle in the new document.

4) In the Object bar, change the colour of the border using the Line Color

drop-down menu. Use any colour for the new border.
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5) Return to the Object bar and select the Gradient option from the Area Style/

Filling drop-down menu and then select a gradient from the list of gradients

in the Area Style/Filling field.

6) Go to the program ruler and right-click on it. Make sure that the unit of

measurement is centimetres. If not, change it.

7) If the rectangle is not selected, do so and select the Edit > Duplicate main

menu option. Make a copy of the rectangle and place it 5 centimetres to the

left of the original.

Figure 5. Object duplicate dialog box

The main features of this dialog box are as follows:

• The Number�of�copies field is used to enter the exact number of copies

we wish to make.

• The Placement section allows us to indicate where we want to create the

new copy, defined as the distance from the top left of the original object.

• In the Enlargementsection, we can enter the enlargement factor to apply

to each subsequent copy.

• In the Colorssection, we can choose a start and end colour so that the

colour of the objects gradually changes from the first to the second.
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• When we click on the Values�from�Selection�button,the attributes of the

current object will be automatically entered in the dialog box fields.

8) Select one of the two rectangles you have created and right-click on it. In the

context menu, select the Position and Size option. In this dialog box, go to the

Position and Size tab and increase the size of the rectangle by 10%. Then go to

the Rotation tab and rotate the rectangle 45º on its bottom left-hand corner.

Figure 6. Rotation tab in the Position and Size dialog box

9) Enable the Stylist by pressing F11 or selecting the Format > Stylist menu

option. Select a rectangle and double-click on the Object without fill format.

The rectangle will change to the new style.
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Figure 7. Stylist showing the graphics styles

10)�In the Main toolbar, press the Connector button and connect the left-hand

side of the first rectangle to the right-hand side of the second one.

11)�We will now convert one of the two rectangles into a 3D rotational object.

To do this, right-click on the rectangle and select the Convert option from the

context menu, followed by To 3D rotation object.

12) We will now enter some text. Do not select anything and go to the Main

toolbar and click on the Text button. Click on the workspace and enter the

following text: "This is a text test". The text frame will grow to fit the text

inside it. To spread the text over more than one line, select it and right-click

to bring up the context menu. Choose the Text option from this menu and

unmark the Fit width to text option.
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Figure 8. Text frame properties dialog box

13) Click again on the Text button of the Main toolbar and create a text frame

in the document approximately 3 centimetres high by 5 centimetres across.

Position the cursor inside it and type: "We will now see how this text frame

behaves with line wrapping". When you drew the new text frame, the frame

was set at the specified horizontal measurement but automatically grows to

accommodate the new lines of text.

14) Select the text you have just typed, right-click on it and choose the Char-

acter option from the context menu. You can also access this dialog box from

the Format > Character main menu option. In this dialog box, select the Con-

ga font, size 12 points and colour blue.
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Figure 9. Character properties dialog box

15) We will now look at how to change the text using the Object bar. In this

bar, change the font to Bitstream Vera Sans size 23 points and colour red.

Right-click the text frame and select the FontWork option. Curve the selected

text using any button and then close the dialog box.

Figure 10. Fontwork dialog box

The top part of the window contains the buttons for curving text horizontally,

vertically and in a circle. If you cannot see all of the available buttons, use the

vertical scroll bar.
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The second row of buttons is used to align the text at all of the angles shown.

The third row of buttons can be used to select the direction of the text.

Other options in this tool are:

• The Orientation button, used to rotate the text horizontally to vertically

and vice versa

• The Distancefield, used to enter the distance between the text and the

line of curvature, if there is one.

• The Indentfield. If you chose to align the text to the left or right, you can

enter the distance from the end of the text to the corresponding end of

the line of the curve or object.

• The Contour button, used to indicate whether to display the contour line

next to the text.

• The Text�Contourbutton, used to give the selected text a contour.

• The Shadow�style�buttons are used to turn shadows on or off. We can

indicate the distance between the shadow and the text in these fields. We

can also select the colour of the shadow in the Shadow Color list.

16)�Double-click the rectangle you did not convert and enter the following

text: "We are writing a long text to explain another one of the program's fea-

tures". If the text is illegible because of the object's angle of rotation, go back

to the Position and Size option and change it.

17)� Right-click the rectangle and select the Text option from the context

menu. Then select the Fit to frame option. The text will be too small to read.

Return to the same dialog box and select Adjust to contour.

18) Move the 3D rectangle so that it covers part of the other rectangle. If it is

underneath the other rectangle, right-click it and select the Arrange > Bring

to Front option to position it on top of the other rectangle.

19)�Click on the Curve button in the Main toolbar and hold down the mouse

button until the Curves bar appears. Click on the Curve, Filled button and

draw a filled polygon. Double-click to stop drawing.

20) Go to the Edit Points button on the left of the Object bar. Click on it and

then select one of the object's handles. Drag the handles to change the shape

of the polygon.
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21) Draw a new rectangle with rounded corners that reaches the four page

margins. Go to the main menu and select the Format > Page option. Go to

the Page tab and select Landscape orientation. Click on OK.

Figure 11. Page tab of the Page Setup dialog box

22) You will see that the rectangle you have drawn has not changed to fit the

margins. To fit the rectangle to the page margins, you need to select the Fit

object to paper format option when changing the page orientation.

23) We will now deal with the topic of saving the graphics we have created.

Go to the main menu and select the File > Export option, leaving the two

export options selected.

Figure 12. File Export dialog box
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2. Creating drawings with basic objects

Open Draw can be used to draw basic shapes such as rectangles or ellipses very

quickly and easily. You simply need to select the corresponding option from

the Main toolbar.

The toolbar buttons do not always display the same image because they dis-

play the last tool you selected. This means that you do not always have to

drop down all of the available options in drop-down buttons.

2.1. Use of basic drawing tools

The easiest tools to use are the ones for drawing rectangles and ellipses. To use

these, simply select the contour or shape you wish to use from the drop-down

list and draw the object in your workspace.

You can also draw a rectangle and change its borders to round the corners.

The steps for doing this are as follows:

1) Select the object you wish to round.

2) Click on the Edit Points button on the left of the Object bar.

3) The text handles will change and one of these will increase in size. When

you click on the biggest handle, the mouse cursor turns into a hand and

you can drag the handle to round the edges symmetrically.

The tool for drawing an arch or filled segment is particularly complicated to

use, so we will look at the steps required to do this now:

1) Click on the Ellipse button in the Main toolbar and select the shape you

wish to draw.

2) Draw the circle or ellipse in the document.

3) When you release the mouse button, the radius will appear and the mouse

pointer will adopt the form of a cross. You now need to click on the shape

where you want to make the cross-section.

4) The program will draw this line and another, movable radius will now

appear, which you need to move to the point on the shape where you

want the next cross-section to be made. The shape you have created will



GNUFDL • PID_00148481 19 Open Draw. Drawing with OpenOffice.org

appear when you click. You can change the size to suit your needs using

the handles.

2.2. Applying attributes with the Object bar

When working with drawing objects, we can format selected objects very

quickly using the program's Object bar, which automatically adapts to our se-

lection.

Figure 13. Open Draw Object bar

The formatting options of the Object bar are as follows:

• Line�Style,�Line�Width and Line�Color can be used to indicate whether

we want to include a border with the selected object. If so, select one from

the line style field. The Line Width and Line Color lists can be used to

define the attributes of the line.

• In the Area�Style/Filling list, we can define the Invisible, Color, Gradient,

Hatching and Bitmap options. When one of these is selected, the previous

style will be removed. In the list to the right of this, you can choose from

the OpenOffice.org options for each of these categories. If the Color cat-

egory is selected, the program will display the same colours as the Color

bar, but with their names.

• The Shadow�style button simply enables or disables this object attribute.

2.3. Applying fill attributes with the Area dialog box

All of the options we have just seen can be customised with advanced settings

in the Area dialog box, which can be accessed from the following menu op-

tion: Format > Area, in the Area tab.

If we select the None option in this dialog box, no settings options will be

available because the selected object will not be filled.

However, if we choose one of the other options, we will see that the contents

of the dialog box change automatically.
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Figure 14. Area dialog box Color option

With the Color option selected, simply choose the colour from the program

palette that you wish to use. In previous units, we saw how to modify the

palette to add custom colours using Tools > Options...> OpenOffice.org>

Colors.

Figure 15. Area dialog box Gradients option

If you select the gradient option, you must then select the type of gradi-

ent you wish to use from the list. You can then select Automatic, whereby

OpenOffice.org creates the gradient automatically or, if you unmark this op-
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tion, you can enter the number of changes in colour tone you wish to ap-

ply. The more changes, the smoother the gradient. The maximum number of

changes is 256.

Figure 16. Area dialog box Hatching option

With the Hatching option, you need to select a style of hatching from the list

of options and indicate whether you want to use a background colour. If you

do not select a background colour, the background will be transparent.

Figure 17. Area dialog box Bitmap option
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The Bitmap screen and its options is rather more complicated than the others,

so we will split up our explanation into different sections:

• In the Sizesection, we can select the Original option to maintain the size

of the bitmap. If you wish to modify the size, unmark the Original option

and enter your width and height measurements for the bitmap. You can

also check the Relative option and enter the percentage of the height and

width of the bitmap you wish to use.

• In Position , you can change the spot where drawing of the bitmap begins.

This percentage relates to the bitmap rather than the object we want to

apply it to. If you select the Tile option, the bitmap will be repeated all

along the surface of the object. We can also select Autofit to adjust the size

of the bitmap to the size of the object.

• In the Offsetsection, we find the options to control where the bitmap is

applied or where bitmap tiling begins, working out from the centre of the

object.

The result of our selections is displayed in the top right of the screen.

This same dialog box can also be used to modify the shadow and transparency

options of objects from their respective tabs. We will now take a look at these.

Figure 18. Area dialog box Shadow tab

The Shadow tab is used to enable or disable shadows by selecting or unselect-

ing the Use shadow option. We can also select its position, the distance of

the shadow from the object, the colour and the transparency percentage we

would like it to have.
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Figure 19. Area dialog box Transparency tab

In the Transparency tab, we can select the mode of transparency we wish to

use. With linear transparency, we can control the level of transparency with

the percentage in the linear transparency field. Gradient transparency is also

controlled in the fields in the gradient transparency section.

For some transparency modes, we need to enter centre coordinates so that

the centre of the colour gradient can move along these coordinates. With less

than 50% it moves left and up while with over 50%, it moves right and down.

To enter the value of the colour gradient angle, type in a number from 0 to

360°.

If the gradient colour is to have a border, the size of this should be entered too.

In the last field of this tab, we need to enter a start and end value for the

intensity of the colour gradient. This value must be at least 0 percent.

2.4. Creating and formatting lines

Open Draw has different types of lines that we can use in our work. They

include simple lines, connectors and diverse types of curves, and different

attributes can be applied to each of these.

The steps for drawing a line are as follows:

1) Click on the Lines and Arrows button on the Main toolbar and hold down

the mouse button until the Lines bar appears. Click on the type of line

you wish to use.
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2) Draw the line and use the handles to adjust it if the result is not quite

what you had in mind.

If you would like to draw a line at an angle, select the button with the cross

image to draw lines at horizontal, vertical or 45º angles.

2.4.1. Applying attributes to lines using the Object bar

As always, the easiest and fastest way to apply attributes to a line is to use the

program's Object bar.

Figure 20. Open Draw Object bar

We will now look at its possibilities.

• In the Arrow�Style list, we can specify the desired shape of the ends of

the line.

• In Line we must select a style, such as Invisible or Continuous or any of

the patterns from the list.

• In the Line�Widthfield, we must enter the line width measurement. The

unit of size used will depend on the system of measurements selected in

OpenOffice.org.

• In Line�Color, we can specify the line colour using the list of colours in

the system palette.

2.4.2. Changing attributes in the Line dialog box

If, after drawing a line, you wish to modify its attributes to precise values,

you will need to go to the Line dialog box, which you can bring up using

the Line button on the Object bar. You can also bring up this dialog box by

right-clicking on the line you have drawn and selecting the Line option from

the context menu.
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Figure 21. Line attributes dialog box

In this dialog box, you can select the type of line, colour and width, besides

a range of other options:

• By choosing Center positions in the Arrow styles section, we will centre

the arrow or line beyond the end of the line, making it bigger than we

originally specified.

• If we select a value greater than 0% in the Transparency field, we will en-

able line transparency to the degree determined by the number we en-

tered.

• If we mark the Synchronize ends option, both ends of the line will look

the same.
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Summary

We have now seen the basics of OpenOffice.org's drawing tool and learnt how

to carry out basic drawing operations by creating a sample document.

We have also learned how to format and create the basic shapes offered by

the program. This unit has not covered text formatting and composition tools

because these topics were discussed in the previous units and the procedure

is exactly the same in this application.

Similarly, everything that we have seen here on drawing tools can be applied

to text documents and spreadsheets.




